Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Anet A8 Fin de carrera ok pero no hace que pare
#1
Exclamación 
Hola a todos, 

Lo primero, gracias por los diferentes aportes relacionados con la Anet A8, me han servido de mucha ayuda.
 
Acabo de instalar unas Ramp 1.4 y estoy teniendo problemas con los finales de carrera. En resumen: para eje "y" y "z" no funcionan. Utilizo los que NO tienen PBC, vamos, con 2 salidas solo.

Los he comprobado en Pronterface y todos estan correctos. En OPEN. Si hago un M119 con alguno pulsado la señal llega correcta y aparecen como TRIGGERED, por lo que aparentemente funcionan.

El del eje X funciona correctamente, pero para Z e Y no hay forma.

Los tengo configurados asi
#if DISABLED(ENDSTOPPULLUPS)
  // fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
  //#define ENDSTOPPULLUP_XMAX
  //#define ENDSTOPPULLUP_YMAX
  //#define ENDSTOPPULLUP_ZMAX
  //#define ENDSTOPPULLUP_XMIN
  //#define ENDSTOPPULLUP_YMIN
  //#define ENDSTOPPULLUP_ZMIN
  //#define ENDSTOPPULLUP_ZMIN_PROBE
#endif

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
const bool X_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool X_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_PROBE_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.


He probado a:

-intercambiar posiciones de los ENDSTOPS y sigue sin funcionar
-cambiar en marlin const bool Y_MIN_ENDSTOP_INVERTING = true false; // set to true to invert the logic of the endstop. Funciona pero mal; si esta abierto el eje Y no se puede desplazar hacia delante, mientras que si lo pulso si (cosa que me descoloca porque al estar en true no pasa de forma inversa)
-Cambiar en marlin el z_MIN_ENDSTOP_INVERTING = true false; // set to true to invert the logic of the endstop. Esto no hace nada.

Opinion:

Mi idea es que hay algo entre la comunicacion de los motores con los ENDSTOP que esta mal configurado, pero no consigo ver que es. He repasado el configuration.h y no encuentro posibles fallos. ¿Alguien tiene idea de que me puede estar pasando?

Gracias por vuestro tiempo
GR
Citar
#2
Hola, no pones como tienes configurados los finales de carrera a usar.
Está un poco más arriba de donde indicas:

//===========================================================================
//============================== Endstop Settings ===========================
//===========================================================================

// @section homing

// Specify here all the endstop connectors that are connected to any endstop or probe.
// Almost all printers will be using one per axis. Probes will use one or more of the
// extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
#define USE_XMIN_PLUG
#define USE_YMIN_PLUG  // Estos son los finales de carrera que tiene una A8
#define USE_ZMIN_PLUG

//#define USE_XMAX_PLUG
//#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG

// coarse Endstop Settings
//#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors

#if DISABLED(ENDSTOPPULLUPS)
 // fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
 //#define ENDSTOPPULLUP_XMAX
 //#define ENDSTOPPULLUP_YMAX
 //#define ENDSTOPPULLUP_ZMAX
 #define ENDSTOPPULLUP_XMIN
 #define ENDSTOPPULLUP_YMIN  // Si utilizas los interruptores normales de la A8 (de dos cables) con la RAMPS, tienes que habilitar las resistencias internas de PullUp.
 #define ENDSTOPPULLUP_ZMIN^

 //#define ENDSTOPPULLUP_ZMIN_PROBE
#endif

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
#define X_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.
#define Y_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.             // Para los interruptores de la A8 (NO) tienen que estar a true.
#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.

#define X_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Y_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Z_MAX_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.
#define Z_MIN_PROBE_ENDSTOP_INVERTING false // set to true to invert the logic of the probe.

// Enable this feature if all enabled endstop pins are interrupt-capable.
// This will remove the need to poll the interrupt pins, saving many CPU cycles.
//#define ENDSTOP_INTERRUPTS_FEATURE


Configurado como he puesto, tendría que funcionar correctamente.
Doy por sentado que no tienes un sensor instalado.
Por otra parte, los dos cables de los interruptores de la A8 van conectados a los pines S y - de la RAMPS (no importa cual va en cual).
Saludos.
Citar
#3
Gracias!

Era eso, tal cual. Por el camino descubrí que tenía algunas otras cosas mal configuradas también.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA marlin compila bien pero no lo sube a la placa edus2846 5 99 Ayer, 09:46 PM
Último mensaje: Shellmer
  CONSULTA Anet a8 sube temperatura extruder pero luego se baja. JIMLAHEY 1 148 08-10-2018, 08:42 PM
Último mensaje: jagmeister
  pantalla anet 6 para la Anet 8 Nestor 12 3,891 12-04-2018, 08:35 PM
Último mensaje: Josnaro
Pregunta Problema con la activación del fin de carrera tras modificar mi Anet A6 br0nka 1 271 31-03-2018, 04:12 PM
Último mensaje: br0nka
  APORTE Finales de carrera siempre “On” (Editado bis). Simemart 19 1,362 24-11-2017, 02:54 PM
Último mensaje: Simemart