Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
APORTE Problemas conexión Arduino IDE placa MKS GEN [SOLUCIONADO]
#1
Escribo esto por si a alguien le sirve.
Tengo una placa MKS GEN con pantalla TFT 3,2 de MKS también. El tema está en que he tenido varios problemas de conexión entre la placa y el ordenador con Arduino IDE. Creo que he dado con la solución, probando y probando me dió por desconectar la pantalla y reiniciar el Arduino IDE y wala!! Programa subido sin ningún tipo de error. Espero que a alguno le valga para algo esta tontería.


Enviado desde mi iPhone utilizando Tapatalk
Citar
#2
Ya no tiene que ver con la placa pero hay tres detalles que a mi me han ocurrido al subir firmwares a un arduino.
1 - El antivirus a veces afecta, antivirus como Avast tienen la manía de meterse donde no les llaman y enlentecer o incluso bloquear totalmente la compilación o envío de un sketch. Si no das subido un programa, desactiva el antivirus 10 minutos y prueba otra vez.
2 - Ejecutar el Arduino IDE en modo administrador. Aunque parezca mentira, a veces no le da la gana de funcionar al IDE sin privilegios administrativos, lo peor de todo es que como fallo simplemente dice "No se ha podido subir el sketch", y ni habilitando el modo debug de compilación o subida del .hex sale el motivo... simplemente no lo sube y punto.
3 - Si nada de esto funciona... comprobar si hemos conectado algo a los pines 0 o 1, a mi me ocurrio una vez que se me ocurrio la genial idea de conectar un sensor de filamento que me hice al puerto D0. El resultado fué que esa linea se mantenia a 0v todo el rato, imposibilitando la comunicación con el PC. Los puertos D0 y D1 son los puertos del puerto serie del arduino y están conectados al conversor USB-TTL que llevan las placas integradas.
Citar
#3
(29-01-2018, 07:16 PM)Shellmer escribió: Ya no tiene que ver con la placa pero hay tres detalles que a mi me han ocurrido al subir firmwares a un arduino.
1 - El antivirus a veces afecta, antivirus como Avast tienen la manía de meterse donde no les llaman y enlentecer o incluso bloquear totalmente la compilación o envío de un sketch. Si no das subido un programa, desactiva el antivirus 10 minutos y prueba otra vez.
2 - Ejecutar el Arduino IDE en modo administrador. Aunque parezca mentira, a veces no le da la gana de funcionar al IDE sin privilegios administrativos, lo peor de todo es que como fallo simplemente dice "No se ha podido subir el sketch", y ni habilitando el modo debug de compilación o subida del .hex sale el motivo... simplemente no lo sube y punto.
3 - Si nada de esto funciona... comprobar si hemos conectado algo a los pines 0 o 1, a mi me ocurrio una vez que se me ocurrio la genial idea de conectar un sensor de filamento que me hice al puerto D0. El resultado fué que esa linea se mantenia a 0v todo el rato, imposibilitando la comunicación con el PC. Los puertos D0 y D1 son los puertos del puerto serie del arduino y están conectados al conversor USB-TTL que llevan las placas integradas.


A mí lo de administrador nada, uso Ubuntu y arranco como admin siempre. A mí de momento la pantalla macho. Mira que tontería


Enviado desde mi iPhone utilizando Tapatalk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  (SOLUCIONADO) conexion nema 17 en serie y paralelo Jmaster03 12 694 21-08-2018, 10:41 AM
Último mensaje: Comediaan
  ¿Me he cargado la placa de la impresora? Penitas 2 282 03-06-2018, 11:33 PM
Último mensaje: Penitas
  Configuracion mixta de drivers en la misma placa ? Dragons 0 182 03-06-2018, 06:05 PM
Último mensaje: Dragons
  Duda placa MKS-BASE V1.5 o v1.4 gen Mummra 1 618 31-03-2018, 11:16 PM
Último mensaje: dvera16
  [SOLUCIONADO] Bloqueo impresora ¿Exceso de carga para la fuente? dvera16 8 656 23-03-2018, 03:22 PM
Último mensaje: dvera16