Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
A vueltas con TTL y PWM
#1
Hola a todos!
Me he montado un cnc laser con perfilería y piezas propias, motores, etc.... pero el problema viene a la hora de gestionar el láser.
Como no me quería volver loco configurando arduinos compré una placa EleksMaker Mana SE que está hecha para tal fin.

resim


Como láser cogí este:

https://www.banggood.com/450nm-3500mW-3_...rehouse=CN


resim

Es un laser por TTL, pero.... la Mana SE emite señal en PWM, así que me compré un conversor PWM-TTL, concretamente este:

https://www.banggood.com/EleksMaker-PWM-...rehouse=CN

resim


Bien, pues tras conectarlo todo como creo que hay que contectarlo.... no chuta.
Si le meto alimentación directamente al conversor PWM-TTL la Mana SE empieza a echar humo.... (menos mal que estuve rápido), el láser si lo alimento directamente enciende, pero no puedo controlarlo con el propio soft de Eleksmaker.....
He probado mil combinaciones.... pero nada, no hay manera de hacer encender/apagar el laser con el software de Eleksmaker para esa placa...

Alguien puede echarme un cable? (nunca mejor dicho).
Citar
#2
Curiosidad tengo...
Puedes mandar foto de como lo conectase ?
Por que he leido la info y lo de 1,2 3 y 4 ... en la placa no están señalados.
Te vino algún documento o algo con la placa ?
Ubuntizando...
Citar
#3
Ni con la placa, ni con el láser ni con el conversor PWM-TTL me ha venido ningún tipo de manual.
Ahora lo tengo todo desconectado porque ya no sé la de pruebas diferentes que he hecho, pero según me da a mi el sentido común (que lo mas sencillo es que esté MUY equivocado) es que de el cable de tres conectores S - + que saca la señal PWM de la Mana SE tenía un cable que iba al INPUT de PWM del conversor PWM-TTL, luego, del conector rojo del conversor PWM-TTL saco un cable que va a la entrada de corriente del laser y de la salida S - del conversor va a la entrada TTL + - del láser.....
Citar
#4
Tengo una situación similar, con ese mismo láser.
En mi caso, lo estoy conectado a la CNCboard, que tiene salida PWM, y el encendido/apagado funciona perfectamente.

Has probado con otro soft¿? por lo que tengo entendido, el Gcode de encendido/apagado puede variar entre S0 y S5 (si mal no recuerdo, ojo.).

Trasteo cuando tengo un ratillo con este asunto, pero me quedo por aquí a ver si damos con la tecla del problema.
Citar
#5
(28-01-2019, 07:45 PM)jukillo escribió: Tengo una situación similar, con ese mismo láser.
En mi caso, lo estoy conectado a la CNCboard, que tiene salida PWM, y el encendido/apagado funciona perfectamente.

Has probado con otro soft¿? por lo que tengo entendido, el Gcode de encendido/apagado puede variar entre S0 y S5 (si mal no recuerdo, ojo.).

Trasteo cuando tengo un ratillo con este asunto, pero me quedo por aquí a ver si damos con la tecla del problema.

Si, he probado con un par de softwares mas y nada de nada... pero claro, sin saber si los cables están bien conectados es como dar palos de ciego....

A ver si entre todos lo sacamos.
Citar
#6
Yo me pondría en contacto con EleksMaker y te aclaren...
Ubuntizando...
Citar
#7
(30-01-2019, 04:06 PM)BlackBit escribió: Yo me pondría en contacto con EleksMaker y te aclaren...

Ya lo hice.... y aún estoy esperando respuesta.....
Citar
#8
He encontrado esto...

https://github.com/openfab-lab/toolsDocs/issues/13

Yo no entiendo mucho ingles, pero si tienes un rato echale un ojo.
Igual te aclaran algo...
Ubuntizando...
Citar
#9
(30-01-2019, 04:49 PM)BlackBit escribió: He encontrado esto...

https://github.com/openfab-lab/toolsDocs/issues/13

Yo no entiendo mucho ingles, pero si tienes un rato echale un ojo.
Igual te aclaran algo...

Sí, ese foro ya lo visité días atrás pero tampoco solucionan nada....
He pedido por si acaso un láser con entrada PWM para poder conectarlo directamente a la placa Mana SE y así por lo menos sacar un curro que me han encargado y así mientras tanto ir investigando.....
Citar
#10
Vale, me acaba de llegar el laser con entrada PWM para conectarlo directamente desde la placa ManaSE al láser... pues no chuta, ni puto caso, le doy a "laser ON" y el laser no se enciende. Y el laser funciona, si lo alimento con 12V con el transformador que trae se enciende sin problemas, pero a través de la placa tururú. Creo que me la cargué el otro día probando con el otro laser y el conversor PWM/TTL.
A pedir placa nueva toca, para descartar, como así ya no funcione.... ya no sé que hacer.
Citar
#11
No entiendo lo de si alimento con 12V funciona correctamente.

Una señal de PWM no es de potencia, el driver tiene que tener 2 entradas, una para el PWM y otra para la alimentación. Estas conectando las dos cosas? Pon alguna foto y explica eso de los 12 y funciona.

Puedes medir si va bien la salida de PWM con un polimetro. Por ejemplo, pon un valor bajo, medio y alto al parámetro que controle la salida PWM (en grbl parametro Sxxx) y mide. Para bajo, te tiene que salir 0 o cercano a 0, para medio entorno a 2,5v y para alto si pones lo máximo serían 5v.

Saludos
Citar
#12
(08-02-2019, 04:11 PM)grafisoft escribió: No entiendo lo de si alimento con 12V funciona correctamente.

Una señal de PWM no es de potencia, el driver tiene que tener 2 entradas, una para el PWM y otra para la alimentación. Estas conectando las dos cosas? Pon alguna foto y explica eso de los 12 y funciona.

Puedes medir si va bien la salida de PWM con un polimetro. Por ejemplo, pon un valor bajo, medio y alto al parámetro que controle la salida PWM (en grbl parametro Sxxx) y mide. Para bajo, te tiene que salir 0 o cercano a 0, para medio entorno a 2,5v y para alto si pones lo máximo serían 5v.

Saludos

No, el láser solo lleva una entrada de tres cables, PWM, positivo y negativo y de la placa sale lo mismo.....
Con el láser viene un cable para que lo conectes a esa entrada triple con un adaptador de conexión para meterle directamente un transformador 220V-12V que viene incluído (como el de los portátiles) y así puedas probar si funciona o no.

Luego cuando vaya donde está el láser hago fotos.
Citar
#13
Estas son las conexiones del láser

resim

Y este es el cable que permite alimentar el láser con 12V y meterle señal de PWM desde la placa, he probado a alimentar con la placa con los 3 cables (PWM, +, -) y nada, el láser no hace ni puto caso a los comandos que le mando desde el software.... solo enciende si le alimento con 12V, pero entonces ni enciende ni apaga, está siempre encendido

resim
Citar
#14
No conozco el driver ese. No tienes nada de documentación del driver?

Lo que se me ocurre es que para trastear desconectes (desoldar) los cables del diodo laser y le conectes diodos led blancos de 1W en paralelo. NO se de que potencia sera tu diodo, asi que ponle tastos leds en paralelo como sea la potencia del diodo laser. Asi podras hacer pruebas sin cargarte el laser.

Saludos
Citar
#15
(13-02-2019, 07:55 PM)grafisoft escribió: No conozco el driver ese. No tienes nada de documentación del driver?

Lo que se me ocurre es que para trastear desconectes (desoldar) los cables del diodo laser y le conectes diodos led blancos de 1W en paralelo. NO se de que potencia sera tu diodo, asi que ponle tastos leds en paralelo como sea la potencia del diodo laser. Asi podras hacer pruebas sin cargarte el laser.

Saludos

No, la verdad es que no, no tengo documentación de ese driver.....

De lo otro que comentas de desoldar, diodo láser y tal.... ni puta idea....
Citar
#16
Puesdes dejar enlace de donde lo compraste ?
Ubuntizando...
Citar
#17
(18-02-2019, 05:06 PM)BlackBit escribió: Puesdes dejar enlace de donde lo compraste ?


Sí, mira, esta es la placa

https://www.banggood.com/2-Axis-Stepper-...rehouse=CN

Y este el láser

https://www.banggood.com/EleksMaker-FB03...rehouse=CN


También anteriormente compré este láser

https://www.banggood.com/450nm-3500mW-3_...ds=myorder


Y este conversor PWM/TTL

https://www.banggood.com/EleksMaker-PWM-...rehouse=CN
Citar
#18
Yo estoy esperando un conversor de esos... cuando llegue y haga pruebas te comento, ;D
Citar
#19
Dentro de mi ignorancia, pero cre oque al menos deberías coenctar el gnd del cable rojo quje va al laser. Si tienes alimentado el laser, pero no tiene masa en la que va a la placa de control. Te lo digo porque le puse una arduino mega a un laser de co2 que tenía muerto de risa por la controladora, que perdía un montón de pasos, y hasta que no conecté los 5v de la arduino al driver no se movía. No le vale solo con los 5v de un transformador, sino que tienen que salir de la misma placa donde está conectado el pv y dr del driver. Al menos así me ha funcionado a mi.

Saludos
Citar
#20
Pues ya ha aparecido el peine.
Hoy me ha llegado la nueva placa Mana SE, ha sido conectarlo todo y funcionar a la primera....

cuando he desmontado la vieja me he dado cuenta de donde estaba el problema....

resim


Ahora a ver si encuentro recambio sólo de eso y así tengo dos placas.....
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Triste A vueltas con el jodido laser Forsito 3 361 17-04-2019, 08:07 PM
Último mensaje: Forsito