This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Ender 3 pro Problema primeras capas mas bajas
#1
Hola.

Acabo de empezar hace un mes con este asunto de las impresoras 3D con una Ender 3 pro y todo iba perfecto. Sólo he tenido problemas con la cama magnética que después de la primera semana de uso estaba totalmente deformada. Cristal y muelles duros mano de santo...

Pero ahora tengo otro problema y no encuentro solución:
Tengo la cama perfectamente nivelada y los pasos/mm de cada motor bien ajustado. El margen de error en las medidas es mínimo mínimo... excepto en piezas con altura de menos de 2cm (ese es el problema)
Todo viene por el efecto de pata de elefante. Siempre me salen las primeras capas ensanchadas y no sabía porque hasta ayer. Le ponga mucha separación del cabezal a la cama o poca no cambia nada. Tampoco cambia jugando con las temperaturas ni con el flujo. Me estaba volviendo loco hasta ayer que descubrí el porqué (pero no encuentro solución). Resulta que al intentar recalibrar los pasos/mm del eje Z por enésima vez, encontré una forma de colocar el calibre digital de modo que es 100% sencillo y fiable tomar mediciones y me di cuenta de lo siguiente:
El eje Z sube casi exactamente lo que le pido con sólo un margen de error mas o menos de +-0.02mm, PEEEEEROOOO.... el primer centímetro (es decir, estando en la posición 0 al subir 10mm) no sube 10mm sino 9.85mm. De ahí en adelante si sube lo que corresponde. Resumiendo: posición abajo del todo, subo 10mm y sube 9.85mm, subo otros 10mm y sube a 19.85, subo otros 10 y va a 29.85, 39.85... Conforme se va acercando a 80mm si va acercándose a la medida real de la pieza porque es la medida con la que ajusté los pasos/mm.
Para verlo mejor lo que hice fué subir de 10 en 10mm y poner a cero cada vez el calibre, osea, subir 10, ver medición y poner a 0, subir, ver y poner a 0, subir... Entonces claramente se ve que la primera medición es de 9.85mm y el resto de 10.
Para precisar mas pasé a movimientos de 1mm. Estando en 0 abajo del todo subo 1mm y el calibre me dice que ha subido solo 0.85, subo otro mm y ya si me dice que ha subido 1. A partir de aquí bien ya. Para mas precisión paso a saltos de 0.1mm. Y el resultado es que en los 3 primeros saltos me dice que sube menos (no recuerdo la cifra, repetiré las medidas). Al cuarto creo recordar ya medía 0.1mm (era ya tarde y acabé rápido para irme a la cama ?)

Entonces esas primeras capas están prensadas y es lo que explica la pata de elefante y la falta de altura de la pieza.
Estos días he impreso 7 piezas de 10mm que deben ir apiladas para dar sobre 70mm y mide casi 2mm menos dando lugar a holguras.

Pensaba que iba a ser por algún problema mecánico, como por ejemplo que el husillo estuviese mal justo en esa zona, los perfiles, rodamientos, pero no, debe ser algo de configuración o software. Si muevo el final de carrera mas arriba para evitar esa zona se traslada el problema, ese primer milímetro, pongas el home donde lo pongas "mide menos".

Da la impresión se que eso sea apropósito para asegurar la adhesión a la cama, pero en ese caso perjudica mas que ayuda, con el cristal y la laca se pega a veces incluso demasiado.

En los menús de la ender no hay ninguna opción relacionada con ese aspecto. No se si podrán estar relacionados los babystep Z, pero solo aparece la opción al iniciar impresión. Otra cosa sería meter comandos gcode a mano para contrarrestar el efecto si es que los hay.

A ver si me podéis ayudar porque se está forma no me sirve la impresora para piezas de precisión, si calibro el Z por ejemplo con un cubo de 2 cm las piezas pequeñas me salen bien, pero las grandes me salen mas altas. Y si calibro con medidas mas grandes, las piezas grandes salen bien pero las pequeñas salen mas bajas (que es lo que me pasa ahora). Y realmente en cualquier caso la calibración no es buena porque como dije, ese primer milímetro siempre "mide menos".

Así es como imprimo:
PLA 200°
cama 40°
boquilla 0.4
altura capa 0.2

Espero que m podáis ayudar y perdón por semejante rollo... ?
  Responder
#2
Voy a resumir que me he enrollado mucho:

El eje Z sube desde el milímetro 0 al 1 menos de lo que debe (0.85mm en lugar de 1) provocando efecto pata de elefante y que la pieza sea mas baja de lo que tiene que ser. Del milímetro 1 en adelante se mueve con normalidad. No es problema mecánico.
  Responder
#3
Hola @Mazaias, bienvenido al foro.
Antes de pasar al problema concreto, decir que esa forma de calibrar los micropasos por milímetro del eje Z no es muy precisa, aunque pueda parecer lo contrario.
Y eso, aunque el calibre digital sea de los buenos (un Mitutoyo de doscientos euros). Si es uno de esos baratos que abundan por Internet, ya ni hablamos.
La forma más precisa de hacer esa regulación y que da el mejor resultado en la práctica, es poner los valores teóricos y después ajustar en función de los resultados.
Respecto al problema concreto que estás teniendo, no tiene mucho sentido lo que indicas: si ese primer milímetro lo hace menor, así tendrá que ser para piezas grandes como para pequeñas. Tanto unas como otras tendrán la misma falta de medida y no podrías ajustar nada para que unas salgan bien y las otras no.
Es decir, si haces un cubo de 20 milimetros, tendrá 19,85mm y uno de 80mm, tendrá 79,85mm. En ambos el mismo efecto "pata de elefante" y la misma falta de 0,15mm en la altura.
Si no es así y cambia en función de la altura final, es que no se tiene configurado el valor correcto de los micropasos por milímetro, con lo que el error es proporcional a la distancia recorrida.
La única explicación para un comportamiento como el que indicas en el movimiento del eje, es un problema mecánico: bien que el husillo sea defectuoso o que el motor pierda pasos. Para el firmware todos los movimientos son exactamente iguales, independientemente de la posición del eje en que se hagan.
Otra cosa es el resultado de la impresión. Eso ya depende de la regulación del punto Z=0 (home de Z) y de la configuración de varios parámetros del programa de corte, no solo de los de movimiento.
Las medidas en el eje Z siempre son problemáticas y para saber la altura teórica que tendrá la pieza (la real depende también de la expansión del material, a su vez relacionada con su tipo, la temperatura de impresión y la ventilación de capa), hay que tener en cuenta los factores indicados: la regulación de la separación de la boquilla en el punto Z=0 (home de Z), la altura de capa inicial configurada en el programa de corte y la altura de capa normal.
Si la impresora tiene bien calibrados los micropasos por milímetro, para que la medida de altura de una pieza sea la teórica del diseño, hay que jugar con todos ellos.
La regulación del Z=0 se suele realizar con la hoja de papel de 80gr/m², que tiene un grosor de 0,1mm. Se hace así, más que nada, porque se ha demostrado con la práctica que es una distancia apropiada y por la precisión que se consigue, a pesar de la sencillez del método.
La altura de capa inicial conviene ponerla de forma que, sumada a la regulación anterior, nos de la altura de capa normal que utilizaremos. Es decir, la capa normal menos 0,1mm. Así nos aseguramos de que todas las capas sean iguales.
La altura de capa normal hay que elegirla con cuidado, pues los programas de corte no realizan fracciones de capa por lo que, si no la elegimos bien, no obtendremos la altura correcta de la pieza.
Se verá mejor con un ejemplo: supongamos que queremos hacer el cubo de calibración de 20mm. Si tenemos regulada la impresora con la hoja de papel (0,1mm) y pensamos configurar las capas normales de 0,3mm, configuramos la capa inicial de 0,2mm, con lo que todas se imprimirán con la boquilla a 0,3mm de la superficie de impresión.
El programa corta la pieza y le salen 67 capas, la primera de 0,2mm y 66 más de 0,3mm, lo que equivale a: 66*0,3+0,2=20mm que tiene la pieza. El program de corte se queda muy satisfecho, pero nosotros obtenemos una pieza de 20,1mm, porque la primera capa realmente tiene 0,3mm (0,2mm+0,1mm de la hoja) y no 0,2mm como hemos configurado.
En teoría, con cualquier combinación de 0,2 o 0,3 para las capas, es imposible imprimir el cubo de 20mm: la única forma sería con capa inicial de 0,15mm y capa normal de 0,25mm.
Naturalmente, en la práctica hay más factores que influyen (como ya he dicho) y es difícil cumplir con la teoría.
Lo normal es tener más o menos ajustada la impresora para un margen de tamaños de pieza razonables, lo que limita las desviaciones que se producen de forma teórica.
En todo caso, no es mala idea diseñar con todo esto en mente (si podemos elegir las medidas que queramos dentro de un cierto margen, claro).
Resumiendo, si tienes ese error en el movimiento del eje, su causa solo puede ser mecánica. Si es en los resultados de la impresión y los micropasos por milímetro están bien configurados, entonces el problema es la configuración del programa de corte.

P.S.: Creo que yo también me he enrollado un poco.
  Responder
#4
Lo primero: Gracias por dar un mensaje tan detallado y mostrar las pruebas que has hecho. Eso ya demuestra tu interés y nos da más ganas de ayudar.

Que yo sepa los pasos por mm del eje Z no se hacen por regla de tres (como en X o Y), sino que va por una fórmula:
pasos_por_mm = (pasos_por_vuelta_del_motor * micropasos_del_driver_del_motor) / paso_varilla

pasos_por_vuelta_del_motor : en los NEMA 17 son 200
micropasos_del_driver: No sé en la Ender, pero suele ser 32 ó 16
paso_varilla: En este caso husillo, yo no lo sé.

yo creo puede ser dos cosas:
- pasos por mm mal configurado en eje Z: No lo es, en piezas altas terminaría imprimiendo en el aire (porque el eje sube más de lo que debe), o bien sube menos en cada capa y el fusor termina rozando la pieza y moviéndola.

- fallo mecánico: lo más probable, al iniciar el movimiento le cuesta mover el eje Z, por eso sube menos de lo que debe (dando igual si está abajo o arriba). Yo revisaría ese eje.

Si crees que es de software, instala RepetierHost y filetea con Slicer, en el fichero gcode te añade todos los parámetros de impresión usados. Pásanos también el cubo ese que sale mal, el fichero gcode (comprimido en zip o rar para subirlo al foro) dentro del fichero podemos ver si en las primeras capas ordena subir menos de lo normal. Pero desde ya te digo que no creo sea el problema.

En RepetierHost y slicer, si solo cambias lo básico:
- tamaño de cama
- tamaño de boquilla del fusor
- grosor de filamento
- grosor de primera capa a 0.2
- grosor del resto de capas a lo que quieras

No hay nada de configuración que modifique la altura a subir en Z, por lo que puedes comparar con tu fileteador.

Hay muchos programas más con lo que puedes probar: IdeaMaker, Craftware, etc. Quédate con el que más te guste, no te quedes con CURA ó RepetierHost por ser los más conocidos.
Ulticampy V2: fundiendo plástico sin descanso...
  Responder
#5
Jajaja también te has enrrollado, si. Pero es una respuesta muy útil y estoy de acuerdo en todo.

A ver si no me dejo nada en mi respuesta:

Punto 1. Efectivamente, esa falta de altura de 0.15mm ocurre en todas las piezas (grandes y pequeñas) si por ejemplo muevo el Z 10 cm, mido el desplazamiento real y hago la regla de 3 para sacar los pasos/mm como hago ahora. Así se que tengo siempre un error de -0.15mm.
La distinción que he hecho antes de grandes y pequeñas es porque antes imprima una pieza y calibraba en función de las medidas de la pieza. Entonces si hacía un cubo de 2 cm y calibraba con las medidas que daba obviamente al volver a imprimir el cubo lo sacaba con 20mm clavados porque contraresta esa perdida de 0.15mm, pero al imprimir una pieza de 10 cm la cosa se va de madre y sale mas grande. Si calibraba con una pieza de 8 cm pues las piezas de medidas parecidas salen bien y las pequeñas (o mas grandes) ya se va acumulando error. No se si me explico.
Al descubrir ese error en el primer milímetro siempre no vale calibrar midiendo piezas impresas ya que siempre cuentan con ese error de 0.15mm. Solo vale la calibración midiendo el desplazamiento del eje pero siempre tendremos esa perdida de 0.15mm en el Z, pero al menos el error es siempre el mismo sea el tamaño que sea.

Punto 2. Puede que el fallo sea mecánico, pero ponga donde ponga el final de carrera para probar en varios puntos del eje Z el problema es el mismo. Por eso me desconcierta.

Punto 3. Me dices que pruebe mas cosas a parte de Cura. Cuando tenga tiempo lo haré. Pero no es la causa del problema ya que es de la propia impresora, lo hace a la hora de imprimir y a la hora de mover los ejes desde el menú.



Se puede pensar que un error de 0.15mm no es para tanto, pero si tenemos que juntar 10 piezas de 1 cm cada una, la diferencia es 0.15 x 10 = 1.5 mm que no es moco de pavo. Y si a esto le sumamos la molesta pata de elefante... Tengo que encajar piezas y me toca tirar de dremel para comerme lo que sobra.

Y en cuanto al calibre me es difícil y poco preciso medir el movimiento de los ejes X e Y, pero con el Z lo tengo muy muy fácil, 99% fiable diría yo. Puedo medir 30 veces seguidas y obtener variaciones despreciables. Y te digo una cosa, lo compré a 12€ hace mas de 10 años en el Lidl y va de auténtico lujo todavía. Para decirte que mi primo es tornero hace mas de 20 años y su jefe compraba calibres de 250€. Cansado ya que se rompieran y tener que gastar otros 250€ probó en este del lidl por probar, no tenía nada que perder. Pues fuera bromas y aunque parezca coña no volvió a comprar mas calibres "buenos". Me dijo que lo guardara como oro en paño.



Mañana probaré a hacer inventos con el final de carrera, a ver si hace algo raro al pisarlo y no para donde debe o algo, pero no creo. Pare donde pare 1 mm es 1 mm, no tiene sentido que el primer mm del recorrido sea mas pequeño...

Perdón nuevamente por el rollo jajaja y un saludo.

[Imagen: IMG-20190917-232302.jpg]

Me he diseñado ésta escalera de 10 mm de altura con peldaños de 1 mm cada uno para hacer pruebas. Se conforma que el primer escalón mide aproximadamente 0.85mm y el resto aproximadamente el milímetro. Con lo que la altura total es mas o menos 9.85 mm.
  Responder
#6
Voy por partes, que sino me pierdo.
En respuesta a @Lepes: la formula general para calcular los micropasos por milímetro teóricos es la misma para todos los ejes, pues todos los mueve un motor controlado por el firmware.
Lo único que cambia es el sistema de arrastre del eje y por lo tanto, lo que se mueve este por cada vuelta del motor que lo impulsa.
La fórmula es: micropasos por milímetro = pasos por vuelta del motor * micropasos del driver / desplazamiento del arrastre del eje (en milímetros) por cada vuelta del motor.
Por ejemplo, para un motor que mueva de forma directa una correa GT2 con una polea de 20 dientes, el desplazamiento son 40mm por vuelta (GT2=2mm por diente).
Para un husillo T8-8 acoplado directamente al motor, son 8mm (paso del T8-8=8mm por vuelta). La regla de tres se utiliza para ajustar el valor teórico según el resultado de las distancias reales obtenidas.
En respuesta a @Mazaias: como he comentado antes, la regla de tres no se utiliza para sacar los micropasos a partir de las medidas, sino al contrario. Hay que poner el valor teórico que sale de la fórmula general indicada, mandar mover una distancia al eje y medir lo que se ha desplazado en realidad. Con ese valor, se aplica la formula (regla de tres): micropasos a configurar = micropasos actuales * distancia ordenada / distancia obtenida.
Un error de 0,15mm es apreciable y si se acumula (por unir piezas que lo tengan), pues mucho más. Pero no comprendo el problema que tienes con la "pata de elefante": ¿estás diciendo que no la puedes quitar? ¿Que si en lugar de configurar una capa inicial de x mm, configuras una de 2x mm (o de 3x mm, etc.) te la sigue haciendo? No parece muy plausible.
Sobre esa diferencia en el primer milímetro del movimiento, si fuese en otro eje se podría deber al backlash, pero precisamente en el eje Z no se aplica, dado que la gravedad siempre mantiene la rosca del husillo en contacto con la tuerca.
Sobre lo del calibre mejor no comento nada. Si dices que te va bien, por mí perfecto.
Lo de que el final de carrera no pare donde debe, precisamente se corrije haciendo bien la calibración con la hoja de papel. En todo caso, pare donde pare, solo influye en la altura inicial de impresión, pero no en las distancias que recorre el eje en los movimientos y que indicas es el problema que tú tienes.
En lo que sí estoy totalmente de acuerdo es en que no tiene sentido que el primer milímetro del movimiento, sea menos distancia que los milímetros posteriores.

P.S.: Estaba escribiendo la respuesta cuando ampliaste la tuya. Si adjuntas el archivo gcode de esa escalera, quizá se vea algo en él que arroje luz sobre el asunto.
  Responder
#7
Ese fallo en el primer milímetro lo hace ponga donde ponga el final de carrera. Si me olvido de la cama y pongo el final en varios puntos por probar, el primer mm siempre mueve menos y no es porque le cueste mover al principio porque pasaría en cada arranque, sin embargo una vez superado ese mm el movimiento es normal. Si fuese ese caso, haría 4 movimientos y "le costaría mover" en los 4 rranques, sin embargo solo ocurre en el primero. Muevo solo 1 mm y se mueve menos, me espero el rato que sea y subo otro mm, ya sube justo 1 mm. Es decir, siempre sube menos el primer milimetro desde el origen éste donde esté. Si en lugar de subir de milímetro en milímetro subo de 0.1 en 0.1 sube menos los 3 primeros movimientos, al cuarto ya sube 0.1. Sempre hablo de moverlo desde el menú, no imprimiendo. Pero imprimiendo el problema es el mismo, y ahí viene la pata de elefante, como sube al principio menos de lo que debe chapa las capas.

No tengo ahora a mano el gcode para pasarlo, pero no es el problema, ya lo revisé (a parte de que sin gcode, moviendo desde los menús como digo se aprecia el problema). Viendo el gcode se ve como va subiendo las capas de 0.2 en 0.2, pero como digo la máquina no responde como debe a esas primeras subidas de 0.2 prensando las capa.
Pensé en modificar a mano las 2 o 3 primeras subidas o hacer un script para automatizarlo, pero el gcode lo genera con coordenadas absolutas, con lo que tendría que cambiar TODAS las Z. Con coordenadas relativas si sería fácil, subiendo por ejemplo las dos primeras capas 0.25 en lugar de 0.2 podría compensar la perdida, sería calcularlo.

Simemart en lo que dices de que ocurre si modifico la altura de la primera capa pues tres cuartos de lo mismo. Si pongo la primera capa a 0.3 en lugar de 0.2 para intentar reducir la pata de elefante, como la impresora va subir realmente sobre 0.15-0.2mm en lugar de 0.3 sigue chafando las capas y haciendo igualmente la pata de elefante.

Jajaja... el tema del calibre... Me arrepentí de comentarlo porque sabía que iba a sonar a ingenuo y/o chapuzero jajaja pero es verídico. Obviamente ese calibre de 12€ no va a tener la calidad de uno de 200€, pero su calidad/precio es insuperable. Y ya te digo que los han usado durante mucho tiempo en una fábrica que hace piezas y máquinas para toda España (asín semos en España y asín nos va jaja). Es como decir que mi Xiaomi de 220€ es mejor que un Samsung de 1500€. Pues no es mejor, no, faltaría mas, pero su calidad precio es imbatible. En relación a lo que pagué si es mejor y me sobra móvil. Hace tiempo que dejé de creer en las marcas. Se encuentran cosas baratas muy buenas al igual que caras y no tan buenas.

Pásanos de polémica de calibres a móviles jajaja. Perdón por el off topic.

Yo sigo pensando que es problema de firmware y no mecánico. He pensado en instalar marlin 2.0 a ver que pasa. Pero no tengo ganas de complicar las cosas, la máquina va en general de lujo, salvo éste tema de los famosos 0.15mm perdidos. Me da miedo complicar o empeorar otras cosas por intentar arreglar otras. No es por miedo a toquetear, programo en Arduino desde el 2012 y me encantaría meter mano al código y personalizarlo a mi gusto, pero no tengo tiempo para tanto ya...
Hablando de marlin, por lo poco que he visto, a la hora de modificar por ejemplo los pasos de los motores la gente modifica las variables, recompila y sube el programa a la placa con los cambios hechos. Es obligatorio así? No están las opciones en menú para no tener que volver a cargar el firm cada vez que quieras cambiar algo?. Me gustan las cosas prácticas, si tiene todas las opciones en menú si me animaría a probar, mas que nada por ver si se soluciona mi problema.
  Responder
#8
Pues no es mala idea lo de probar a cambiar el firmware, pues cosas más extrañas se han dado, aunque puedes instalar la versión 1.1.9-bugfix sin problema en lugar de la 2.0, eso como veas.
Lo que sí te recomiendo es que utilices para ello los archivos descargados de la página oficial de Marlin.
Sobre la modificación de parámetros del firmware, Marlin tiene una gestión muy eficiente de la memoria EEPROM que permite realizar esos cambios de forma sencilla, sin necesidad de modificar el código, recompilarlo y subirlo a la MCU. Recientemente he dado esta respuesta a ese tema, que quizá te interese.
  Responder
#9
Muchas gracias Simemart, me has aclarado la principal duda que tenía respecto a marlin. Cierto es que solo había curioseado un poco sobre el porque no tenía pensado instalarlo ya que comentan que no vale mucho la pena en la ender excepto si lo que se quiere es añadir el autolevel.
Me meteré a fondo con el y si no soluciono mi problema probaré con marlin.
  Responder
#10
@Mazaias, te he malinterpretado, al decir que creías "que el problema era de software", pensé en CURA. Ahora entiendo que te refieres al firmware de serie de la impresora.
Lo raro es que nadie más en el foro ha hablado sobre este tema, si fuera firmware estarían todos con el mismo problema.

Una cosa sobre Marlin: No es que solo sirva para poner Autolevel, tienes el control de todo. Te aconsejaría le eches una visual, aunque solo sea por bichear. Igual tiene otra característica que te interese.
Ulticampy V2: fundiendo plástico sin descanso...
  Responder
#11
Cagüen,.... Se ha borrado el mensaje....

No te preocupes, la culpa es mía por decir software en lugar de firmware.

De paso detallo algo mas. Siempre mueve menos de un milímetro desde la posición 0 a la posición 1mm tanto en subida como en bajada. Estoy en el 0, subo 1mm y sube 0.85, subo otro mm y sube 1 mm, bajo 1mm y baja 1, bajo 1 y baja 0.85, ya está en el 0. Subo otra vez de 1 en 1 y siempre solo entre el 0 y el 1 se mueve 0.85 tanto en subida como en bajada y en pasar ese primer milímetro ya mueve 1 justo. Ahora muevo el final de carrera a cualquier punto aleatorio y hago la misma operación de subir y bajar de milímetro en milímetro y el resultado es el mismo. Por eso descarto un fallo mecánico, si no, ¿porque siempre siempre mueve menos entre el mm 0 y el 1 y no entre el 4 y el 5 o el 10 y el 11?.

Marlin y a ver que pasa...
  Responder
#12
Pues instalado y probado Marlin 2.0 y.... sigue igual.....
¡Pero al final lo he solucionado!. El caso que tomando nuevamente medidas de los movimientos una vez instalado marlin me doy cuenta que la perdida de los 0.15mm no es siempre abajo del todo tanto en subida como en bajada (extraño, me cansé de repetir cien veces las pruebas), sino siempre en los cambios se sentido, es decir, estoy en el mm 0 y subo 1, entonces sube realmente 0.85, subo 1 y sube 1, subo 1 y sube 1, bajo 1 (cambia el sentido de marcha) y baja 0.85, bajo 1 y baja 1, bajo 1 y baja 1, subo 1 (cambio) y sube 0.85. Solo en los cambios de sentido. Todo me va cuadrando, por eso siempre falla nada mas empezar, es un cambio de sentido. Hace home bajando y tiene que ir subiendo de capas. Con lo que ya cambio de idea y tiene que ser claramente algo mecánico. Después de repasarlo todo veo que las ruedas que deslizan sobre el eje Z van muy duras. Total, que el asunto era aflojar un poco la rueda excéntrica del lado derecho, el lado contrario al del husillo. Que pasaba, que el motor tira, mueve fácil el mismo lado del motor y husillo, pero el carro del lado contrario que va muy cogido de ruedas le cuesta mas y se arquea toda la barra hasta que empieza a moverla. En cada cambio de sentido es cuando se engancha y pierde esas décimas.

El caso es que tiene delito la cosa, soy ascensorista y las puertas automáticas van sobre carros con ruedas fijas y ruedas excéntricas iguales a los carros de la impresora, y salvo algunos casos, tenemos la norma de que las ruedas excéntricas deben rozar la guía pero se tienen que poder girar con la mando, que no que estén tan fuertes que no se puedan mover. Y me preguntaba siempre si debían ir esas ruedas tan fuertes Triste ¿Porque no aplicaría esa norma a la impresora? Sonrisa

He vuelto a imprimir el cubo de calibración de 2cm y de lujo! En los 3 ejes 20 mm +- 0.05 mas o menos. Ya no le faltan los 0.15mm de altura. Y como ya no comprime en la base esos 0.15mm ya no tiene para de elefante!!!!

Mmuchas gracias Simemart y Lepes por soportarme SonrisaSonrisaSonrisa

Un saludo!
  Responder
#13
Me alegro que lo hayas solucionado, aunque no sea de Marlin, ya puedes cambiar todo lo que se te antoje más fácilmente.
Ulticampy V2: fundiendo plástico sin descanso...
  Responder
#14
Si, me ha gustado. Algunas cosas me las he puesto mas a mi gusto y aunque no sean menús muy complejos y no sea necesario, siempre se hace mas agradable tenerlos en español. Lo primero que noté fué con la suavidad que hace el home. Con el firm original pega unos golpes en los finales que parece que se parte la máquina.
  Responder
#15
Hola, reabro el post para dar la razón a @Mazaias en relación con lo que había apuntado sobre el calibre del Lidl.
Después de su comentario me picó la curiosidad y miré si Lidl aún lo vendía y sí, sigue ofreciéndolo en su página de venta online.
Por un precio de menos de 10 euros, me dije, no merece la pena dormir intranquilo con esa duda. Asi que pedí uno y llevo probándolo estás semanas.
Como era de esperar, el acabado del producto está acorde con su precio: aristas vivas, superficies bastas, etc. Todo dentro de lo normal.
Pero, con relación a las medidas que realiza, tengo que decir que me ha sorprendido. Muy buena precisión y repetibilidad, muy superior a los modelos que se ven por Internet con precios 5 veces mayores.
No es un Mitutoyo, eso está claro, pero efectivamente la relación precisión/precio es muy alta y ha sustituido al que utilizaba hasta ahora (también barato, aunque no tanto, pero bastante peor. El Mitutoyo se sale de presupuesto).
Así que tengo que decir que tenías razon @Mazaias, muchas gracias.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Primeras capas con reborde y exceso de PLA inviernomudo 14 206 25-01-2022, 06:53 AM
Último mensaje: inviernomudo
Exclamación CONSULTA Problemas adhesión ender 3 pro Fatalis22 11 1,576 10-01-2022, 07:25 AM
Último mensaje: Macuho
  CONSULTA Instalando Marlin para ENDER 3 PRO JOSELUIS54 22 910 25-09-2021, 10:20 PM
Último mensaje: JOSELUIS54
  CONSULTA Ender pro 3 IMPRIME DÓNDE QUIERE jgalan1981 4 298 25-09-2021, 10:10 PM
Último mensaje: JOSELUIS54
  Mi Ender 3D PRO imprime fatal (SOLUCIONADO) JOSELUIS54 28 1,611 13-09-2021, 09:47 PM
Último mensaje: JOSELUIS54