This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
mi extrusor se para a mitad de la impresion
#1
hola,

soy nuevo en esto, bastante novato. Tengo una prusa i3 y llevo tres meses imprimiendo normal pero hay veces sobre todo en impresiones largas (+ de 10 horas) que de pronto el extrusor se detiene y la impresora sigue trabajando claro sin que salga el filamento. he estado mirando y parece que puede ser la temperatura y con un ventilador mayor se podría resolver, aun que también puede ser del driver, si alguien conoce este tema os agradezco vuestros comentarios.
  Responder
#2
Normalmente si es una cuestión de temperatura la impresora para. Si es por encima la placa se para completamente, da un mensaje de error y no puedes hacer nada más que quitarle corriente, y si es por debajo se para el movimiento, el software no permite extrusión por debajo de 160/170º, se configura pero más o menos por ahí anda la temperatura por defecto.

Mira a ver si es algún tipo de problema con el cableado, que se desconecte en determinado punto o algo similar.

[Imagen: banner_01.jpg]
  Responder
#3
gracias por la respuesta, estoy mirando el cableado y parece que está bien, y lo peor es que me ha pasado alguna vez, en diferentes alturas en z y otras veces no pasa, vuelvo a empezar la impresión otra vez con el mismo gcode y si que termina bien. a veces falla y otras no...
  Responder
#4
¿La vigilas durante todo el proceso?, ¿en el momento que deja de extruir hace un ruido?, ¿deja de extruir de golpe o cada vez suelta menos filamento? es por ir descartando, voy con lo básico.

Por cierto comprueba que esté bien el prisionero de la rueda dentada del extrusor, también por descarte.

[Imagen: banner_01.jpg]
  Responder
#5
Si la voy vigilando, pero se detiene de golpe y ya está. he apretado la rueda dentada, y es que el motor del extrusor deja de girar pero si luego pongo otra impresión funciona perfectamente. no hace ruido entiendo porque se queda del todo parado. lo que no tengo claro es por que a veces se para y otras no...

gracias
  Responder
#6
¿La temperatura del "hotend" varía?, ¿cuándo deja de extruir es porque se enfría?

[Imagen: banner_01.jpg]
  Responder
#7
A ver, existen varias causas por las que se puede parar la impresora. Lo primero es hacer una diferenciación de como se está parando.

Si la impresión se para totalmente en algún punto (es decir, los motores de los ejes se detienen y la impresora se queda estática) suele ser un problema de lectura de SD/comunicacion por usb o bien un problema de temperatura excesivamente alta o baja en el extrusor o en la cama caliente. En este caso, la impresora integra unas protecciones por software para evitar accidentes (incendio en la elevada), que desconecta todas sus salidas y se queda en error hasta que se apague. Si la temperatura es demasiado alta y todo esta ok suele ser debido a una mala regulación del PID y se puede solucionar haciendo un PID Autotune.
La otra posibilidad es que la impresora detecte una temperatura demasiado baja, en este caso también entra en error por si se da la casualidad de que se te haya salido un termistor de su sitio/se haya roto, en ese caso, la impresora estaría mandando calentar y calentar sin parar para alcanzar una temperatura que nunca va a leer y podría causarse un incendio también. Por eso si la impresora esta mandando calentar y no detecta una subida de 1ºC en X tiempo se para.

Por lo que veo, el problema de Ray no parece ser ninguno de estos dos problemas (ya que dice que no se para el resto de motores, únicamente el del extrusor). Es cierto que un sobrecalentamiento del driver del extrusor podría causar este comportamiento, pero es raro que una vez falle, no vuelva a echar filamento de nuevo en ningun momento. Los driver tienen una protección por sobre-temperatura, esto es que si se calientan demasiado, se apagan momentáneamente y se da lo que se llama la perdida de pasos, podría ser la causa, pero lo dudo... el comportamiento en perdida de pasos del extrusor debería ser intermitente. Como te ha comentado Fendetestas, podría ser un tema de cableado (cable tenso que este dañado, que se te suelte un pin del motor (y por tanto se te desconecte una de las bobinas y adiós al movimiento del motor), a lo mejor al bajar la impresora al hacer un homing se te esta recolocando el cable y te deja de dar fallos.

Por ultimo, podría ser un atasco, pero lo dudo también si tras parar has podido comenzar impresiones de nuevo sin tocar nada, yo optaría por tema de cableado.
  Responder
#8
muchas gracias por la explicación... ahora parece que está trabajando bien, el problema es cuando lleva varias horas, es desesperante....

La duda es cuando se calienta el driver del motor, se para todo la impresora o es posible que solo el motor que controla. Porque se me ocurre que si le pongo otro ventilador para la placa y los drivers pueda solucionarlo...

Los cables parece que están todos bien!!!
  Responder
#9
Si un driver se sobrecalienta ese motor para hasta que el driver se enfria lo suficiente como para volver a arrancar.

La impresora no se entera nunca de si un motor se ha parado o no ya que no hay ningun sensor que le provea datos al firmware para saber la posición real (en el firmware se asume que si avanzas 10000 pasos, se han avanzado)

Asi que si... puede ser un problema de calentamiento y podrias solucionarlo con una mejor refrigeración.
  Responder
#10
Hola buenas, llevo un par de días montando una impresora franquestein de repuestos que tenia, decidí hacer una cartesiana de doble color con una placa trigorilla. En el marlin utilice el 1.1.9 usando una configuración adaptada de la ramps1. 4 EEB +F
Cuando empiezo a imprimir todo correcto el fallo empieza con el patrón de relleno. Cuando éste empieza da igual si es con el e0 o el e1 se para pero solo el motor del hotend todos los demás siguen.
E probado el sobrealimentado y el subalimentado de los motores les e aumentado la velocidad y los pasos. E comprobado los cables y no consigo que me haga ni una capa completa de un cubo de calibración. Alguien podría ayudarme por favor, me estoy desesperando.
Gracias de antemano

Se me olvidaba utilizo los driver tmc 2208
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Problema a mitad de impresión Ender 3 ABonilla7 3 186 02-10-2021, 12:29 PM
Último mensaje: Simemart
  CONSULTA la impresora deja de extruir filamento casi a la altura de la mitad de la pieza erjavi_zgz 2 443 06-04-2021, 03:02 PM
Último mensaje: Simemart
  DUDA Parada a mitad de impresión y posteriormente no lee tarjeta Txili 6 461 22-01-2021, 09:07 AM
Último mensaje: Txili
  DUDA Mi extrusor se atasca a mitad de impresión Gonzo49 5 1,368 11-10-2019, 02:00 PM
Último mensaje: Estrallator
  CONSULTA Pieza se despega a mitad de impresión Gonzo49 8 8,567 25-09-2018, 09:56 PM
Último mensaje: Gonzo49