This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 6 voto(s) - 4 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Firmware (copia de seguridad y restauración) y bootloader.
#81
Tengo 2 tarjetas de este tipo, una nueva y la otra con un fallo del potenciometro del driver Y entonces podría realizar pruebas
Pregunta, con Marlin 2.0 no necesita bootloader pero igualmente se tiene que configurar la board?

Por otro lado configure una Ramps 1.4 para esta impresora, la instale pero a en el momento de hacer pruebas de movimiento de motores, no los mueve

[Imagen: B4533-B1-E-5-D7-C-4-B61-9-D0-E-5-FB123446-E77.jpg]
  Responder
#82
Hola, el bootloader va incorporado en la MCU. No necesitas preocuparte por él para cargar el firmware (a no ser que falte).
Pero lo que sí tienes que tener en cuenta es que no puedes utilizar el IDE de Arduino, tendrás que utilizar otro (ATOM, por ejemplo).
Y por supuesto, hay que configurar la placa correctamente. Si no, ¿cómo sabría el compilador qué archivo de configuración de pines tendría que enlazar (entre otras cosas)?
Sobre la RAMPS, sin saber cómo has conectado todo, es difícil responder con propiedad. ¿Has conectado las dos tomas de corriente?
  Responder
#83
Hola, gracias por responder
Tema motores en RAMPS si lo conecte con las dos alimentaciones pero nada con mi impresora principal funciona correctamente entonces no me preocupa mucho.

Del tema de la Tronxy creo que lo voy a tener complicado me pondré a buscar información, pero siendo un modelo de placa así reciente no creo o dudo que encuentre la configuración de pines o algo, tema ATOM nunca lo he tocado.... vamos que esta complicado y ya que no es algo en lo que tenga experiencia...

Gracias a las persona que entienden como tu, nos facilitas mucho las cosas al resto
  Responder
#84
hola,soy nuevo por aquí y ando con el lio de las impresoras he seguido el maual y me salio bien pero después de desconectar la impresora para probarla no me funcionaron bien los finales de carrera y al meterla de nuevo a el pc ya no función mas cargándola con arduino, lo consegui de nuevo con avrdudes pero necesito un firmware en formato hex mi impresora es:ctc 3d con placa anet v1 y procesador atmega1284p, agradecería que alguien me pasase el dump de el firm,gracias.
  Responder
#85
Hola, he llegado a tu posteo que hasta ahora es el único que ha podido darme un poco de luz. Tengo una impresora Brother HL1212w y estaba actualizando el firmware cuando se cortó el suministro eléctrico y ahora la impresora no me anda. Directamente no me la reconoce la computadora. Quería saber si esto podría ayudarme y en ese caso como debería hacerlo. No tengo la más mínima idea de todo lo que aquí hablas y los técnicos qué hay en mi ciudad y que he consultado me han dicho que no pueden ayudarme, que el equipo ya no sirve más.
Podrían darme una mano con esto así puedo recuperar mi impresora? Se los agradecería un montón!
  Responder
#86
Hola @3412reyna, bienvenid@ al foro pero me temo que te has equivocado, pues ese modelo que indicas es una impresora de tinta y este es un foro de impresión 3D.
  Responder
#87
(06-07-2021, 11:13 PM)Simemart escribió: Hola @3412reyna, bienvenid@ al foro pero me temo que te has equivocado, pues ese modelo que indicas es una impresora de tinta y este es un foro de impresión 3D.

Jajaja si lo se, pero por ahí me tiraban un centro. Gracias igual.
  Responder
#88
Hola a todos, tengo una tarjeta Mega2560 con Ramps 1.4 y drivers A4988, la cual en principio esta funcionando bien, pero debido a que se quemo el regulador de 5V de la placa, lo que hace que para alimentarla, tenga que conectarle un cable USB, compre una tarjeta Arduino Mega2560 "original", y empecé a averiguar para clonarla, pero resulta que cuando la conecto a la PC mediante el cable USB, no logro que la computadora la reconozca, o sea, no es que no reconoce el driver, sino que directamente ni la ve, cuando la conecto, el administrador de dispositivos ni siquiera pestanea como para saber o tener una idea de que algo se conecto, pero no. He probado desinstalar todos los controladores de Bus serie, pero nada. En cuanto al led amarillo de la placa original, cuando esta conectada a la PC, esta prendido de forma fija, mientras que si conecto la placa nueva (vacía), si la reconoce, y el led amarillo de la placa, se prende de forma intermitente. La verdad que ya llevo varios días buscando información al respecto, y en todos los foros, videos, que encontré, no pude dar con un caso que se parezca al mío. 

Como dije en mi presentación, ni siquiera llego a la categoría de no iniciados, pero agradezco cualquier ayuda que me puedan dar al respecto
  Responder
#89
Hola @fr-print, bienvenid@ al foro.
Probablemente, lo que causó el fallo del regulador interno, haya afectado también al chip controlador USB y ya no puedas utilizar ese puerto.
Por otra parte, supongo que si intentas clonar el firmware que tenías instalado en el nuevo Arduino Mega, será porque no tienes las fuentes para volver a compilarlo y grabarlo, aunque creo que te será más fácil volverlo a configurar de cero que clonarlo: si no hay algo más estropeado en la placa, esto último podrías hacerlo por la conexión ICSP.
  Responder
#90
(12-04-2022, 12:45 AM)Simemart escribió: Hola @fr-print, bienvenid@ al foro.
Probablemente, lo que causó el fallo del regulador interno, haya afectado también al chip controlador USB y ya no puedas utilizar ese puerto.
Por otra parte, supongo que si intentas clonar el firmware que tenías instalado en el nuevo Arduino Mega, será porque no tienes las fuentes para volver a compilarlo y grabarlo, aunque creo que te será más fácil volverlo a configurar de cero que clonarlo: si no hay algo más estropeado en la placa, esto último podrías hacerlo por la conexión ICSP.

Muchas gracias por tu pronta respuesta. Con respecto al Firmware, en realidad quisiera copiar el de la placa vieja, para tenerlo como backup, y a su vez, copiarlo en la placa nueva, por lo que no se si lo podría hacerlo por ICSP, ya que si mal no entendí, para poder hacerlo, justamente necesitaría poder acceder a la placa original. No?
  Responder
#91
En realidad creo que me estoy expresando mal, porque lo que quisiera clonar, es el firmware de la maquina que es el que esta en la placa vieja y que no puedo conectar por medio del cable del USB, y no el firmware de la placa en si, pero como no entiendo casi jada, no se si los firmware (el de la maquina y el de la placa) se guardan en el mismo lugar, o son 2 cosas distintas
  Responder
#92
Hola, no te has expresado mal y está claro lo que deseas hacer, pues no hay dos firmwares distintos en el Arduino Mega, solo una memoria flash en la que se graba el firmware que controlará la impresora y en su caso, un pequeño programa que controla la grabación de dicha memoria por el puerto USB, denominado bootloader.
El Aduino Mega antiguo no puede comunicarse por el puerto USB, pero seguramente sí lo haga por el puerto ICSP, pues es una comunicación directa con la MCU (ATMega2560), aunque para ello necesitas utilizar un programador (ISP) externo, que puede ser perfectamente otro Arduino.
Como tienes dos, puedes utilizar el nuevo como programador externo para recuperar el firmware que se encuentra en el antiguo (esperemos que esté bien) y después reprogramarlo con él: la cuestión es si te ves capaz de hacerlo sin comprometer la integridad de ambas placas.
En todo caso, te indico como debes realizar todo este proceso.

Recuperar la memoria flash del Arduino antiguo

1- Conectar por USB el Aduino nuevo al ordenador, abrir el IDE de Arduino, cargar el sketch de ejemplo ArduinoISP y grabarlo con la siguiente configuración:

Placa: Arduino Mega or Mega2560
Procesador: ATmega2560 (Mega2560)
Puerto: el COM asignado por el ordenador


2- Una vez grabado el sketch ArduinoISP, desconectar el Arduino nuevo del ordenador y conectar ambos Arduinos según el siguiente esquema:

[Imagen: Img1.jpg]

3- Con los dos Arduinos conectados así, conectar el Arduino nuevo por USB al ordenador y realizar la copia de seguridad con el AVRDUDESS como indico en el apartado Crear la copia de seguridad del tutorial, con la siguiente configuración:

Programmer: Atmel AVR ISP
Port: el COM asignado por el ordenador
Baud rate: 19200


Terminada la descarga, cerramos AVRDUDESS, desconectamos el cable USB y después los cables que unen los dos Arduinos.

Grabar el Arduino nuevo

En este momento tendremos un archivo con extensión .hex con el contenido de toda la memoria flash del Arduino antiguo, que tendrémos que cargar en el nuevo como indico en el apartado Restaurar la copia de seguridad, con la siguiente configuración:

Programmer: Wiring
Port: el COM asignado por el ordenador
Baud rate: 115200
  Responder
#93
Muchísimas gracias!!! 

voy a tratar de hacerlo este fin de semana que es largo, y después te cuento, si mi capacidad estuvo al alcance o no jaja ajajaj

Abrazo y nuevamente, 1000 gracias!!!
  Responder
#94
Una cosa que, aunque es obvia, se me olvidó indicar: en el AVRDUDESS debe estar siempre configurada, en el apartado MCU, el ATmega2560 (en teoría debe detectarlo de forma automática, pero conviene comprobarlo).
  Responder
#95
Que yo sepa, el AVRDUDESS no tiene ningún problema con los ATMega2560, ni con ningún otro MCU de Atmel: solo es un GUI gráfico que facilita el uso del AVRDude, que es lo que utilizan casi todas las aplicaciones que interactuan con estos micros (como el IDE de Arduino, por ejemplo).
Por lo que veo en las fotos, parecen estar bien conectados, así que las posibles causas de que no se comunique podrían ser:
1- el nuevo no tiene bien grabado el sketch ArduinoISP.
2- no está conectado en el COM3 del ordenador o no funciona bien la conexión (puerto USB o cable).
3- el antiguo no se comunica debido a la avería.
Antes de indicarte el proceso, lo he realizado yo mismo, por lo que sé que funciona.
  Responder
#96
(13-04-2022, 04:12 PM)Simemart escribió: Una cosa que, aunque es obvia, se me olvidó indicar: en el AVRDUDESS debe estar siempre configurada, en el apartado MCU, el ATmega2560 (en teoría debe detectarlo de forma automática, pero conviene comprobarlo).

Muchísimas gracias Simemart!!!, al final y luego de volver a probar iniciar desde 0, porque aparentemente le he errado al tratar de instalar el ArduinoISP, lo que me hacia que el Avrdude, no pudiera leer las placas, he podido probarlo, y 1ro es como que fallo algo, ya que la placa o la ramps, no llegaba a poder terminar de iniciar el programa, o de encender la pantalla, por lo que, volvi a hacer todo de nuevo desde 0, y ahora si, pude hacer que arranque el programa, que prenda la pantalla, y que mueva los motores, pero en el caso de mi maquina (no es una impresora 3D, sino una cortadora de polifan), en la salida D9, que en el caso de las impresoras, veo que se usa para el ventilador de capa, en el caso de la mia, lo usa para el alambre que corta el polifam, y ahora no anda, pero en resumen, debido al 1er problema anterior y ahora a este ultimo, creo que debe ser mas un problema de la ramps nueva (cambie placa y ramps) que de la clonación de las placas, por lo que ahora voy a seguir probando, pero desde ya te quería dar la 1.000 gracias, para que un NI recién iniciado como yo, pueda llegar a buen puerto B2 B2 !!!! Abrazo y gracias por todo
  Responder
#97
Me alegro de que lo hayas conseguido.
Si no te funciona la salida D9, quizá sea un problema de configuración del tipo de placa ya que, dependiendo del hardware concreto conectado a la RAMPS, esta puede ser de varios tipos, enumerados mediante las iniciales de los dispositivos (E=extrusor, F=ventilador, B=cama): en función de ello, se asignan en el archivo de pins las salidas correspondientes.
  Responder
#98
(25-04-2022, 08:52 PM)Simemart escribió: Me alegro de que lo hayas conseguido.
Si no te funciona la salida D9, quizá sea un problema de configuración del tipo de placa ya que, dependiendo del hardware concreto conectado a la RAMPS, esta puede ser de varios tipos, enumerados mediante las iniciales de los dispositivos (E=extrusor, F=ventilador, B=cama): en función de ello, se asignan en el archivo de pins las salidas correspondientes.

Tene presente que no llego ni a neófito ni siquiera en la categoría de recién iniciado, y la verdad que ya me daba vergüenza preguntar, pero ya que tocaste el tema……si solo cambio la Ramps, y los drivers de los motores (ya los calibre para los mismos) por una nueva, no se supone que tendría que andar igual, o no? No queria poner la Ramps vieja, por miedo a que vuelva a quemar la parte que alimenta a la Mega, pero para sacarme la duda, la coloque, y anda perfecto, así que, puede ser que sea un tema de placa, o podría ser de configuración?
  Responder
#99
Pregunta todo lo que quieras saber sin ningún reparo, para eso está el foro.
Cuando se avería el regulador interno del Mega2560 no es culpa de la RAMPS, ya que esta solo se limita a entregar la alimentación que le entra por su conector: es el voltaje con el que se alimenta la RAMPS el que causa el fallo, si sube por encima de los 12V que son el máximo teórico que admite el Mega2560.
Es decir, puedes utilizar la RAMPS antigua sin ningún problema y lo que tienes que comprobar es la fuente de alimentación que estás utilizando.
Sobre la D9, ¿que configuración de RAMPS tienes? Ten en cuenta que es una salida con PWM, que entrega por tanto un voltaje "virtual" entre 0V y 12V, dependiendo del valor enviado a ella.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  placa anet v1.7 no me deja subir el firmware Hunterfett 4 1,788 19-09-2022, 02:12 PM
Último mensaje: Simemart
  Firmware Anet A8 Plus 1.6 Akila 1 1,269 20-02-2021, 05:51 PM
Último mensaje: miguelangel
  Anet ET4 no me deja actualizar Firmware. Linuco 1 1,055 23-01-2021, 06:55 PM
Último mensaje: Linuco
  Autolevel, paso a paso (I): Cambiar el firmware. Simemart 149 49,304 20-11-2020, 11:59 AM
Último mensaje: LOLO
  CONSULTA actualizacion firmware anet et4 Toni55 7 5,247 21-08-2020, 06:20 PM
Último mensaje: macugo