This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Lcd no funciona si desconecto del usb
#1
Hola a todos,

llevo ya días imprimiendo, siempre desde el PC.

El otro día quise imprimir desde la SD y me llevé una sorpresa. El LCD si no lo conecto (el arduino) al pc, no visualiza nada.

Ya he probado a tocar el potenciómetro del lcd, pero era un sinsentido, ya que por usb funciona y se ve perfectamente.

Alguien podría orientarme o sabe donde puede estar el problema?

Saludos y gracias.
  Responder
#2
Tienes soldado el diodo D12 (esta debajo de el pololu de X o Y)
"Enseñar es aprender dos veces".
  Responder
#3
Quiza antes de poner mi problema deberia haber puesto lo que tengo. Por usb imprime perfectamente, mejor o peor pero imprime.

Uso una ramps 1.4SB que ya lleva diodos antiparalelo en las clemas de la cama y Extrusores. Solo tiene dos semanas por lo que caso decarto que sea cosa de mosfets.

También uso rele, sin diodo.

edit: veo que te refieres al regulador del arduino. En caso de estar roto, tiene algun sintoma? Perdonad mi ignorancia, podria ser el regulador, pero entonces no entiendo que el pc reconozca todo correctamente.

Repito que la pantalla se enciende, aunque parpadea un poco , pero no sale nada.
  Responder
#4
Para descartar, esta tarde pruebo con otro arduino mega que tengo. Asi salgo de dudas de si es el regulador, porque cortos por los endstop si que he tenido.
  Responder
#5
Os cuento,

he probado otro Arduino mega y ha funcionado, la lcd se veía sin conectar el Arduino al usb, pero a los pocos segundos ha salido olor a quemado, que viene, efectivamente del regulador Ams. No se si merece la pena cambiarlo, porque se volverá a quemar. Este arduino que he probado tiene muy poco uso, asi que desconozco que puede estar fallando. Los endstop estan bien, sin cortos...

Edit: Lo que veo que se ha quemado son el condensador y alguna resistencia de las que estan justo detras del conector usb del arduino. El regulador parece que está bien.
  Responder
#6
Bueno, vuelvo con lo mismo. Ya he cambiado el regulador del arduino y sigue igual, sigue sin encenderse sin conectarla al usb.

Es un problema porque dependo del pc para imprimir.

A ver si alguien me echa una mano.
  Responder
#7
Hola Jarryson.

Conseguiste solucionar el problema??

Yo tengo el mismo problema:
RAMPS v1.4 con los diodos D1 y D2 montados.
LCD smart controller de Reprap Discount
Arduino MEGA 2560

.... y sólo funciona la LCD con alimentación de USB!!!
También he revisado el regulador de voltage de la Arduino con el polímetro y salen 5V. Por lo que intuyo que está bien.

Si alguien sabe dónde puedo encontrar una solución lo agradecería!!!
Saludos.
  Responder
#8
Es el regulador ams1117. Yo lo que hice fue quitarlo y poner un LM7805. Y desde entonces sin problemas
  Responder
#9
OK. Gracias. Lo probaré a ver qué tal!!!
  Responder
#10
Mí solución fue pelar el cable del USB y conectar a 5v los cables de color negro y rojo
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  ¿CÓmo funciona una SKR MINI para calentar hotend? RocaDiesel 2 96 04-12-2021, 11:19 PM
Último mensaje: RocaDiesel
  Cambio Endstop por 3dTouch y no funciona. Luz roja constante [Solucionado]. Mafer 15 784 13-09-2021, 09:09 PM
Último mensaje: Simemart
  pantallas mks tft 3,5 v1.0 no funciona en placas sgen_l y sbase v 1,3 domingo 9 2,364 23-03-2021, 07:20 PM
Último mensaje: magnus722
Exclamación CONSULTA El motor del filamento en el extrusor no funciona correctamente alexramsal 2 523 22-01-2021, 07:23 PM
Último mensaje: alexramsal
  CONSULTA Alimentación por DC no funciona Jaii 3 863 15-02-2020, 07:35 PM
Último mensaje: Simemart