This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Marlin builder Error: Could not find one of 'package.json'
#1
Hola y gracias por leerme.
He estado desconectado de mi impresora 3D y de la programación por un tiempo, pero al volver, no funcionaba bien, a si que cogí el ultimo código de Marlin que tenia y trate de compilarlo (Con el marlin builder en VS code) no obstante me reporta el error:
Código:
Error: Could not find one of 'package.json' manifest files in the package

Uso la MKS SGen-L con el LPC1768

Esto solo me pasa con este procesador, he tratado de compilar para la MKS Monster8 con el STM32F4 y para la Mega2560, estas si compilan

La versión de marlin es la 2.0.9, pero al probar con la 2.1.1 recién descargada sucede lo mismo, también he probado a eliminar la carpeta .pio y a compilar sin el marlin builder, nada funciona, siempre el mismo error.

He estado buscando en internet, pero no he encontrado ninguna solución.

¿Alguien sabe a que puede ser debido esto?
  Responder
#2
Hola, he intentado compilar para esa placa y no me ha dado ningún error.
Si hace mucho que no lo utilizas, quizá tengas desactualizado el VSCode: actualízalo o mejor aún, desinstala todo y parte de cero.
  Responder
#3
Hola Simemart y gracias por responder

(23-11-2022, 11:04 PM)Simemart escribió: Hola, he intentado compilar para esa placa y no me ha dado ningún error.
Si hace mucho que no lo utilizas, quizá tengas desactualizado el VSCode: actualízalo o mejor aún, desinstala todo y parte de cero.

Lo he desinstalado y vuelto a instalar eliminando todas las extensiones y solo he instalado PlatforIO, sigue dándome el mismo error.
¿Podria ser un problema con PlatformIO?
  Responder
#4
Pues si has borrado todas las carpetas que pudieran quedar después de la instalación, va a ser difícil saber porqué se produce ese error en tu caso.
Yo tengo instalada la versión 1.73.1 de VSCode, la 2.5.5 de PlatformIO y la 2.1.45 de ABM y Marlin 2.1.x compila sin errores solo cambiando el modelo de placa a SGEN L; quizá el problema venga por la compilación de alguna otra funcionalidad de Marlin que yo no tenga activada: si adjuntas los archivos de configuración que estás utilizando y de qué versión de Marlin son, puedo probar si tengo el mismo error.
  Responder
#5
(24-11-2022, 03:35 PM)Simemart escribió: Pues si has borrado todas las carpetas que pudieran quedar después de la instalación, va a ser difícil saber porqué se produce ese error en tu caso.
Yo tengo instalada la versión 1.73.1 de VSCode, la 2.5.5 de PlatformIO y la 2.1.45 de ABM y Marlin 2.1.x compila sin errores solo cambiando el modelo de placa a SGEN L; quizá el problema venga por la compilación de alguna otra funcionalidad de Marlin que yo no tenga activada: si adjuntas los archivos de configuración que estás utilizando y de qué versión de Marlin son, puedo probar si tengo el mismo error.

Claro, antes de borrar nada he guardado los archivos, a si que adjunto una carpeta de drive que lo contiene todo:
https://drive.google.com/drive/folders/1...sp=sharing


La versión 2.1.1 de Marlin es recién descargada, solo he cambiado la placa y el Serial port
La versión 2.0.9 es el código que tenia en un principio

La version de vVisual Studio Code es 1.73.1
La version de Platform IO es Core 6.1.5 y Home 3.4.3 ( No se si esto son las versiones pero no se donde mirarlo si no )
No estoy usando Marlin autobuilder ya que quería probar con el mínimo de extensiones
  Responder
#6
Las versiones de las extensiones se indican a la derecha de su nombre, en la página que aparece al seleccionarlas en el apartado de extensiones.
El Marlin 2.1.1 que has colocado en GD tiene algún problema, pues me indica errores de falta de un archivo; la 2.0.9 directamente me indica que no es un proyecto válido de Marlin, así que creo que ambas están mal: en todo caso, no me ha indicado el error que pones en tu primer mensaje.
Si utilizo el Marlin 2.1.1 descargado de la página oficial y le pongo los archivos de configuración que tienes en el que adjuntas, me compila sin errores.
  Responder
#7
(24-11-2022, 07:25 PM)Simemart escribió: Las versiones de las extensiones se indican a la derecha de su nombre, en la página que aparece al seleccionarlas en el apartado de extensiones.
Mi version de platformIO es 2.5.5

(24-11-2022, 07:25 PM)Simemart escribió: El Marlin 2.1.1 que has colocado en GD tiene algún problema, pues me indica errores de falta de un archivo;
Vaya, que raro... Subire de nuevo los archivos a ver

(24-11-2022, 07:25 PM)Simemart escribió: la 2.0.9 directamente me indica que no es un proyecto válido de Marlin, así que creo que ambas están mal: en todo caso, no me ha indicado el error que pones en tu primer mensaje.
Si utilizo el Marlin 2.1.1 descargado de la página oficial y le pongo los archivos de configuración que tienes en el que adjuntas, me compila sin errores.
Yo también he probado a descargarlo, pero me da el mismo error. Como una imagen vale mas que mil palabras, he añadido un video donde trato de compilar el marlin recién descargado pero para la MKS SGen L, tanto con como sin marlin builder, con las configuraciones predefinidas como con mi código.
También lo hago para la Mega2560 y para la MKS Monster8 que si funciona.
  Responder
#8
Pues el problema tiene que estar en tu entorno de compilación, porque yo compilo el Marlin 2.1.1 que tienes compartido sin ningún error.
Por probar algo, desinstala la versión de Python que tengas e instala la última versión (3.11.0).
Utilizar los archivos de configuración entre versiones de Marlin distintas, te dará un error al compilar: aunque puede evitarse editando el número de versión que aparece en el archivo, no es conveniente pues entre versiones pueden aparecer, desaparecer o cambiar de nombre parámetros y eso también generará errores de compilación.
  Responder
#9
(25-11-2022, 04:18 PM)Simemart escribió: Pues el problema tiene que estar en tu entorno de compilación, porque yo compilo el Marlin 2.1.1 que tienes compartido sin ningún error.
Por probar algo, desinstala la versión de Python que tengas e instala la última versión (3.11.0).
Lo he hecho, pero nada...

(25-11-2022, 04:18 PM)Simemart escribió: Utilizar los archivos de configuración entre versiones de Marlin distintas, te dará un error al compilar: aunque puede evitarse editando el número de versión que aparece en el archivo, no es conveniente pues entre versiones pueden aparecer, desaparecer o cambiar de nombre parámetros y eso también generará errores de compilación.
Soy consciente de ello, pero lo había considerado una buena forma de mostrar como ni siquiera llega a ese punto.


Finalmente he decidido volver a desinstalar por completo visual studio, python, todos los paquetes y todo lo que se me ha ocurrido, he borrado todas las carpetas que he visto relacionadas con visual studio code y lo he vuelto a instalar. Al ejecutar la compilación se ha puesto a descargar cosas y luego ha compilado sin problemas.
Muchísimas gracias por todo y lamento las molestias...
  Responder
#10
Ninguna molestia, me alegro que se haya solucionado.
Un saludo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Marlin TH3 UFW 2.48 error eje Z AYUDA SkyManker 0 159 26-05-2022, 03:42 PM
Último mensaje: SkyManker
  Error al compilar Marlin con vscode 21Curiosos 8 790 18-05-2022, 05:35 PM
Último mensaje: 21Curiosos
  Marlin Builder v1.0: Configurando firmwares Marlin online y de forma muy sencilla Peter13 4 12,903 20-04-2020, 10:07 AM
Último mensaje: Peter13
  Error al compilar Marlin 2.0 para la SKR 1.3//RESUELTO mrprlopper 0 1,460 21-11-2019, 05:10 PM
Último mensaje: mrprlopper
  Cambiar mensajes de error Marlin p52sarup 6 1,671 16-07-2019, 09:15 PM
Último mensaje: p52sarup