This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Ayuda marlin y configuración CTC Y 5137
#1
Hola a tod@s ,me regalaron esta impresora y no trae el cd, el procesador es Atmega1284p.
[Imagen: Screenshot-20221116-161308.jpg]

Soy nuevo y estoy muy pez.
[Imagen: 20221115-212255.jpg]
  Responder
#2
¿Nadie tiene el marlin y la configuración?
Valla liada si nadie lo tiene.
  Responder
#3
Hola @Vayafumo, bienvenid@ al foro.
Tienes que tener paciencia si preguntas en el foro, pues no siempre tendrás una contestación en solo tres horas.
Esa impresora es el típico clon de la Prusa I3, que incorporan como placa controladora un clon de la Melzi, muy parecida a la Anet A8.
Efectivamente, esa placa lleva la MCU ATMega1284P, que está algo limitada de memoria flash, lo que complica las cosas a la hora de instalar el firmware si se habilitan muchas funcionalidades.
El manual que suelen traer estas impresoras en puramente simbólico: algunas orientaciones de montaje, descripción de las opciones del menú del firmware de fábrica y algo sobre el uso de alguna versión obsoleta de CURA; puedes pasar de él tranquilamente, pues encontrarás más información en Internet y mucho más detallada.
Lo primero que debes hacer es revisar todas las conexiones de los distintos componentes en la placa antes de encender la fuente, que veo que no has conectado aún: mucho cuidado con la polaridad, pues no todas tienen la misma posición y si la conectas mal pasará a mejor vida
Si no está serigrafiada en ella cual es el positivo, lo más seguro es comprobar con un multímetro la continuidad con un pin GND conocido, por ejemplo el pin más hacia el interior de la placa de los conectores de finales de carrera (cualquiera de los rotulados como SX, SY o SZ): el negativo de la alimentación, será el que dé continuidad con dicho pin (resistencia casi nula).
También debes asegurarte que estén bien apretados los bornes de los conectores END y BED, sobre todo este último, pues sino puede que se queme el conector, cosa bastante habitual en estas placas.
Así mismo, conviene vigilar el conector que va en la cama, en este caso que entre firme y hagan buen contacto los pines, por la misma razón: te recomiendo que no dejes la impresora sin supervisión mientras imprime, sobre todo con estos modelos.
¿Porqué necesitas un firmware? ¿Ya sabes si la placa lo tiene o no? Primero comprueba si tiene algún firmware instalado y si no lo tiene, no hay problema en indicarte cómo hay que configurar Marlin para esa impresora.
  Responder
#4
Cuando enciendas la impresora, después de comprobar todas las conexiones bien como te comenté, sabrás si tiene firmware instalado y cual (sería raro que no tuviese ninguno): si es Marlin, lo indicará en la pantalla inicial de carga; sino, será seguramente el original (estas máquinas suelen traer una versión específica).
En este mundillo, la única solución a la inexperiencia es leer todo lo que se pueda sobre el tema (el foro es un sitio inmejorable para ello) y practicar mucho.
No dudes en consultar lo que necesites, por aquí estaré para ayudarte en lo que pueda.
  Responder
#5
(16-11-2022, 08:18 PM)Simemart escribió: Hola @Vayafumo, bienvenid@ al foro.
Tienes que tener paciencia si preguntas en el foro, pues no siempre tendrás una contestación en solo tres horas.
Esa impresora es el típico clon de la Prusa I3, que incorporan como placa controladora un clon de la Melzi, muy parecida a la Anet A8.
Efectivamente, esa placa lleva la MCU ATMega1284P, que está algo limitada de memoria flash, lo que complica las cosas a la hora de instalar el firmware si se habilitan muchas funcionalidades.
El manual que suelen traer estas impresoras en puramente simbólico: algunas orientaciones de montaje, descripción de las opciones del menú del firmware de fábrica y algo sobre el uso de alguna versión obsoleta de CURA; puedes pasar de él tranquilamente, pues encontrarás más información en Internet y mucho más detallada.
Lo primero que debes hacer es revisar todas las conexiones de los distintos componentes en la placa antes de encender la fuente, que veo que no has conectado aún: mucho cuidado con la polaridad, pues no todas tienen la misma posición y si la conectas mal pasará a mejor vida
Si no está serigrafiada en ella cual es el positivo, lo más seguro es comprobar con un multímetro la continuidad con un pin GND conocido, por ejemplo el pin más hacia el interior de la placa de los conectores de finales de carrera (cualquiera de los rotulados como SX, SY o SZ): el negativo de la alimentación, será el que dé continuidad con dicho pin (resistencia casi nula).
También debes asegurarte que estén bien apretados los bornes de los conectores END y BED, sobre todo este último, pues sino puede que se queme el conector, cosa bastante habitual en estas placas.
Así mismo, conviene vigilar el conector que va en la cama, en este caso que entre firme y hagan buen contacto los pines, por la misma razón: te recomiendo que no dejes la impresora sin supervisión mientras imprime, sobre todo con estos modelos.
¿Porqué necesitas un firmware? ¿Ya sabes si la placa lo tiene o no? Primero comprueba si tiene algún firmware instalado y si no lo tiene, no hay problema en indicarte cómo hay que configurar Marlin para esa impresora.
Hola simemart, gracias por responder tan rápido, la verdad que muchas veces no nos damos cuenta de que las demás personas también tienen vida. 
Yo no tengo nada de idea de esto y un amigo que tiene una me va a echar una mano.
El me comentó que necesitaba el marlin que traía y la configuración, pero como no tengo el cd ,pues  tenía que buscarlo.
Veo que entiendes mucho ,eres muy activo en el foro ayudando a tod@s. Tus consejos no van a caer en saco roto y los seguiré  al pie de la letra.
De todos modos darte las gracias ,me puedas ayudar o no, por todo lo que estás haciendo en este grupo. 
Ahora la estoy transformado a chasis de acero ,por que el de contrachapado estaba muy mal.
Un saludo ?
  Responder
#6
(16-11-2022, 10:57 PM)Simemart escribió: Cuando enciendas la impresora, después de comprobar todas las conexiones bien como te comenté, sabrás si tiene firmware instalado y cual (sería raro que no tuviese ninguno): si es Marlin, lo indicará en la pantalla inicial de carga; sino, será seguramente el original (estas máquinas suelen traer una versión específica).
En este mundillo, la única solución a la inexperiencia es leer todo lo que se pueda sobre el tema (el foro es un sitio inmejorable para ello) y practicar mucho.
No dudes en consultar lo que necesites, por aquí estaré para ayudarte en lo que pueda.
Hola Simemart ? ? hoy ya la encendí no marca nada .
Sale así directamente. 
Mi amigo me instalo el repetier y no se que más hizo, ahora puedo imprimir pero tiene varios fallos que yo vea.
El primero las piezas no salen en el centro. 
2° no echa suficiente filamento y salen  las piezas como porosas.
Mañana imprimo un cubo de calibración. 
Ya te contaré. 
[Imagen: Screenshot-20221119-224128.jpg]
  Responder
#7
Hola, de momento ya es un comienzo, pero tendrás que realizar muchos ajustes y calibraciones para que la impresora funcione como debe: iremos paso a paso.
El problema del no centrado de las piezas, se debe a que no está bien configurada en el firmware el área de impresión: no basta con poner las medidas de la cama, también hay que configurar de forma apropiada los offsets, de forma que el origen (punto 0 de los ejes XY) se encuentre exactamente sobre la esquina delantera izquierda de la cama.
Para indicarte como debes proceder, necesitaría ver la configuración que tienes actualmente en ese firmware (¿lo habéis cargado vosotros o venía con la impresora?).
Así mismo, tendrás que realizar una calibración completa, tanto de la parte mecánica como de la extrusión y probablemente tengas varias cosas mal configuradas en ese apartado, de ahí la subextrusión: el proceso a realizar lo explico en este post.
  Responder
#8
Hola, mi amigo me dice que no cargo nada ,ya venia cargado y el no sabe qué marlin tiene.
Yo hoy he echo un cubo de calibración 20x20x20, del que tiene letras ajustando manualmente la velocidad de extrusion por que no sale bastante filamento. Las medidas del cubo X = 20.04 Y=20.04 Z=20,36
Relleno al 9%
La velocidad a 105
Extrusor 114
Cama 55°c
Extrusor a 220°c
[Imagen: 20221120-172833.jpg]

[Imagen: 20221120-172837.jpg]

[Imagen: 20221120-172840.jpg]

[Imagen: 20221120-172715.jpg]
  Responder
#9
Hola, si no habéis cargado vosotros el firmware, probablemente sea el de fábrica, de ahí que no indique nada al arranque: yo lo dejaría de momento, por lo menos mientras le vas cogiendo el aire al asunto.
Sobre los parámetros que indicas, supongo que con ese 105 de velocidad te refieres al parámetro que indica la pantalla como FR: si es así, no solo influye en la velocidad de impresión, también en otros aspectos de la misma, como la extrusión, por lo que es mejor dejarlo siempre en 100% y configurar las modificaciones que sean necesarias en el perfíl de impresión del programa de corte.
Si lo que utilizas es PLA, esos 220 ºC son demasiados y te dará mejores resultados configurar sobre 200-205 ºC.
Por las fotos de ese cubo, se ven algunos problemas con las capas iniciales, lo que puede indicar una regulación incorrecta de la altura inicial de impresión (punto 0 del eje Z, el que normalmente se regula con la hoja de papel), o bien una temperatura en la cama demasiado alta (55 ºC está bien, aunque puede no ser real).
Sobre el centrado de las piezas en la cama, tienes una ligera deviación hacia el lado negativo de los dos ejes (XY), bien por una configuración incorrecta de los offsets en el firmware o por unos interruptores de final de carrera desplazados de sus posiciones originales.
Primero comprueba si al llevar los ejes XY a las máximas posiciones que permite el firmware, la boquilla no llega a la esquina trasera derecha de la cama, quedandose más o menos al doble de la distancia que están desplazadas la piezas del centro: si es así, puedes modificar los offsets mediante gcode para intentar centrarlas.
Para ello, debes conectar la impresora por USB al ordenador y utilizar Pronterface para controlarla.
Para ajustar los offsets, debes proceder así:
- Haz home a los tres ejes, por ejemplo pulsando el boton de la casita que no tiene letra.
- Cuando se pare el cabezal, con los controles de movimiento de los ejes X e Y, lleva el centro de la boquilla de impresión justo sobre la esquina delantera izquierda de la cama.
- Comprueba que el eje Z está en la posición 0 (sino muévelo a esa posición) y envía el comando M428: con eso quedan configurados los offsets de los ejes.
- Envía el comando M500 para grabarlos en la EEPROM y que no se pierdan al reiniciar la impresora.
En principio y si todo ha ido bien, ya te centraría las piezas en la cama, siempre que también lo estén en el programa de corte, pues tiene sus propios offsets (que deberían estar a 0).
  Responder
#10
(20-11-2022, 10:17 PM)Simemart escribió: Hola, si no habéis cargado vosotros el firmware, probablemente sea el de fábrica, de ahí que no indique nada al arranque: yo lo dejaría de momento, por lo menos mientras le vas cogiendo el aire al asunto.
Sobre los parámetros que indicas, supongo que con ese 105 de velocidad te refieres al parámetro que indica la pantalla como FR: si es así, no solo influye en la velocidad de impresión, también en otros aspectos de la misma, como la extrusión, por lo que es mejor dejarlo siempre en 100% y configurar las modificaciones que sean necesarias en el perfíl de impresión del programa de corte.
Si lo que utilizas es PLA, esos 220 ºC son demasiados y te dará mejores resultados configurar sobre 200-205 ºC.
Por las fotos de ese cubo, se ven algunos problemas con las capas iniciales, lo que puede indicar una regulación incorrecta de la altura inicial de impresión (punto 0 del eje Z, el que normalmente se regula con la hoja de papel), o bien una temperatura en la cama demasiado alta (55 ºC está bien, aunque puede no ser real).
Sobre el centrado de las piezas en la cama, tienes una ligera deviación hacia el lado negativo de los dos ejes (XY), bien por una configuración incorrecta de los offsets en el firmware o por unos interruptores de final de carrera desplazados de sus posiciones originales.
Primero comprueba si al llevar los ejes XY a las máximas posiciones que permite el firmware, la boquilla no llega a la esquina trasera derecha de la cama, quedandose más o menos al doble de la distancia que están desplazadas la piezas del centro: si es así, puedes modificar los offsets mediante gcode para intentar centrarlas.
Para ello, debes conectar la impresora por USB al ordenador y utilizar Pronterface para controlarla.
Para ajustar los offsets, debes proceder así:
- Haz home a los tres ejes, por ejemplo pulsando el boton de la casita que no tiene letra.
- Cuando se pare el cabezal, con los controles de movimiento de los ejes X e Y, lleva el centro de la boquilla de impresión justo sobre la esquina delantera izquierda de la cama.
- Comprueba que el eje Z está en la posición 0 (sino muévelo a esa posición) y envía el comando M428: con eso quedan configurados los offsets de los ejes.
- Envía el comando M500 para grabarlos en la EEPROM y que no se pierdan al reiniciar la impresora.
En principio y si todo ha ido bien, ya te centraría las piezas en la cama, siempre que también lo estén en el programa de corte, pues tiene sus propios offsets (que deberían estar a 0).
El marcó ,se lo he cambiado y lo más seguro que el problema de centrado ,creo que puede ser por los interruptores, no coinciden en la misma posición ,como en el marcó antiguo ,que estaba roto.
Voy a intentar hacer lo que me indicas,a ver que lio.jejeje.
Muchas gracias. 
[Imagen: 20221120-193154.jpg]
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Problema configuracion de Drivers TMC2130, Solucionado 21Curiosos 15 200 04-02-2023, 08:51 PM
Último mensaje: Simemart
  De Marlin 2.0.9 a Marlin 2.12 21Curiosos 3 153 22-01-2023, 09:36 PM
Último mensaje: 21Curiosos
  CONSULTA Configuración Marlin lambda4 55 9,373 18-10-2022, 12:52 AM
Último mensaje: akira_ve
Bombilla PROBLEMA CON CONFIGURACIÓN PASOS EXTRUSOR!!!!!!!!! mikeloliva 5 350 13-06-2022, 12:04 AM
Último mensaje: Simemart
  Marlin TH3 UFW 2.48 error eje Z AYUDA SkyManker 0 186 26-05-2022, 03:42 PM
Último mensaje: SkyManker