This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA AM8 Cambiar Placa
#21
Hola, el error se debe a que el archivo de pines de la placa tiene definido los pines serie para el eje E1, pero si lo utilizas para el segundo motor del eje Z , se convierte en el eje Z2 y si pones un TMC2209 en modo UART para controlarlo, debes cambiar la asignación de esos pines: para ello, edita el archivo pins_MKS_GEN_L_V21.h, que se encuentra en la ruta \Marlin\src\pins\ramps\ y cambia las siguientes líneas:

...
#ifndef E1_SERIAL_TX_PIN
  #define E1_SERIAL_TX_PIN                    20
#endif
#ifndef E1_SERIAL_RX_PIN
  #define E1_SERIAL_RX_PIN                    12
#endif
...


sutituyendo el E1 por Z2, quedando así:

...
#ifndef Z2_SERIAL_TX_PIN
  #define Z2_SERIAL_TX_PIN                    20
#endif
#ifndef Z2_SERIAL_RX_PIN
  #define Z2_SERIAL_RX_PIN                    12
#endif
...


Con eso ya compilarás sin errores.
  Responder
#22
(25-11-2022, 11:26 PM)Simemart escribió: Hola, el error se debe a que el archivo de pines de la placa tiene definido los pines serie para el eje E1, pero si lo utilizas para el segundo motor del eje Z , se convierte en el eje Z2 y si pones un TMC2209 en modo UART para controlarlo, debes cambiar la asignación de esos pines: para ello, edita el archivo pins_MKS_GEN_L_V21.h, que se encuentra en la ruta \Marlin\src\pins\ramps\ y cambia las siguientes líneas:

...
#ifndef E1_SERIAL_TX_PIN
  #define E1_SERIAL_TX_PIN                    20
#endif
#ifndef E1_SERIAL_RX_PIN
  #define E1_SERIAL_RX_PIN                    12
#endif
...


sutituyendo el E1 por Z2, quedando así:

...
#ifndef Z2_SERIAL_TX_PIN
  #define Z2_SERIAL_TX_PIN                    20
#endif
#ifndef Z2_SERIAL_RX_PIN
  #define Z2_SERIAL_RX_PIN                    12
#endif
...


Con eso ya compilarás sin errores.


OK, pero me sigue saliendo error de conexión tmc (mensaje sale en el LCD), conectado a través de la fuente de alimentación.

No se que estaré haciendo mal.

Como comentaste he movido los ejes y es super silencioso comparado con el original, lastima no haberlo sabido antes.

Puede ser que necesite conectar una resistencia de 1K? en esta placa no es necesario hacer eso o eso creo
  Responder
#23
Acabo de editar el marlin para ponerlos en STANDALONE y cambiar los jumper del modo UART a STANDALONE y no aparece el error de conexión tmc, vaya dolor de cabeza me esta dando Triste
Estoy mas perdido que el barco del arroz
  Responder
#24
¿Estás comprobando con la alimentación normal (12V o 24V, la que uses), no con la del conector USB? Porque con esta última dan error los TMC.
¿Qué información te da el comando M122?
  Responder
#25
(26-11-2022, 10:34 AM)Simemart escribió: ¿Estás comprobando con la alimentación normal (12V o 24V, la que uses), no con la del conector USB? Porque con esta última dan error los TMC.
¿Qué información te da el comando M122?

Esta conectado con la fuente de 12V de 20Amp, y esto es lo que sale con M122:


ENVIADO: M122
LECTURA: X Y Z Z2 E
LECTURA: Address 0 0 0 0 0
LECTURA: Enabled false false false false false
LECTURA: Set current 800 800 800 800 800
LECTURA: RMS current 1436 1436 1436 1436 1436
LECTURA: MAX current 2025 2025 2025 2025 2025
LECTURA: Run current 25/31 25/31 25/31 25/31 25/31
LECTURA: Hold current 12/31 12/31 12/31 12/31 12/31
LECTURA: CS actual 0/31 0/31 0/31 0/31 0/31
LECTURA: PWM scale
LECTURA: vsense 0=.325 0=.325 0=.325 0=.325 0=.325
LECTURA: stealthChop false false false false false
LECTURA: msteps 256 256 256 256 256
LECTURA: interp false false false false false
LECTURA: tstep 0 0 0 0 0
LECTURA: PWM thresh. 1290 1290 10702 10702 4216
LECTURA: [mm/s] 100 100 3 3 30
LECTURA: OT prewarn false false false false false
ENVIADO: M105
LECTURA: pwm scale sum 0 0 0 0 0
LECTURA: pwm scale auto 0 0 0 0 0
LECTURA: pwm offset auto 0 0 0 0 0
LECTURA: pwm grad auto 0 0 0 0 0
LECTURA: off time 0 0 0 0 0
LECTURA: blank time 16 16 16 16 16
LECTURA: hysteresis
LECTURA:  -end -3 -3 -3 -3 -3
LECTURA:  -start 1 1 1 1 1
LECTURA: Stallguard thrs 0 0 0 0 0
LECTURA: uStep count 0 0 0 0 0
LECTURA: DRVSTATUS X Y Z Z2 E
LECTURA: sg_result 0 0 0 0 0
LECTURA: stst * * * * *
LECTURA: olb
LECTURA: ola
LECTURA: s2gb
LECTURA: s2ga
LECTURA: otpw
LECTURA: ot
LECTURA: 157C
LECTURA: 150C
LECTURA: 143C
LECTURA: 120C
ENVIADO: M105
LECTURA: s2vsa
LECTURA: s2vsb
LECTURA: Driver registers:
LECTURA: X 0x00:00:00:00 Bad response!
LECTURA: Y 0x00:00:00:00 Bad response!
LECTURA: Z 0x00:00:00:00 Bad response!
LECTURA: Z2 0x00:00:00:00 Bad response!
LECTURA: E 0x00:00:00:00 Bad response!
LECTURA:
LECTURA:
LECTURA: Testing X connection... Error: All LOW
LECTURA: Testing Y connection... Error: All LOW
LECTURA: Testing Z connection... Error: All LOW
LECTURA: Testing Z2 connection... Error: All LOW
LECTURA: Testing E connection... Error: All LOW
LECTURA: ok
LECTURA: ok T:16.47 /0.00 B:17.72 /0.00 @:0 B@:0
LECTURA: ok T:16.47 /0.00 B:17.72 /0.00 @:0 B@:0
ENVIADO: M105
LECTURA: ok T:16.83 /0.00 B:17.41 /0.00 @:0 B@:0

Pienso que falla la comunicacion rx tx o que los drivers estos no sirvan.
https://es.aliexpress.com/item/100500460...pt=glo2esp
  Responder
#26
Por lo que indica el reporte, los TMC no están conectados a UART: ¿cómo tienes configurados los puentes debajo de los drivers?
  Responder
#27
(26-11-2022, 02:50 PM)Simemart escribió: Por lo que indica el reporte, los TMC no están conectados a UART: ¿cómo tienes configurados los puentes debajo de los drivers?

Asi en los 5 drivers
[Imagen: mks.png]
  Responder
#28
En la foto que pusiste en #5, veo que tienes el puente de Drive IC Power en 3,3V, pero para esta placa tiene que estar en 5V: probablemente sea ese el problema.
  Responder
#29
Eso era. 

Muchas gracias
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Cambiar tamaño de cama mediante Gcode o pantalla. Damian Marcelo 17 1,795 12-12-2021, 01:05 AM
Último mensaje: Simemart
  Cambiar el Z_SAFE_HOMING del autolevel a una esquina de la cama Hugo43 3 766 19-07-2021, 01:27 AM
Último mensaje: Simemart
  MKS ROBIN E3D eje z no responde después de cambiar el firmware Xucu 1 1,206 11-01-2021, 01:39 AM
Último mensaje: mangelh
Fotografía [MARLIN] Cambiar logo inicial con Bootscreen.h jukillo 10 11,906 04-01-2021, 11:06 PM
Último mensaje: Forever
  Cambiar velocidad por defecto del extrusor en modo manual kokeeeeee 3 1,397 10-04-2020, 11:12 AM
Último mensaje: kokeeeeee