This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
MKS SGEN L1.0 + TMC2209
#1
Hola hace unos meses se me quemó la placa, la mayoría de drivers y el bltouch.

Como tenía que comprar nuevo y no había stock, compré la MKS SGEN L v1.0 con los TMC 2209 v2.0 de Makerbase y un nuevo bltouch.

Pues bien, después de meses, el único firmware que me deja usar la máquina es el de kind3r: 

Firmware-Molise-Artillery/MksGenLv1_to_MksSGenLv1_pins.md at 38816a65bb862cdf50d9285e38ebb213c1baf3f7 · Dtcreation/Firmware-Molise-Artillery (github.com)

Venía usando un mod de DTCreation que esta muy bien, pero no quiere funcionar y me ocurre esto:

https://drive.google.com/file/d/1lSqhQBk...sp=sharing

¿Alguno tiene idea de que puede ser? He probado mil cosas, pero sin llegar a arreglar nada.

Muchisisimas gracias.
  Responder
#2
Hola, ese firmware que enlazas no es más que un Marlin 2.0.9.2, aunque algo retocado para facilitar su configuracion en algunos tipos de impresoras y placas, pero no tiene nada de especial en otro sentido.
El problema que muestra ese vídeo es de pérdida de pasos en los motores, pero no se aprecia bien en qué ejes sucede y si es debido a que no se activan los finales de carrera, a que se bloquean por demasiada velocidad/aceleración o porque no deslizan de forma correcta: tendrás que hacer homing por separado en cada eje para saberlo.
  Responder
#3
(06-03-2022, 03:35 PM)Simemart escribió: Hola, ese firmware que enlazas no es más que un Marlin 2.0.9.2, aunque algo retocado para facilitar su configuracion en algunos tipos de impresoras y placas, pero no tiene nada de especial en otro sentido.
El problema que muestra ese vídeo es de pérdida de pasos en los motores, pero no se aprecia bien en qué ejes sucede y si es debido a que no se activan los finales de carrera, a que se bloquean por demasiada velocidad/aceleración o porque no deslizan de forma correcta: tendrás que hacer homing por separado en cada eje para saberlo.

Hola @Simemart, no no es una pérdida de pasos. Con el firmware de kind3r puedo imprimir sin problemas. Así que descarto un problema de hardware y lo achaco más a un problema de software. Así que debe ser algo que no encuentro en el Marlin. El problema es que cuando le digo a la máquina que haga home, en vez de irse al medio y con el bltouch hacer homming, se va a una esquina y aunque el sensor "detecte" sigue bajando, como si la señal del bltouch no la tuviera en cuenta.

La pregunta es a ver si alguno le suena y me da luz a intentar encontrar en que sección es.
  Responder
#4
@rafalitens, puedes estar seguro de que ese ruido corresponde a uno o varios motores perdiendo pasos: que no suceda durante las impresiones, no implica que no lo haga al hacer el home, como es el caso.
Bien por las velocidades configuradas para el homing, bien porque tienes un sensor y estará configurado el Z Safe Home (esta funcionalidad realiza un movimiento coordinado de los ejes X e Y, para llevar el cabezal de impresión al centro de la cama para hacer el home del eje Z y dicho movimiento se realiza por defecto a 133 mm/s), alguno de esos ejes (yo diría que los dos) pierden pasos y por eso el home del eje Z no lo hace en el centro de la cama.
Cambia las siguientes líneas:

#define XY_PROBE_FEEDRATE (60*60)
#define Z_PROBE_FEEDRATE_FAST (6*60)
#define HOMING_FEEDRATE_MM_M { (60*60), (60*60), (6*60) }


graba el firmware, sin olvidarte de refrescar la memoria EEPROM y ya me dices.
Sobre la detección del BL-Touch, puede que ese sea otro problema aparte del anterior.
  Responder
#5
@Simemart, va más lento pero sigue con el mismo problema, parece que aunque el bltouch lee que hay contacto no para y continua bajando:

https://drive.google.com/file/d/1ikiUIOu...sp=sharing

Tengo lo drivers configurados en placa como UART:

https://youtu.be/vSgcH2wjCwY
https://youtu.be/eF8Mqa2Y3oo

Y el cableado de Kind3r:

[Imagen: 140608506-9bbf00e2-f2c6-4c44-afa2-1d70d6568433.png]

Mil gracias por la ayuda.
  Responder
#6
Para ver ese vídeo, me exige inciar sesión en Google: ¿sigue haciendo el ruido del anterior y sin realizar el home de Z en el centro de la cama?
  Responder
#7
(06-03-2022, 09:30 PM)Simemart escribió: Para ver ese vídeo, me exige inciar sesión en Google: ¿sigue haciendo el ruido del anterior y sin realizar el home de Z en el centro de la cama?

Arreglado lo del video.
  Responder
#8
Es bastante raro lo que sucede al hacer el home, ¿tienes interruptores de final de carrera físicos o estás utilizando el sensorless?
Y si no lo tienes configurado, ¿habrás quitado los puentes correspondientes al pin DIAG, no?
  Responder
#9
(06-03-2022, 10:02 PM)Simemart escribió: Es bastante raro lo que sucede al hacer el home, ¿tienes interruptores de final de carrera físicos o estás utilizando el sensorless?
Y si no lo tienes configurado, ¿habrás quitado los puentes correspondientes al pin DIAG, no?

//#define SENSHOME                                  // Active sensorless homing ONLY for TMC 2208 UART and 2009 UART with SKR 1.3 (extra wiring needed) and SKR 1.4 (no extra wiring needed)

Y tengo todos los DIAG de la placa con su JUMPER.

Me dices que lo active y que le quite el JUMPER a DIAGX o todos los JUMPERS a los DIAG{X-Y-Z-X+,Y+}
  Responder
#10
Si no utilizas el sensorless, tienes que quitar todos los puentes DIAG de la placa.
Puede que sea eso el problema, pues aunque no esté activado en el firmware el sensorless, como lo que hacen los puentes es conectar el pin DIAG del driver con el conector de final de carrera del eje correspondiente, se está generando la señal de final de carrera sin que se activen los interruptores, de ahí que no funcione de forma correcta el home: quita todos esos puentes y prueba a ver si se ha solucionado el problema.
  Responder
#11
Vale, vamos avanzando, ahora hace otra cosa.

Sin SENSORLESS y con todos los JUMPERS quitados.

https://drive.google.com/file/d/1pJBGwK0...sp=sharing

Sin SENSORLESS y con JUMPERS, hace lo mismo que el video anterior.
Con SENSORLESS y con JUMPERS, hace lo mismo que el video anterior.
Con SENSORLESS y sin JUMPERS, se va al final como el video anterior pero no baja.

La mejor opción es Sin SENSORLESS y sin JUMPERS quitados, pero da error en el bltouch.
  Responder
#12
La configuración correcta si tienes interruptores físicos de final de carrera, es sin Sensorless y sin los puentes: ese ya es el homing correcto de los ejes X e Y, con el desplazamiento al centro de la cama del Z Safe Home.
Ahora el problema está en el BL-Touch, que no está funcionando bien, lo que puede deberse a un conexionado o configuración incorrectos o a que esté averiado el propio dispositivo.
Ese firmware que estás utilizando no facilita mucho encontrar los problemas de configuración: no estaría mal cambiar a un Marlin oficial, bien configurado para variar.
  Responder
#13
@Simemart es el marlin de DtCreation.

Con el Marlin de Kind3r, aunque tengo algún que otro error porque se le va la olla con el posicionamiento de x e y, si que funciona todo perfectamente.

Lo jodido es que con el 2.0.7.2-1 tengo los pines de DIAG colocados y el sensorless activado y no se queja para nada:

#define SENSORLESS_HOMING // StallGuard capable drivers only

#if EITHER(SENSORLESS_HOMING, SENSORLESS_PROBING)
// TMC2209: 0...255. TMC2130: -64...63
#define X_STALL_SENSITIVITY 140
#define X2_STALL_SENSITIVITY X_STALL_SENSITIVITY
#define Y_STALL_SENSITIVITY 140
#define Y2_STALL_SENSITIVITY Y_STALL_SENSITIVITY
//#define Z_STALL_SENSITIVITY 8
//#define Z2_STALL_SENSITIVITY Z_STALL_SENSITIVITY
//#define Z3_STALL_SENSITIVITY Z_STALL_SENSITIVITY
//#define Z4_STALL_SENSITIVITY Z_STALL_SENSITIVITY
//#define SPI_ENDSTOPS // TMC2130 only
//#define IMPROVE_HOMING_RELIABILITY
#endif

Lo acabo de probar, ahora te subo video.

Me esta rayando que la única cosa que veo diferente es y que hace un juego con los invert de los motores dependiendo del estado activo o desactivado del sensorless_homing pero esto ya lo he probado también a dejarlo como el de kind3r y por supuesto la versión que es la última:

//
// M43 - display pin status, toggle pins, watch pins, watch endstops & toggle LED, test servo probe
//
#define PINS_DEBUGGING
  Responder
#14
No acabo de entender a que te refieres cuando hablas de un Marlin de Kind3r o de uno de DtCreation: en los enlaces que pusiste en tu primer mensaje solo hay uno, el Molise, que es el que estoy mirando desde el principio: de ese kind3r que mencionas no tengo constancia.
En todo caso, vuelvo a repetir que es liarse para nada utilizar estos firmwares multi configuración.
Sobre el sensorless, solo hay dos posibles formas de configurar los finales de carrera y hay que decidirse por una opción u otra: con interruptores/sensores, para lo que hay que desactivar en el firmware el sensorless y quitar los puentes DIAG en la placa o sin interruptores/sensores (modo sensorless), para lo que hay que hacer lo contrario.
Si con un firmware te funciona bien el BL-Touch y con otro no, seguramente el problema esté en la configuración del que no funciona bien.
  Responder
#15
Firm de Kind3r: https://github.com/kind3r/genius-firmware-mks-sgen-l
Firm de DTCreation: https://github.com/Dtcreation/Firmware-Molise-Artillery el que ves...

Pues la verdad es que en esto me pillas, bastante tengo con entender algo de lo que voy tocando. Pero si debe ser algo del firm, como te dije al principio.

El problema vino que se me quemó la placa y bueno en stock solo encontré la mks Sgen l que con el primer firm me ha ido bien, sin embargo con el segundo con los menus y sobre todo el terminal (así ya no tengo que usar pronterface) pues me encantó. Pero bueno, he activado casi todas las opciones en el de kind3r a base de ir pillando y comparando firms. Pero el engorro de la mjs sgen l que si quieres actualizar marlin hay que hacerlo por micro-sd en la placa, así que imagínate cada vez que tengo que probar algo del firm, quita la tapa, quita la placa, pon la microsd, enciende, carga, pon la tapa, endereze la impresora....

En fin, doy por cerrado el tema y ya lo que me toca es seguir probando a ver si doy con la tecla de lo que es. Si lo encuentro volveré a postearlo por aquí.

Mil gracias @Simemart por el apoyo y la ayuda.
  Responder
#16
Ese Marlin de Kind3r ya es otra cosa, con una configuración para una sola máquina, mucho más razonable de cara a la configuración y el mantenimiento.
En todo caso, mi recomendación es que desactives el sensorless y quites los puentes DIAG de la placa: teniendo los finales de carrera mecánicos instalados, tendrás menos problemas si no lo utilizas.
Respecto al BL-Touch, la configuración parece correcta, por lo que o lo tienes mal conectado en la placa o está averiado el sensor.
Ese Marlin está configurado para utilizar esta conexión:

[Imagen: Img1.jpg]

Por otra parte, conviene que cámbies la siguiente línea en el archivo Configuration_adv.h:

//#define BLTOUCH_HS_MODE

y estas otras dos en el Configuration.h:

#define XY_PROBE_SPEED 3600
#define HOMING_FEEDRATE_Z  (6*60)


Si das por cerrado el tema, nada más por mi parte.
Un saludo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Ayuda con MKS GEN L 1v.0 Artillery Genius rgl3dprint 44 13,185 27-10-2020, 01:11 PM
Último mensaje: Simemart