This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino nano y servo de rotación continua
#1
Buenas a todos
Estoy haciendo un control para un sistema de radiocontrol en el que tengo un servo de rotación continua y detectores de posición puestos en su periferia para detectar unas posiciones concretas.
Estoy teniendo un problema que no se por donde puede venir.
El sistema está formado por un arduino nano, un servo de rotación continua, relés reed, un receptor RC y una fuente de alimentación a 5v para alimentar
Al conectar la alimentación a mi sistema, el servo se pone a girar solo. El servo está gobernado por una salida PWM, la cual al inicio del programa pongo a valor 1500 para que se quede en posición neutra. Pero no lo hace. El caso es que una vez iniciado, si le pulso el botón de reset del arduino, se detiene y ya obedece al programa.
Por el monitor serie puedo ver que el valor 1500 permanece estable aunque vea al servo girar.

¿Le ha ocurrido a alguien algo semejante?

Gracia de antemano
  Responder
#2
He insertado un condensador electrolítico de 10 uF y otro de poliéster de 100nF en paralelo con la alimentación para evitar que por alguna caída de tensión me genere problemas. Además he insertado un retraso en la sentencia void setup para evitar la ejecución inmediata del programa y nada.
Por tanto, por esa causa no creo que sea.
  Responder
#3
Bien, siguiendo con las pruebas, he probado a cambiar la instrucción

myservo.writeMicroseconds (...) por la myservo.write(...)

y parece que va bien. Ignoro porque no le gusta que le de la orden en ancho de impulso en vez de grados de giro. Salvo una pequeña deriva que he tenido que tantear, el programa parece que funciona. Seguiré con las pruebas, pero ¿porque no es equivalente un método que el otro?
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  problemas arduino nano generico Lejisan 2 515 12-07-2021, 01:25 PM
Último mensaje: asesorplaza1
  Funcionamiento incorrecto servo Bear 1 356 28-05-2021, 06:48 PM
Último mensaje: Bear
  CONSULTA arduino nano electronica914 2 2,269 31-07-2019, 03:25 PM
Último mensaje: Iván
Pregunta Circuito de carga para Arduino Nano Electromecánico 8 3,260 18-06-2019, 03:29 PM
Último mensaje: Popeye
  Problema con motores y Arduino Nano Jericonsio 2 1,922 21-03-2019, 05:52 AM
Último mensaje: Jericonsio