This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA como configurar sensor inductivo sn04 y eje z_safe_min
#1
Dedo abajo 
Estimados primero que nada que tal espero que estén muy bien  ( o mejor que yo ) dado a que hace poco compre un sensor inductivo sn04 el cual funciona perfecto lo he probado y va de lujo pero me encuentro con un problema al intentar configurarlo en marlin 2.0.9.2

para que esten al tanto les comento lo que tengo

hardware:

arduino mega 2560
ramps 1.4
lcd full graphic smart controller
Drivers A4988
cama caliente
Sensor de filamente ( aun no lo he activado  ni modificado nada )
la impresora es una Clone wars: Prusa iteración 3 ( es reciclada todo muy artesanal )


software:
Marlin 2.0.9.2
Visual Studio Code + Platformio

El problema:


el tema es el siguiente sigo todos los pasos para activar el sensor y que funcione sin el eje z_min dado a que activo la auto nivelación para que lo haga en el centro de la cama pero al configurar todos los parámetros me arroja el siguiente error al intentar compilar 

#error "disable_[xyzijk] is not compatible with home_after_deactivate or z_safe_homing."

este error me o arroja al activar las siguientes opciones 
les adjunto mi archivo de configuracion.h por si alguien lo quiere ver y darme una mano hace ya una semana que no le puedo encontrar una solución


desde ya muchas gracias a todos!


Archivos adjuntos
.txt   CONFIGURATION.H.txt (Tamaño: 111.12 KB / Descargas: 2)
  Responder
#2
Revisa que no sea esto lo que te está dando problemas

https://reprap.org/forum/read.php?152,504042

Tienen que estar así
//https://reprap.org/forum/read.php?152,504042
  Responder
#3
primero que nada muchas gracias por responder tan pronto te comento echare un vistazo a lo que me has mencionado pero mi impresora es cartesiana digamos de las normales 

es asi 

[Imagen: I3-boxframe.jpg]
  Responder
#4
Hola, si como supongo tienes conectado el sensor en el conector de Z-, hay varias cosas mal configuradas (con adjuntar el archivo es suficiente, sino se dificulta mucho la lectura del post).
Debes comentar (poner // delante) las líneas de los endstops de los ejes que no se utilizan (todos menos X_MIN, Y_MIN y Z_MIN).
Tienes el punto para realizar el home de Z en X=2 Y=2. Si quieres que lo haga en el centro de la cama, tendrás que configurar dicho punto, por ejemplo así:

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2)
  #define Z_SAFE_HOMING_Y_POINT ((Y_BED_SIZE) / 2)
#endif


No tienes definido el parámetro con los offsets del sensor (NOZZLE_TO_PROBE_OFFSET), no se si tienes alguna razón para ello.
  Responder
#5
(06-10-2021, 01:10 PM)Simemart escribió: Hola, si como supongo tienes conectado el sensor en el conector de Z-, hay varias cosas mal configuradas (con adjuntar el archivo es suficiente, sino se dificulta mucho la lectura del post).
Debes comentar (poner // delante) las líneas de los endstops de los ejes que no se utilizan (todos menos X_MIN, Y_MIN y Z_MIN).
Tienes el punto para realizar el home de Z en X=2 Y=2. Si quieres que lo haga en el centro de la cama, tendrás que configurar dicho punto, por ejemplo así:

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2)
  #define Z_SAFE_HOMING_Y_POINT ((Y_BED_SIZE) / 2)
#endif


No tienes definido el parámetro con los offsets del sensor (NOZZLE_TO_PROBE_OFFSET), no se si tienes alguna razón para ello.


Simemart ahi modifique el post para que seas mas comodo para los usuarios ya que creo que si era mucha info pero mas que nada lo habia colocado para las personas que no quieren descargar archvos jaja


respecto a tu pregunta de por que no tengo definido el NOZZLE_TO_PROBE_OFFSET es por que no sabia que lo debía definir digamos las opciones que yo pensé que debía habilitar y las que me guie de mucho tutoriales fueron las  que vez en el archivo creeme que intente de todo pero llega un momento que después de 4 días dándole ya estaba quemado lo probare y si hay alguna novedad os comento

nada ahi subi nuevamente el archivo modificado pero persiste el bendito y maldito error

In file included from Marlin\src\HAL\AVR\../../inc/MarlinConfig.h:49:0,
                from Marlin\src\HAL\AVR\HAL.cpp:24:
Marlin\src\HAL\AVR\../../inc/SanityCheck.h:1866:6: error: #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
    #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
      ^~~~~
In file included from Marlin\src\HAL\AVR\../../inc/MarlinConfig.h:49:0,
                from Marlin\src\HAL\AVR\HAL_SPI.cpp:34:
Marlin\src\HAL\AVR\../../inc/SanityCheck.h:1866:6: error: #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
    #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
      ^~~~~
In file included from Marlin\src\HAL\AVR\../../inc/MarlinConfig.h:49:0,
                from Marlin\src\HAL\AVR\MarlinSerial.cpp:39:
Marlin\src\HAL\AVR\../../inc/SanityCheck.h:1866:6: error: #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
    #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
      ^~~~~
In file included from Marlin\src\HAL\AVR\../../inc/MarlinConfig.h:49:0,
                from Marlin\src\HAL\AVR\Servo.cpp:55:
Marlin\src\HAL\AVR\../../inc/SanityCheck.h:1866:6: error: #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
    #error "DISABLE_[XYZIJK] is not compatible with HOME_AFTER_DEACTIVATE or Z_SAFE_HOMING."
      ^~~~~
*** [.pio\build\mega2560\src\src\HAL\AVR\HAL.cpp.o] Error 1
*** [.pio\build\mega2560\src\src\HAL\AVR\MarlinSerial.cpp.o] Error 1
  Responder
#6
Ok, se me había olvidado el error y pasé por alto esa configuración.
El error es debido a que tienes a true los parámetros DISABLE_X, DISABLE_Y y DISABLE_Z: ponlos a false y ya no te dará el error, pues no se pueden activar cuando se define el Z Safe Homing.
Sobre los probe offsets, si los tutoriales que has mirado sobre el tema no hablan de ellos, mejor no los tengas en cuenta, pues no tienen mucha idea de lo que hablan.
Si no se definen, el firmware no podrá saber si el sensor sale de la superficie de impresión y cómo posicionarlo de forma correcta para realizar las mediciones.
Tienes que medir la distancia a que se encuentra el centro del sensor respecto del centro de la boquilla en los ejes X e Y y ponerlo en la matriz del parámetro, con signo negativo si el sensor queda más cerca que la boquilla del punto 0 del eje correspondiente.
El de Z hay que ajustarlo de forma empírica, por ejemplo como indico en esta respuesta.
  Responder
#7
(06-10-2021, 06:44 PM)Simemart escribió: Ok, se me había olvidado el error y pasé por alto esa configuración.
El error es debido a que tienes a true los parámetros DISABLE_X, DISABLE_Y y DISABLE_Z: ponlos a false y ya no te dará el error, pues no se pueden activar cuando se define el Z Safe Homing.
Sobre los probe offsets, si los tutoriales que has mirado sobre el tema no hablan de ellos, mejor no los tengas en cuenta, pues no tienen mucha idea de lo que hablan.
Si no se definen, el firmware no podrá saber si el sensor sale de la superficie de impresión y cómo posicionarlo de forma correcta para realizar las mediciones.
Tienes que medir la distancia a que se encuentra el centro del sensor respecto del centro de la boquilla en los ejes X e Y y ponerlo en la matriz del parámetro, con signo negativo si el sensor queda más cerca que la boquilla del punto 0 del eje correspondiente.
El de Z hay que ajustarlo de forma empírica, por ejemplo como indico en está respuesta.


ERES UN MAQUINA te amo de verdad ya pude compilar ahora a probar si hace bien todos los pasoso 

con los comandos g28 y g29  en repetier 

por otro lado algo que me incomoda un poco es tener los motores activado cuando el equipo no hace nada digamos al deshabilitar las opciones indicadas los motores estan trabajando siempre 

es decir ahora los tengo asi 

// Disable axis steppers immediately when they're not being stepped.
// WARNING: When motors turn off there is a chance of losing position accuracy!
#define DISABLE_X false
#define DISABLE_Y false
#define DISABLE_Z false


antes los tenia en true lo cual permitía que no esten trabados en todo momento es normal que hagan un pequeño zumbido los motores ? o es por que tengo demasiado voltaje en los mim

esto ya es otro tema y lo tengo bastante claro pero SINCERAMNETE TE LO SUPER AGRADEZCO a vos y a esta linda comunidad  me salvaste
  Responder
#8
Que los motores se queden activados un tiempo después de realizar los movimientos no es un problema: por el contrario, en muchas situaciones es conveniente que así sea (cuando se necesita mantener la posición inalterada).
El tiempo que tardan los motores en desactivarse después de un movimiento, se configura en el parámetro DEFAULT_STEPPER_DEACTIVE_TIME, que se encuentra en el archivo Configuracion_adv.h: por defecto está configurado en 120 segundos.
Si vibran mucho los motores cuando están activados y parados, puede que esté regulada muy alta la intensidad en los drivers: el valor correcto es el mínimo que permita que el eje se mueva de forma correcta (sin perder pasos).
  Responder
#9
(06-10-2021, 08:03 PM)Simemart escribió: Que los motores se queden activados un tiempo después de realizar los movimientos no es un problema: por el contrario, en muchas situaciones es conveniente que así sea (cuando se necesita mantener la posición inalterada).
El tiempo que tardan los motores en desactivarse después de un movimiento, se configura en el parámetro DEFAULT_STEPPER_DEACTIVE_TIME, que se encuentra en el archivo Configuracion_adv.h: por defecto está configurado en 120 segundos.
Si vibran mucho los motores cuando están activados y parados, puede que esté regulada muy alta la intensidad en los drivers: el valor correcto es el mínimo que permita que el eje se mueva de forma correcta (sin perder pasos).

perfecto muchas gracias por toda la ayuda y la dudas  la verdad me ha quedado funcionando de 10 ahora solo me falta calibrar el centro de la cama y como hacer para que mida la superficie de la cama jaja pero eso ya es otra cosa estoy mirando tutoriales 

te mando un fuerte abrazo desde argentina
  Responder
#10
Me alegro que lo hayas solucionado.
Un saludo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
Triste CONSULTA Actualizando Marlin, TMC2130, LCD y Sensor de filamento betowars 21 711 26-12-2021, 11:28 PM
Último mensaje: betowars
  CONSULTA Ender 3X no puedo configurar para cambio de color juanfortus 5 412 27-06-2021, 11:28 AM
Último mensaje: Simemart
  Del eje z al eje y xan 4 642 12-01-2021, 12:35 AM
Último mensaje: Simemart
  Problemas con la temperatura (sensor) Bear 0 474 22-03-2020, 08:05 PM
Último mensaje: Bear
  Configurar Pantalla Marlin Valurian 4 2,292 11-02-2020, 10:05 PM
Último mensaje: Simemart