This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Instalando Marlin para ENDER 3 PRO
#61
Muchisimas gracias, voy con ello esta tarde noche.
  Responder
#62
Buenas, todo hecho, pero al dar a guardar todo, me han aparecido estos 2 errores

[Imagen: errores.jpg]
  Responder
#63
Esos errores son los que detecta el comprobador de sintaxis de C++ del editor y no deberían impedir compilar y subir el firmware: ¿has intentado hacer la compilación para ver si te da algún error?
  Responder
#64
Bajo mi modesta opinión, creo que ni la version bugfix 2.0.x esta lo suficientemente depurada como para ser fiable para mi placa, te explico, con el entorno melzy_optiboot_optimized, siempre me ha dado compilación incompleta, pero con el entorno melzy_optiboot o melzy_optimized, a veces si, a veces no, luego entonces deduzco lo dicho. Yo creo que es "demasiado" Marlin para mi placa.

[Imagen: error.jpg]

Me voy as descargar el paquete unificado 1 de la pagina TH3D , que es para placas de 8 bits, que seguro que para lo que yo lo quiero, me vale de sobra.  Siento que estoy perdiendo demasiado tiempo de mi vida con esto, y aunque se lo que hago lo tengo todo como muy "descontrolado", esto es un mundo inmenso, sino lo instalo como indica el manual y acabo antes, me quedo sin offsets, no pasa nada, me adapto y listo. Los micropasos los pongo a 130 cada vez que enciendo la impresora y listo. 
La culpa de quien me recomendó una impresora obsoleta en otro foro.

Y nosotros, porque al principio en el VSCode, no creamos un proyecto para instalar el marlin  Icon_question

Por cierto como se limpia el Visual Studio Code, digamos como se deja  como cuando te lo instalas y se ejecuta por 1ª vez Icon_question
  Responder
#65
Naturalmente, eres libre de hacer lo que quieras, pero te aseguro que las razones que indicas para ello no tienen ningún fundamento: la versión 2.0.x-bugfix está muy depurada y la utilizan millones de usuarios en el mundo, tanto con placas de 8 bits (entre los que me incluyo) como de 32 bits.
Para ello, tiene una filosofía distinta de trabajo a la versión 1, ya que tiene separados los kernels y cuando se compila, utiliza el adecuado para el tipo de placa de que se trate (8 bits o 32 bits): eso es el entorno (environment) que te indica Auto Build Marlin a la hora de compilar.
Por descontado que la versión de Marlin que estás utilizando se puede usar sin ningún problema en esa placa, hay miles de usuarios que lo están haciendo.
Y como es lógico, todo lo que te he indicado a realizar en el proceso de compilación, lo he comprobado yo antes (siempre lo hago) y funciona de forma correcta, así que algo estás haciendo que no te deja en tu caso.
  Responder
#66
Pues si esta mas que probado, sigo con ello entonces, parto de 0, yo me lo he imprimido todo y voy con atención.

Me permites que sustituya también el config.h y el config_adv.h que carga al principio de todo el proceso, por los de mi Ender 3 PRO V1  Icon_question es que así he comprobado que ya no tengo  cambiar tantas cosas ,  es mas he tenido compilaciones sin errores así, algo abré liado despues de la 1ª compilación correcta, me pregunto algo del workspace y ya no se ni a que le dí.

Explico mis pasos:

1.- instalar el nuevo uninstaller pro v.trial, y me he cargado todo de una vez, VSCode y Marlin, una maravilla, así parto de 0.

2.-Instalo marlin bugfix 2.0.x de este link Marlin bugfix 2.0.x

3.- Descomprimo el archivo .zip y genero las carpeta que utilizaré posteriormente en el escritorio o Desktop.

4.- Me descargo el VSCode esa versión, ejecuto, e instalo las dos extensiones mi idioma, y dejo el C y C++ que por otra parte, yo no he instalado.

[Imagen: 5.png]
  Responder
#67
No puedes utilizar los archivos de configuración de una versión antigua con una nueva: haz todo como te he indicado o no llegarás a buen puerto.
  Responder
#68
Perfecto, así lo haré, de hecho todavia no los he sustituido
  Responder
#69
De VSC, descarga la versión User Instaler Stable e instálala haciendo doble click sobre el archivo, con todas las opciones por defecto (pulsa siguiente a todo).
Instala las extensiones PlatformIO y Auto Build Marlin, si no siguen instaladas (ahí verás si realmente funciona ese uninstaller tan bien).
  Responder
#70
(10-02-2022, 01:21 PM)Simemart escribió: De VSC, descarga la versión User Instaler Stable e instálala haciendo doble click sobre el archivo, con todas las opciones por defecto (pulsa siguiente a todo).
Instala las extensiones PlatformIO y Auto Build Marlin, si no siguen instaladas (ahí verás si realmente funciona ese uninstaller tan bien).

Tán bien no funciona, porque el Autobuild y el idioma son los únicos que he tenido que poner , si bien el icono del platformIO al principio no aparecía, y "voila" apareció posteriormente. Clap

Estas son antiguas  Icon_question

[Imagen: antiguos.jpg]

Si son  las bugfix 2.0.x Nusenuse
  Responder
#71
Porqué dices que son antiguas?
  Responder
#72
(10-02-2022, 01:12 PM)Simemart escribió: No puedes utilizar los archivos de configuración de una versión antigua con una nueva: haz todo como te he indicado o no llegarás a buen puerto.

Por esto que me dijiste , creo que ha habido un malentendido, no importa.

Es que a ver, yo verifico todo lo que hay que cambiar, pero si sobrescribo ese par de archivos, hay defines  que ya no tengo que tocar porque vienen como tú me indicaste, p.ej el nombre , algún true, algunas dobles lineas horizontales ya vienen activadas o desactivadas...  De hecho , ya hice compilaciones correctas de esta forma, y así verifico todo, pero tengo que cambiar menos instrucciones , entonces esas configuraciones valen verdad  Icon_question
  Responder
#73
Lo siento, pero no estás siguiendo al pie de la letra el proceso que te he indicado: vuelve a leer bien los archivos que tienes que copiar de la carpeta de archivos preconfigurados de Marlin.
  Responder
#74
(10-02-2022, 03:46 PM)Simemart escribió: Lo siento, pero no estás siguiendo al pie de la letra el proceso que te he indicado: vuelve a leer bien los archivos que tienes que copiar de la carpeta de archivos preconfigurados de Marlin.

Vale, disculpa, ya lo sigo todo al pie de la letra.
  Responder
#75
Bueno , es que a mi me gusta mucho "trastear" de todas formas, he conseguido compilar Mola , pero ya no tengo esa compilación, no importa, ya contaré mis experiencias.

A todo esto esto, como puedo borrar todo eso, no veo el delete por ningún sitio, que se borren los registros relacionados con también, y si hago click con el botón derecho del ratón, no me aparece la opción, como se hace  Icon_question

[Imagen: uu.png]
  Responder
#76
Para dejar limpio el editor de VSC, hay que ir al menú Archivo y seleccionar la opción Cerrar carpeta.
VSC guarda toda la información del estado de ese proyecto por lo que, al abrir de nuevo la carpeta, estará igual que cuando se cerró (si no se modifica fuera de él, claro).
  Responder
#77
(11-02-2022, 10:01 PM)Simemart escribió: Para dejar limpio el editor de VSC, hay que ir al menú Archivo y seleccionar la opción Cerrar carpeta.
VSC guarda toda la información del estado de ese proyecto por lo que, al abrir de nuevo la carpeta, estará igual que cuando se cerró (si no se modifica fuera de él, claro).

GRacias

Ahora te cuento lo que a mi me pasa, si hago exactamente lo que dices, he vuelto a repasar y está idéntico, la compilación me da un error, que en realidad son 2.

[Imagen: 1.jpg]

Hay un error de sintaxis que no tendrá en cuenta , pero falta por actualizar el valor en includepath , eso ya no es un error de sintaxis.

[Imagen: 2.jpg]

He pensado voy a cambiar uno a uno hasta que de con el que da el error, divide y venceras, y así ha sido, he dado de donde viene relacionado, y es en este comando, #define NOZZLE_TO_PROBE_OFFSET { DX, DY, 0} , al compilar da ese error, sin embargo si lo escribo con los parámetros #define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0} , guardar todo, y , build, compila con éxito, hay que actualizar ese campo para que no de ese error, seguro que darás con ello maestro, cuando venga bien.


[font=Consolas, 'Courier New', monospace][Imagen: 20220211-223508.jpg][/font]
  Responder
#78
En fin, quizá sea yo quien no me explico suficientemente bien.
En mi respuesta se puede leer lo siguiente:

(09-02-2022, 03:06 PM)Simemart escribió: ...
Una vez tengas colocado el BL-Touch en la impresora, tienes que medir la distancia entre la vertical del centro del vástago del sensor y el centro de la boquilla, tanto en el eje X como en el Y: serán los valores DX y DY más adelante en la configuración de Marlin.
...
#define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0 }  -->  #define NOZZLE_TO_PROBE_OFFSET { DX, DY, 0 }
...

En el parámetro NOZZLE_TO_PROBE_OFFSET, hay que poner el valor que tengan las medidas indicadas en sustitución de DX y DY, .
  Responder
#79
(11-02-2022, 11:52 PM)Simemart escribió: En fin, quizá sea yo quien no me explico suficientemente bien.
En mi respuesta se puede leer lo siguiente:

(09-02-2022, 03:06 PM)Simemart escribió: ...
Una vez tengas colocado el BL-Touch en la impresora, tienes que medir la distancia entre la vertical del centro del vástago del sensor y el centro de la boquilla, tanto en el eje X como en el Y: serán los valores DX y DY más adelante en la configuración de Marlin.
...
#define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0 }  -->  #define NOZZLE_TO_PROBE_OFFSET { DX, DY, 0 }
...

En el parámetro NOZZLE_TO_PROBE_OFFSET, hay que poner el valor que tengan las medidas indicadas en sustitución de DX y DY, .

Perdona, es que leí muy rápido, culpa mia. 



Visto desde frente la impresora, el vastago del sensor esta en el eje X 41mm a la izquierda, y el eje Y unos 7mm adelantado respecto del centro de la boquilla, en ambos casos claro , positivos o negativos  Icon_question

Por cierto, el vástago tiene algo de holgura tanto en el eje X unos 0,8mm , y en el eje Y yo creo que algo menos de medio mm.


Porque de origen viene con los valores { 10, 10, 0 }¨y no { 0, 0, 0 } Icon_question , y porque esos valores de , p.ej el eje X , de 41mm, porque no se suma o resta o esos 10 originales  Icon_question
  Responder
#80
El signo de los valores del offset del sensor, depende de hacia que lado se encuentre este respecto a la boquilla: si está hacia el lado negativo del eje, serán negativos los valores y viceversa: en tu caso, los dos son negativos.
Que el vástago tenga una pequeña holgura lateral es normal y no debería ser un problema a la hora de su correcto funcionamiento.
La razón por la que Marlin tiene por defecto para ese parámetro esos valores la desconozco, aunque intuyo que tiene que ver con las medidas de los hotends típicos, en los que la boquilla suele estar situada a 10 mm del borde del cubo calentador.
En todo caso, podrían ser cualesquiera (por ejemplo 0 como indicas), pues al activar un tipo de sensor hay que configurar los que le correspondan, sin que influya lo que esté configurado anteriormente.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Pausa Ender 3 Pro Danissan88 3 15 Hace 1 hora
Último mensaje: Macuho
  Ender 3 V2 a Ender 3 S1 fvelez 3 69 14-06-2022, 09:25 PM
Último mensaje: Macuho
Exclamación CONSULTA Problemas adhesión ender 3 pro Fatalis22 11 2,154 10-01-2022, 07:25 AM
Último mensaje: Macuho
  CONSULTA Ender pro 3 IMPRIME DÓNDE QUIERE jgalan1981 4 472 25-09-2021, 10:10 PM
Último mensaje: JOSELUIS54
  Mi Ender 3D PRO imprime fatal (SOLUCIONADO) JOSELUIS54 28 2,301 13-09-2021, 09:47 PM
Último mensaje: JOSELUIS54