This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema arduino mega + ramps 1.4 regulador as1117, y otras dudas
#1
Antes de nada, buenas a todos soy nuevo y me parece un foro estupendo. Llevo leyendo cosas un tiempo y hasta ahora no me había visto en la necesidad de preguntar algo directamente. Así que procedo sin más preámbulo por si alguien me puede echar un cable.

Tengo un clon de arduino mega 2560 y una ramps 1.4. Estoy intentando dar vida a un clon de prusa con algunas modificaciones, usillos de metrica 8, motores de 2.5A y fuente de 12v.

El caso es que el regulador ams1117 pasó a mejor vida intuyo que por poner algun endstop al revés Facepalm , le pasa a mucha gente por lo que he investigado.
Ahora mi pantalla reprap solo enciende con el usb conectado. 

La dudas que tengo al respecto:
-Al tener un mosfet separado, alimentado desde la fuente de 12v deberia dejar de usarlo si quiero alimentar todo con 5v ?
-Si decido usar solo 5V debo quitar el diodo D2 y ya estaría? o hacer algo mas?
-Todo esto que pretendo, mover los motores de 2.5A y alimentar todo con 5V es posible para los drivers DRV8825 ?

Adjunto una foto de lo que tengo por si sirve de ayuda. Gracias de antemano 

[Imagen: New-Project-7.jpg]
  Responder
#2
Hola @lechuzo, bienvenido al foro.
Si los motores que tienes son NEMA17 (1,7 pulgadas de lado, unos 43 mm), me extraña que sean de tanto amperaje: en todo caso, los drivers que los controlen necesitan un voltaje superior a 5V y normalmente se suelen alimentar a 12V, cosa que puedes seguir haciendo sin ningún problema aunque se haya quemado el  regulador interno del Arduino Mega, pues este no interviene en esa alimentación, solo en el control de los drivers. Por la misma razón, tampoco hay ningún problema con el mosfet externo.
Como bien dices, esa avería es muy común y puede solucionarse de forma fácil alimentándolo directamente a 5V, como hace el conector USB.
Para ello, debes quitar el diodo D1 (no el D2) y conectar una alimentación de 5V al pin Vcc, para lo que tienes dos opciones: utilizar una fuente de alimentación independiente o adquirir un regulador externo que convierta los 12V de la fuente de alimentación a los 5V que necesita el Arduino Mega.
En ambos casos, la conexión debe dar un mínimo de 1A, que es la corriente máxima nominal del regulador interno estropeado y en el caso de utilizar una fuente independiente de la de 12V, deberás conectar en común las líneas de GND (-) de ambas fuentes.
Si piensas utilizar una fuente externa como la que pones en esa foto de componentes, ten en cuenta que no puedes conectarla al conector coaxial del Arduino, pues este alimenta directamente el regulador interno: hay que injectar los 5V directamente en el circuito de Vcc del Arduino Mega y el mejor punto de conexión es el pin Vcc de la RAMPS.
Con una imagen quedará más claro todo:

[Imagen: Img1.jpg]

[Imagen: Img2.jpg]
  Responder
#3
Hola @Simemart, espléndida respuesta la verdad muy agradecido. Creo que voy a optar por la opción del adaptador de 5v externo hasta que pida algún regulador a aliexpress más adelante.
¿Con un cargador como este podré realizar el trabajo?

[Imagen: cargador.jpg]


Luego con respecto al tema de los drivers DRV8825 y los motores de 2.5A que tengo. Decirte que son de una BQ Hephestos antigua, adjunto también una foto:


[Imagen: motor.jpg]


Según un amigo mio llevarían 1.2A por bobinado, y al ser dos bobinados 2.4A. Tengo cierto miedo a quemar los pololu con estos motores la verdad...  Sisi3
  Responder
#4
La mejor opción es el regulador externo de voltaje, conectado a la fuente de alimentación pero, de forma provisional, ese cargador debería funcionar pues puede llegar justo a 1A, que es lo mismo que da el regulador interno del Arduino Mega: va justo, pero debería ser suficiente.
Los motores son algo más grandes que los habituales (48 mm de largo en lugar de 40 mm) y efectivamente son de 2,5A, pero eso es por fase (o bobinado como indicas): la corriente no se divide entre las dos fases, pues el driver las alimenta de forma separada.
En todo caso, no debes preocuparte por ello, pues esa es la intensidad máxima que soportan los motores, pero ellos no son los que deciden cuanta es la que se les suministra, son los propios drivers quienes lo fijan: es decir, independientemente del motor que conectes al driver, este dará la corriente que se regule mediante el potenciómetro que tienen al efecto.
En concreto, los DRV8825 pueden llegar de forma continua a esos 2,5A (con refrigeración forzada) pero, para una impresora 3D, no deberías necesitar ni la mitad de ese valor.
  Responder
#5
De acuerdo, pensaba que los motores debian recibir 2.5A. Pues sabiendo eso me quedo mucho más tranquilo. Viendo tutoriales en internet en los potenciómetros comentan de regularlos a 200mA + lo que consuma la ramps. Y en el caso del potenciómetro Z el doble al ser dos motores. Me resultaba raro que la gente usase esas medidas con motores de distintos amperajes y no tenia ni idea de si los míos iban a servir.

Aunque no cuadraba que la placa original de la BQ Hephestos era una "Freuduino" + Ramps 1.4 con drivers A4988 y los motores originales fuesen esos. Pensaba: bueno igual estos de BQ traen alguna cosa propietaria en sus placas y hace que sirvan esos motores. En fin, rumiadas mias para seguir aprendiendo.

Deduzco entonces que el adaptador samsung de 1A me sirve, pero si encuentro otro de 2A o asi mejor para que no se caliente. 

Gracias por la ayuda @Simemart  Clap

Edito: Acabo de pedir el regulador a ver si con suerte me llega en una semana y me ahorro el cargador usb
  Responder
#6
La regulación que indicas (200 mA o 0,2A) es midiendo la intensidad en la línea de alimentación de la RAMPS (12V), pero eso no es lo que envían los drivers a los motores, pues estos no trabajan a ese voltaje, sino a uno menor.
Para regular la intensidad real que envían los drivers, hay que hacerlo mediante el valor del voltaje de referencia (Vref), pero es más sencillo realizarlo de la otra forma.
Ese valor de 0,2A es bastante bajo (serán algo menos de 0,8A en el motor): si ves que en algún eje el motor pierde pasos, puedes subirlo poco a poco hasta que el motor deje de perderlos.
  Responder
#7
(24-05-2021, 11:42 PM)Simemart escribió: La regulación que indicas (200 mA o 0,2A) es midiendo la intensidad en la línea de alimentación de la RAMPS (12V), pero eso no es lo que envían los drivers a los motores, pues estos no trabajan a ese voltaje, sino a uno menor.
Para regular la intensidad real que envían los drivers, hay que hacerlo mediante el valor del voltaje de referencia (Vref), pero es más sencillo realizarlo de la otra forma.
Ese valor de 0,2A es bastante bajo (serán algo menos de 0,8A en el motor): si ves que en algún eje el motor pierde pasos, puedes subirlo poco a poco hasta que el motor deje de perderlos.

De acuerdo, los subiré entonces hasta que se muevan bien. Con los drivers A4988 directamente ni se mueven. Pero puede ser que alguno este dañado... Para descartar compré los DRV8825 y probare de uno en uno con un solo motor, por si las moscas.

Saludos!  Mola
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Mi arduino mega se sobrecalienta y no es reconocido por el pc Riso 4 261 23-09-2021, 06:49 PM
Último mensaje: asesorplaza1
  CONSULTA Problema con Ramps y A4988 lambda4 19 1,240 28-11-2020, 01:28 AM
Último mensaje: Simemart
  CONSULTA problema con la Ramps 1.4 rogelio5702 2 706 14-05-2020, 12:29 AM
Último mensaje: rogelio5702
  Arduino mega y drivers DM542T y DM320T victor92 3 1,260 17-07-2019, 09:37 PM
Último mensaje: PauFerlo
  DUDA Ramps o arduino estropeado Danivl 8 1,810 10-05-2019, 12:17 PM
Último mensaje: Danivl