This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 voto(s) - 3 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con calentamiento de motores
#21
Si los configuras como Standalone, funcionarán en modo STEP/DIR como los drivers habituales y por tanto, tendrás que regular todo de forma manual, tanto la intensidad (mediante los potenciómetros que incorporan) como los micropasos (mediante los puentes), funcionando en este caso como máximo a 16 micropasos de cara al firmware.
No podrás utilizar estos drivers a mas de 16 micropasos si no los controlas por UART y en ese caso, solo tienes que indicar el valor que quieras donde se configura la intensidad en el firmware o en el apartado correspondiente del menú de la pantalla.
Me dá la impresión de que el problema que estás teniendo para controlarlos por UART no es de configuración sino de comunicación, debido a los propios drivers que estas utilizando o a su conexión en la placa.
  Responder
#22
Pues según el manual de @LoKus77, indica que mi tipo de driver se conecta por UART sin tener que hacer ninguna modificación que es "pincharlo y listos".

Yo he probado con el jumper exterior para la configuración del UART, sin el jumper, en varias posiciones que he visto por comentarios en internet, etc... y nada de nada. De la única manera que ha funcionado, a sido así como te digo, en el modo Standalone.

Bueno, seguiré probando para ver si consigo que me vuelva la configuración de los micropasos...
  Responder
#23
Joer, no se que pasa que no me avisa cuando me nombras o citas.

Prueba a borrar la eeprom

Yo es que tengo los Bigtreetech, que son la version v1.2 de los TMC2209.

Tal cual tienes los jumpers, yo los conecté y todo funcionó a la primera

Esta tarde subo mi fichero configuration.h y mi fichero configuration_adv.h para que los eches un vistazo.

Te pongo una foto mía de como tengo todo conectado en mi placa. Algunas cosillas no se ven por los cables que pasan de por medio, pero mira a ver si ves algo diferente

[Imagen: b1ba4533c3a65f893b3e4ecae69b0468o.jpg]

  Responder
#24
(05-06-2020, 09:01 AM)kokeeeeee escribió: Joer, no se que pasa que no me avisa cuando me nombras o citas.

Prueba a borrar la eeprom

Yo es que tengo los Bigtreetech, que son la version v1.2 de los TMC2209.

Tal cual tienes los jumpers, yo los conecté y todo funcionó a la primera

Esta tarde subo mi fichero configuration.h y mi fichero configuration_adv.h para que los eches un vistazo.

Te pongo una foto mía de como tengo todo conectado en mi placa. Algunas cosillas no se ven por los cables que pasan de por medio, pero mira a ver si ves algo diferente

[Imagen: b1ba4533c3a65f893b3e4ecae69b0468o.jpg]

Pues muchas gracias! La verdad es que la foto es tal cual lo tengo yo conectado, con la diferéncia que yo tengo dos Z y uno está conectado al E1, pero por lo demás, yo tambien puse así los jumpers para el UART...

Pues si puedes dejar los archivos de configuración para mirar si tengo alguna opción mal, te estaría muy agradecido.

Gracias de nuevo!
  Responder
#25
te adjunto mis ficheros configuration.h y configuration_adv.h 

es Marlin 2.0-bugfix

Mi impresora una Tevo Tornado. Clon de la CR-10


Archivos adjuntos
.rar   marlin.rar (Tamaño: 64.28 KB / Descargas: 13)

  Responder
#26
Yo tuve un problema similar, me derritio el cable que conecta el nema17 al arduino, y lo solucione disminuyendo el voltaje desde el driver. Claro que busqué la ficha técnica del motor previamente para establecer el voltaje deseado.
Conocer personas en facebook me gusta pero más me gusta, conocer gente que tenga mis mismas aficiones
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
Exclamación cama caliente cr10s pro en calentamiento perpetuo dasafur 6 704 30-04-2021, 02:43 PM
Último mensaje: dasafur
  Problema con motores en SKR 1.3 fgj77 5 1,626 14-09-2019, 12:42 PM
Último mensaje: Simemart
  drivers con voltaje sin movimiento de motores garfieldf 0 733 30-03-2019, 11:00 AM
Último mensaje: garfieldf
  CONSULTA Problema y dudas al ajustar corriente de motores mondobizarro 9 4,378 08-10-2017, 05:41 PM
Último mensaje: mondobizarro
  [Problema] No se mueven los algunos motores con pronterface rundatrap 2 2,552 09-01-2016, 05:19 PM
Último mensaje: pablocano