This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
mks Robin e3d-Eje Z no funciona
#1
Hola, me llamo Miguel Ángel y soy nuevo en el foro. Agradecería que me echaseis una mano:

hace tiempo construí una fresadora con una placa arduino uno. Ahora me he embarcado en la tarea de convertirla en una impresora 3D, más llevadera en casa (por aquello de la suciedad). El caso es que para sustituir la placa compré una MKS Robin E3D con drivers 2209 y una pantalla MKS TFT24. Cuando llegó regule el voltaje de los drivers y la conecté. Traía un firmaware cargado y, aunque los parámetros no eran correctos, movía todos los ejes correctamente. Lo siguiente que hice fue bajarme el último Marlin y la actualización de la pantalla. Tras varios intentos conseguí compilar el Marlin y cargarlo. La cuestión es que a partir de ese momento no consigo que se mueva el eje Z, ni moviéndolo manualmente desde la pantalla ni simulando una impresión desde un archivo. El resto funciona correctamente.

¿alguna idea? muchas gracias de antemano
  Responder
#2
Hola @mangelh, bienvenido al foro.
Ya sois varios los usuarios que habeis reportado este problema con ese modelo de placa y que se produce al cambiar el firmware que trae de serie la impresora (por ejemplo, aquí).
Dado que lo que sucede siempre es que el eje Z deja de funcionar, todo parece indicar que el problema se encuentra en la asignación de pines, que seguramente no concuerdan con la placa.
Como Marlin selecciona el archivo de pines a utilizar en función de la placa configurada, yo diría que el problema está en que no se selecciona la adecuada.
Para la MKS Robin E3D hay dos modelos: uno denominado BOARD_MKS_ROBIN_E3D, que utiliza el archivo de pines pins_MKS_ROBIN_E3D.h, que a su vez incluye el archivo pins_MKS_ROBIN_E3_common.h y otro denominado BOARD_MKS_ROBIN_E3D_V1_1, que utiliza el archivo de pines pins_MKS_ROBIN_E3D_V1_1.h, que a su vez incluye el archivo pins_MKS_ROBIN_E3_V1_1_common.h.
Y precisamente (que casualidad), la única diferencia entre estos dos últimos archivos está en que se definen de distinta forma los pines DIR y STEP del eje Z.
Así que yo diría que la solución al problema pasa por configurar uno u otro modelo de placa, para encontrar el que se tiene realmente.
  Responder
#3
Hola. Muchas gracias por tu rápida respuesta. He revisado el último Marlin y sí aparece el archivo pins_MKS_ROBIN_E3D.h, pero no veo el archivo pins_MKS_ROBIN_E3D_V1_1.h y en el archivo boards.h está #define BOARD_MKS_ROBIN_E3D          4019  // MKS Robin E3D (STM32F103RCT6), pero no para la v1.1 que es la que yo tengo. 

Parece un callejón sin salida!


(18-01-2021, 01:28 AM)Simemart escribió: Hola @mangelh, bienvenido al foro.
Ya sois varios los usuarios que habeis reportado este problema con ese modelo de placa y que se produce al cambiar el firmware que trae de serie la impresora (por ejemplo, aquí).
Dado que lo que sucede siempre es que el eje Z deja de funcionar, todo parece indicar que el problema se encuentra en la asignación de pines, que seguramente no concuerdan con la placa.
Como Marlin selecciona el archivo de pines a utilizar en función de la placa configurada, yo diría que el problema está en que no se selecciona la adecuada.
Para la MKS Robin E3D hay dos modelos: uno denominado BOARD_MKS_ROBIN_E3D, que utiliza el archivo de pines pins_MKS_ROBIN_E3D.h, que a su vez incluye el archivo pins_MKS_ROBIN_E3_common.h y otro denominado BOARD_MKS_ROBIN_E3D_V1_1, que utiliza el archivo de pines pins_MKS_ROBIN_E3D_V1_1.h, que a su vez incluye el archivo pins_MKS_ROBIN_E3_V1_1_common.h.
Y precisamente (que casualidad), la única diferencia entre estos dos últimos archivos está en que se definen de distinta forma los pines DIR y STEP del eje Z.
Así que yo diría que la solución al problema pasa por configurar uno u otro modelo de placa, para encontrar el que se tiene realmente.


Acabo de descargar de https://github.com/makerbase-mks/MKS-Rob...mware/V1.1 es fichero Firmware bin for ender3.rar, que no tiene los parámetros de mi impresora, pero el eje z funciona!

Efectivamente, es un firmware especifico para la versión 1.1 de la MKS Robin E3D

Ahora voy a intentar configurarlo desde cero desde los archivos Marlin para ver que pasa. Espero que sea la solución. Veremos
  Responder
#4
Si con "el último Marlin" te estás refiriendo a la versión  2.0.7.2, efectivamente en ella no encontrarás los archivos de la versión 1.1 de esa placa.
Pero la última versión de Marlin no es esa, sino la bugfix (que va por la 2.0.8) y que es en la que encontrarás los archivos que te he indicado.
  Responder
#5
(18-01-2021, 10:17 PM)Simemart escribió: Si con "el último Marlin" te estás refiriendo a la versión  2.0.7.2, efectivamente en ella no encontrarás los archivos de la versión 1.1 de esa placa.
Pero la última versión de Marlin no es esa, sino la bugfix (que va por la 2.0.8) y que es en la que encontrarás los archivos que te he indicado.

Mil gracias por la ayuda! efectivamente en la dirección de Github que posteé hay una versión de Marlin para la 1.1 que, como dijiste, soluciona el problema.
Viene configurado para Ender3, pero es cuestión de adaptarlo a cada impresora.

Lo dicho, mil gracias. Asunto solucionado.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Ender 3 pro No funciona y la pantalla se queda azul buzbruno 1 106 15-02-2021, 07:06 PM
Último mensaje: buzbruno
  MKS no actualiza Firmware mangelh 4 188 14-02-2021, 08:06 PM
Último mensaje: mangelh
  MKS ROBIN E3D eje z no responde después de cambiar el firmware Xucu 1 307 11-01-2021, 01:39 AM
Último mensaje: mangelh
  Cambio de pines MKS 32 BITS rgl3dprint 8 380 07-11-2020, 04:50 PM
Último mensaje: rgl3dprint
  problemas con marlin para kms robin nano v1.2 Asier esnal 9 1,656 06-07-2020, 09:11 AM
Último mensaje: Azote