This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
impresiones tamaño inferior en eje z
#1
pues eso...levo un dias imprimiendo con ella y aora que immprimo unas piezas con base de 2mm me he dado cuenta que me hace una capa base muy estrecha, aparte de medida total mas estrecha en comparacion con la misma pieza impresa en anet...
es una ender 3 con placa mks gen L, tft mks 3.5,en ejes lleva tmc2208 y el extrusor un drv8825.
estan ajustados todos los pasos y comprobados en maquina y todos bien, ajustadas escentricas varias veces, incluso soltandolas un pelin y nada...
3 cubos de calibracion de 20x20 todas las caras a 20mm menos en z que se queda en 19.4mm
alguna idea de que puede ser??
  Responder
#2
Hola, si lo que indicas es correcto, no parece haber ninguna causa de ese comportamiento si exceptuamos esa primera capa más fina, aunque eso no parece suficiente para explicar una diferencia de altura tan grande.
La altura final de las piezas impresas depende de tres factores: la altura inicial de impresión (punto Z=0), la altura de la primera capa y la altura de capa normal. El primero es fijo y los otros dos dependen de que el eje se mueva de forma correcta.
A falta de saber los valores reales que tienes configurados para ellos y viendo la diferencia de altura que tienes, yo diría que el problema está en el movimiento del eje Z: o no están correctamente configurados los micropasos por milímetro y/o el eje no se mueve con la suficiete fluidez y se están perdiendo pasos.
  Responder
#3
realice varias veces la cuenta para los micro pasos y en todas me sale igual...400.
despues de eso he decho la prueba de darle al cubo de calibracion esa medida que falta y a dado el cubo la medida...en el caso el cubo al principio da 19.4.. e subido la medida a 20.6 y al terminar el cubo a dado 20mm clavados.....aora seguire haciendo mas pruebas y midiendo el desplazamiento del z a ver puede ser de eso....
pense tambien en holgura en la tuerca trapezoidal del eje....pero no se...
  Responder
#4
Tengo la impresión de que la cuenta que realizas para el cálculo es la teórica, es decir pasos del motor * micropasos del driver / paso del husillo (200*16/8=400), y por supuesto siempre dá ese valor.
Pero no es esa la que tienes que realizar para corregirlo, sino la siguiente: pasos actuales * distancia teórica / distancia real (400*20/19,4=412,37). Este es el valor que tienes que configurar para los micropasos por milímetro de ese eje.
No te olvides de que el separador decimal en el firmware es el punto, no la coma.
  Responder
#5
aun no he metido en marlin los pasos que me indicas...la cosa es que aun no los he puesto ya que antes de hacer nada hice un home a z. hice una marca y realice una segunda marca a 10 cnt.
subi Z 10cnt y se quedo clavado en la marca....entonces me hace dudar que sea tema de pasos.....puede ser algo en el firmware????
  Responder
#6
Dudo que hayas podido conseguir una precisión en esa medida que indicas de 10 cm, mayor que la que consigues midiendo la pieza impresa.
Si en 20 mm  tenías un error de 6 décimas, en 10 mm tendrás aproximadamente 3 décimas, que seguramente es menor que la anchura de la marcas que has hecho.
Podrías conseguir algo más de exactitud si tomas una medida mucho más grande, por ejemplo 100 mm. Si está mal el ajuste de los micropasos por milímetro, el error debería rondar los 3 mm.
En cualquier caso, decir que estos ajustes hay que realizarlos de una forma integral (mecánica y extrusión), ya que no sirve de nada ajustar una parte si hay otras desajustadas.
Y hay que hacerlos de forma que los errores de medida, que son imposibles de eliminar, sean lo más pequeños posibles. Tienes una forma para hacerla en su totalidad en este post.
En el firmware no hay nada aparte de los micropasos por milímetro que pueda causar eso, salvo que te refieras a que esté corrupto el que tienes instalado y que no funcione correctamente, cosa bastante poco probable.
  Responder
#7
te confirm las medidas tomadas son de 10cnt o 100mm y las marcas estan medidas con calibre y pintadas con rotulador muy fino y al subir los 100mm llega a la marca sin problemas...se queda justo en la marca.
puede ser quizas algun ajuste en el txt de la tft mks??
  Responder
#8
(31-03-2020, 09:36 PM)yeyo_gato escribió: te confirm las medidas tomadas son de 10cnt o 100mm y las marcas estan medidas con calibre y pintadas con rotulador muy fino y al subir los 100mm llega a la marca sin problemas...se queda justo en la marca.
puede ser quizas algun ajuste en el txt de la tft mks??
hola , lo pudiste solucionar ??
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Ender 3 Pro SKR Mini E3 V2.0 se para impresiones con soporte Quique89 1 150 24-04-2021, 06:24 PM
Último mensaje: pano
  Del eje z al eje y xan 4 369 12-01-2021, 12:35 AM
Último mensaje: Simemart
  Tevo Tornado. impresiones kokeeeeee 27 5,264 08-03-2019, 09:17 PM
Último mensaje: p52sarup
  ¿Tú como haces tus impresiones en ABS? ZionLion 10 2,150 20-02-2019, 02:04 AM
Último mensaje: 3dwork
  Tamaño personalizado para CORE XY Manueldr80 1 491 15-01-2019, 07:57 PM
Último mensaje: Manueldr80