This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Velocidad Ventilador de capa
#1
Buenas a todos, estoy empezando a imprimir con petg y en cura 4.8, he configurado la velocidad del ventilador de capa al 50%, pero en la pantalla de la ender 3 pro[Imagen: IMG-3986.jpg] me aparece al 100%, entiendo que debía figurar 50% ¿hay algún parámetro interno que cambie para que ponga 100%  ò no me ha reconocido la configuración de cura y esta mal?
  Responder
#2
Hola, para saber donde está el problema, se necesita ver como tienes configurado CURA y el valor del parámetro del comando M106 que está poniendo en el archivo de impresión: si pones un pantallazo de la primera y adjuntas el archivo .gcode (en un archivo comprimido), quizá te pueda indicar algo.
  Responder
#3
[Imagen: Captura-de-pantalla-2021-06-03-165155.png]
(03-06-2021, 03:39 PM)Simemart escribió: Hola, para saber donde está el problema, se necesita ver como tienes configurado CURA y el valor del parámetro del comando M106 que está poniendo en el archivo de impresión: si pones un pantallazo de la primera y adjuntas el archivo .gcode (en un archivo comprimido), quizá te pueda indicar algo.


Buenas, creo que adjunto lo que me has comentado, si puedes decirme algo te agradezco.
felix

(03-06-2021, 03:59 PM)felix7 escribió: [Imagen: Captura-de-pantalla-2021-06-03-165155.png]
(03-06-2021, 03:39 PM)Simemart escribió: Hola, para saber donde está el problema, se necesita ver como tienes configurado CURA y el valor del parámetro del comando M106 que está poniendo en el archivo de impresión: si pones un pantallazo de la primera y adjuntas el archivo .gcode (en un archivo comprimido), quizá te pueda indicar algo.


Buenas, creo que adjunto lo que me has comentado, si puedes decirme algo te agradezco.
felix

No he podido subir el gcode comprimido, miro de otra manera si puedo sacar la linea M106

Buenas, he abierto con pronterface, no se de otra manera, adjunto 2 imagenes, del principio y final.[Imagen: gcode1.png]

[Imagen: Gcodefinal.png]


Archivos adjuntos Miniatura(s)
   
  Responder
#4
Adjunto mas imagenes


Archivos adjuntos Miniatura(s)
                   
  Responder
#5
El .gcode es un archivo de texto plano, que puedes abrir con cualquier editor de texto (el Bloc de notas, por ejemplo) y utilizar la función de búsqueda para encontrar los M106 que tenga incluídos.
A pesar de que tienes algunos parámetros no visibles en ese perfil, como la altura a partir de la que la velocidad pasa del 0% al 50%, en principio con esa configuración debería empezar la impresión con el ventilador apagado, que en el gcode se ordena con el M107 que sigue a la línea LAYER:0 y después activarlo al 50%, que en el gcode debería corresponder con un comando M106 S127.5 colocado en la línea siguiente a ;LAYER:XXX, donde XXX es el número de capa que coincide con la altura configurada.

P.S.: Estaba escribiendo la respuesta y no había visto las nuevas imágenes.
Por lo que veo en ellas, está configurado para que la velocidad normal del ventilador se alcance en la capa 3, por lo que incrementa de forma progresiva la velocidad en las capas anteriores: capa 0, M107 = 0%; capa 1, M106 S42.5 = 16,7%; capa 2, M106 S85 = 33,3%; capa 3, M106 S127.5 = 50%.
Si no hay más comandos M106 en el fichero, la pantalla debería indicar esos porcentajes de forma sucesiva y el 50% desde la capa 3 hasta el final de la impresión, otra cosa sería muy extraño.
  Responder
#6
(03-06-2021, 05:23 PM)Simemart escribió: El .gcode es un archivo de texto plano, que puedes abrir con cualquier editor de texto (el Bloc de notas, por ejemplo) y utilizar la función de búsqueda para encontrar los M106 que tenga incluídos.
A pesar de que tienes algunos parámetros no visibles en ese perfil, como la altura a partir de la que la velocidad pasa del 0% al 50%, en principio con esa configuración debería empezar la impresión con el ventilador apagado, que en el gcode se ordena con el M107 que sigue a la línea LAYER:0 y después activarlo al 50%, que en el gcode debería corresponder con un comando M106 S127.5 colocado en la línea siguiente a ;LAYER:XXX, donde XXX es el número de capa que coincide con la altura configurada.
Buenas, si, las primeras capas el ventilador esta a cero y en la capa 3 aparece el valor M106 S127.5, pero entiendo que se activaria al 50%, pero creo que esta al 100%,  que es lo que veo en la pantalla?

(03-06-2021, 05:27 PM)felix7 escribió:
(03-06-2021, 05:23 PM)Simemart escribió: El .gcode es un archivo de texto plano, que puedes abrir con cualquier editor de texto (el Bloc de notas, por ejemplo) y utilizar la función de búsqueda para encontrar los M106 que tenga incluídos.
A pesar de que tienes algunos parámetros no visibles en ese perfil, como la altura a partir de la que la velocidad pasa del 0% al 50%, en principio con esa configuración debería empezar la impresión con el ventilador apagado, que en el gcode se ordena con el M107 que sigue a la línea LAYER:0 y después activarlo al 50%, que en el gcode debería corresponder con un comando M106 S127.5 colocado en la línea siguiente a ;LAYER:XXX, donde XXX es el número de capa que coincide con la altura configurada.
Buenas, si, las primeras capas el ventilador esta a cero y en la capa 3 aparece el valor M106 S127.5, pero entiendo que se activaria al 50%, pero creo que esta al 100%,  que es lo que veo en la pantalla?

Buenas, gracias , he abierto el gcode en formato texto y comprimido pero no me deja adjuntar.
  Responder
#7
Nos estamos pisando las respuestas.
Revisa lo que añadí en la última.
  Responder
#8
(03-06-2021, 05:43 PM)Simemart escribió: Nos estamos pisando las respuestas.
Revisa lo que añadí en la última.
Si, entiendo que en el gcode a partir de la 3 capa el ventilador de capa está al 50%, como lo he configurado en el cura, mi duda es que en la pantalla de la impresora veo 100%, 

O
  Responder
#9
Pues la verdad es que es bastante raro ese comportamiento y todo parece indicar que el problema está en el firmware: ¿qué versión tiene instalada?
  Responder
#10
(03-06-2021, 07:11 PM)Simemart escribió: Pues la verdad es que es bastante raro ese comportamiento y todo parece indicar que el problema está en el firmware: ¿qué versión tiene instalada?
Buenas, ahi me pillas, esta de serie, creo que era la 1.16, la que traia la maquina, la verdad que nunca le habia cambiado la velocidad del ventilador, siempre he imprimido PLA .
  Responder
#11
Prueba otro laminador, cura tiene demasiados bug, en mis impresoras da igual la temperatura que le pongas en la primera capa que en las siguientes, siempre pone la misma, no la cambia
  Responder
#12
(03-06-2021, 08:51 PM)Macuho escribió: Prueba otro laminador, cura tiene demasiados bug, en mis impresoras da igual la temperatura que le pongas en la primera capa que en las siguientes, siempre pone la misma, no la cambia
Ya me habia acostumbrado a cura, ¿que laminador?
  Responder
#13
Si las órdenes están en el archivo gcode y son correctas, no es un problema del laminador: si a Marlin se le pasa un comando M106 con una velocidad concreta, esta tiene que aparecer en el display con el porcentaje que le corresponde y si no es así, es que algo está mal en él.
Para comprobar si lo hace siempre, se puede probar a enviar el comando directamente (con el panel de control de CURA o con Pronterface).
  Responder
#14
(03-06-2021, 09:04 PM)Simemart escribió: Si las órdenes están en el archivo gcode y son correctas, no es un problema del laminador: si a Marlin se le pasa un comando M106 con una velocidad concreta, esta tiene que aparecer en el display con el porcentaje que le corresponde y si no es así, es que algo está mal en él.
Para comprobar si lo hace siempre, se puede probar a enviar el comando directamente (con el panel de control de CURA o con Pronterface).
Como se haría con el panel de control de cura?
  Responder
#15
Configuración de Cura
[Imagen: Captura.png]

Archivo generado con cura, verás que se ha pasado por las narices el cambio de temperatura, no se para que tiene tantas opciones si no hace caso a los cambios y ya hace muchas versiones que tiene ese bug

Código:
;Generated with Cura_SteamEngine 4.9.0
M82 ;absolute extrusion mode
; -- START GCODE --
M104 S208
M109 S208 ; Makes sure the temperature is correct before printing
G28 ; Zero-ing position
;G1 Z5 X10 Y290 F2000;Posicion eje X Y y Z
;G29 ; Auto bed-leveling
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X5.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X5.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X5.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X5.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
; -- end of START GCODE --
M141 S28
G92 E0
G92 E0
G1 F2400 E-2.4
;LAYER_COUNT:178
;LAYER:0
M107
G1 F600 Z0.6
;MESH:PM3D_jedi anna - torso.stl
G0 F6000 X111.623 Y173.654 Z0.6
;TYPE:WALL-INNER
G1 F600 Z0.3
G1 F2400 E0
G1 F2100 X111.328 Y174.177 E0.04494
G1 X110.653 Y173.801 E0.10276
G1 X110.086 Y173.478 E0.15159
G1 X109.553 Y173.182 E0.19722
G1 X109.067 Y172.903 E0.23915
G1 X108.401 Y172.532 E0.29621
G1 X107.969 Y172.284 E0.33348
G1 X107.271 Y171.899 E0.39314
G1 X106.78 Y171.623 E0.43529
G1 X106.722 Y171.586 E0.44044
G1 X105.808 Y171.071 E0.51895
G1 X106.019 Y170.673 E0.55266
G1 X106.309 Y170.156 E0.59702
G1 X106.611 Y169.654 E0.64086
G1 X106.868 Y169.164 E0.68227
G1 X107.111 Y168.742 E0.71871
G1 X107.362 Y168.279 E0.75812
G1 X107.645 Y167.784 E0.80079
G1 X107.938 Y167.258 E0.84585
G1 X108.198 Y166.804 E0.885
G1 X108.498 Y166.268 E0.93097
G1 X108.913 Y165.539 E0.99375
G1 X109.484 Y165.862 E1.04284
G1 X110.206 Y166.264 E1.10468
G1 X111.251 Y166.854 E1.19449
G1 X112.878 Y167.769 E1.33418
G1 X113.352 Y168.038 E1.37496
G1 X113.827 Y168.3 E1.41556
G1 X114.325 Y168.587 E1.45857
G1 X114.438 Y168.65 E1.46826
G1 X114.055 Y169.332 E1.52679
G1 X113.758 Y169.852 E1.5716
G1 X113.454 Y170.4 E1.6185
G1 X113.185 Y170.874 E1.65929
G1 X112.892 Y171.396 E1.70409
G1 X112.489 Y172.108 E1.76531
G1 X112.228 Y172.575 E1.80535
G1 X111.945 Y173.075 E1.84834
G1 X111.623 Y173.654 E1.89792
G1 F2400 E-0.50208
G1 F600 Z0.6
G0 F6000 X111.7 Y174.74 Z0.6
;TYPE:WALL-OUTER
G1 F600 Z0.3
G1 F2400 E1.89792
G1 F2100 X111.559 Y174.995 E1.91973
G1 X111.003 Y174.683 E1.96744
G1 X110.361 Y174.325 E2.02245
G1 X109.792 Y174.001 E2.07145
G1 X109.254 Y173.702 E2.11751
G1 X108.772 Y173.425 E2.15911
G1 X108.109 Y173.056 E2.2159
G1 X107.675 Y172.807 E2.25334
G1 X106.981 Y172.424 E2.31266
G1 X106.474 Y172.139 E2.35619
G1 X106.415 Y172.102 E2.3614
G1 X105.126 Y171.375 E2.47214
G1 X104.992 Y171.302 E2.48356
G1 X105.239 Y170.864 E2.52119
G1 X105.496 Y170.379 E2.56227
G1 X105.795 Y169.846 E2.60801
G1 X106.088 Y169.36 E2.65047
G1 X106.336 Y168.886 E2.69051
G1 X106.587 Y168.449 E2.72822
G1 X106.841 Y167.981 E2.76807
G1 X107.122 Y167.489 E2.81047
G1 X107.417 Y166.96 E2.8558
G1 X107.676 Y166.508 E2.89478
G1 X107.976 Y165.972 E2.94075
G1 X108.226 Y165.532 E2.97862
G1 X108.688 Y164.724 E3.04827
G1 X109.318 Y165.078 E3.10235
G1 X109.778 Y165.339 E3.14193
G1 X110.502 Y165.742 E3.20394
G1 X110.992 Y166.02 E3.2461
G1 X111.545 Y166.331 E3.29358
G1 X112.007 Y166.59 E3.33322
G1 X112.695 Y166.979 E3.39236
G1 X113.173 Y167.247 E3.43337
G1 X113.645 Y167.514 E3.47396
G1 X114.126 Y167.78 E3.51509
G1 X114.621 Y168.065 E3.55783
G1 X114.929 Y168.237 E3.58423
G1 X115.127 Y168.347 E3.60119
G1 X115.256 Y168.418 E3.6122
G1 X115.145 Y168.616 E3.62464
G1 X114.867 Y169.111 E3.66712
G1 X114.576 Y169.63 E3.71165
G1 X114.281 Y170.146 E3.75613
G1 X113.979 Y170.691 E3.80276
G1 X113.707 Y171.169 E3.84392
G1 X113.414 Y171.692 E3.88878
G1 X113.012 Y172.402 E3.94984
G1 X112.75 Y172.871 E3.99004
G1 X112.468 Y173.368 E4.0328
G1 X112.146 Y173.949 E4.08251
G1 X111.7 Y174.74 E4.15047
G0 F6000 X111.559 Y174.995
G0 X111.552 Y174.991
G1 F2400 E1.75047
G1 F600 Z0.6
G0 F6000 X111.103 Y173.376 Z0.6
M104 S208

Hace más de un año que uso Prusa Slicer y de momento no lo cambio


Archivos adjuntos
.rar   BQH2_PM3D_jedi anna - torso.rar (Tamaño: 851.73 KB / Descargas: 5)
  Responder
#16
Con la impresora conectada, en la pestaña SUPERVISAR hay un campo denominado Enviar GCode, escribe en él M106 S127.5 y pulsa Intro: el ventilador de capa debería encenderse y en la pantalla indicar que funciona al 50%.
Para pararlo, envía M107.
  Responder
#17
(03-06-2021, 09:18 PM)Simemart escribió: Con la impresora conectada, en la pestaña SUPERVISAR hay un campo denominado Enviar GCode, escribe en él M106 S127.5 y pulsa Intro: el ventilador de capa debería encenderse y en la pantalla indicar que funciona al 50%.
Para pararlo, envía M107.
Bien, probare, con pronterfare sera igual?
Gracias por todo
  Responder
#18
Exactamente igual: conecta con la impresora, escribe el comando en el campo de texto de abajo a la derecha y envía con el botón Send.
  Responder
#19
@Macuho, yo tengo instalada la última versión de CURA (4.9.0), aunque solo sea para poder verificar las cuestiones que se plantean en el foro, ya que no lo uso para cortar mis piezas.
Siempre he criticado la gran cantidad de opciones de configuración que tiene y que en mi opinión no aportan gran cosa, aparte de complicación de uso para los usuarios poco expertos, pero decir que tiene demasiados bugs me parece bastante injusto, sobre todo cuando el problema que indicas no es precisamente uno de ellos.
Por suerte, el abanico de opciones de programas de corte es bastante amplio y hay para todos los gustos: seguramente habrá usuarios de CURA que no lo cambiarían por otro, por lo que decir que uno está muy contento con el que usa, no se puede decir que diga gran cosa sobre la bondad del mismo.
El problema que tienes se debe al script de inicio que trae CURA pre configurado para la impresora BQ Hephestos 2, en el que se incluyen las órdenes de calentamiento (una idea bastante pésima, que no dice nada bueno sobre la competencia de quien lo confeccionó, por cierto), lo que hace que se obvien las temperaturas configuradas en el perfil.
Para conseguir que la temperatura se corresponda con la del perfil, dado que el script es fijo, se hace uso de las variables de entorno que tiene CURA, en las que se almacenan casi todos los parámetros del perfil y que pueden invocarse desde los scripts con su nombre entre llaves.
Dado que, como es lógico, solo se puede incluir una temperatura, el que hizo ese script utilizó la de impresión y por eso es la única que te aparece en los gcodes que generas con esa impresora seleccionada.
Como se puede ver en el gcode que has adjuntado, en el script de inicio tienes lo siguiente:

; -- START GCODE --
M104 S208
M109 S208 ; Makes sure the temperature is correct before printing
G28 ; Zero-ing position
;G1 Z5 X10 Y290 F2000;Posicion eje X Y y Z
;G29 ; Auto bed-leveling
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X5.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X5.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X5.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X5.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
; -- end of START GCODE --


pero las dos primeras líneas de comandos son realmente así:

M104 S{material_print_temperature}
M109 S{material_print_temperature} ; Makes sure the temperature is correct before printing


en las que {material_print_temperature}, es la variable de entorno que almacena la temperatura de impresión configurada en el perfil y que se sutituye por el valor al general el fichero.
Solo tienes que eliminar esas dos líneas del script, borrándolas o colocando un punto y coma delante, para que ya se utilicen todas las temperaturas que configures en el perfil.
  Responder
#20
[Imagen: IMG-3988.jpg]

[Imagen: IMG-3989.jpg]
(03-06-2021, 10:08 PM)Simemart escribió: Exactamente igual: conecta con la impresora, escribe el comando en el campo de texto de abajo a la derecha y envía con el botón Send.
Buenas, he probado con el comando como me indicas y ahora si que me aparece en la pantalla el ventilador al 50%.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Cambiar velocidad por defecto del extrusor en modo manual kokeeeeee 3 599 10-04-2020, 11:12 AM
Último mensaje: kokeeeeee
  CONSULTA Como configurar la velocidad manual de los ejes X e Y Cayo 0 388 22-03-2020, 11:48 AM
Último mensaje: Cayo
  APORTE Distinta velocidad entre capas Cura 4.3 Jose_3D 1 1,112 07-11-2019, 12:32 PM
Último mensaje: Jose_3D
  CONSULTA ventilador de capa cura 4.3.0 anet a8 abo182 3 1,329 05-11-2019, 09:07 PM
Último mensaje: abo182
  Ventilador de Capa arranca cuando "quiere"!! Ko2Power 0 477 28-08-2019, 11:36 AM
Último mensaje: Ko2Power