This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema eje Z. Ayuda por favor
#1
Buenos días. Este es mi primer mensaje. Estoy teniendo un problema importante para mover el eje z en mi Prusa steel: Resulta que hago la prueba de desplazamiento y en cada centímetro se me queda corto 3 mm. Haciendo una regla de tres y viendo que los pasos por Milímetros de ese eje que tengo en Marlyn son 2560, cambio a 4000 a través de Arduino. Cuando lo hago intento mover el eje z, los motores hacen un ruido extraño (pitido) Y no se inmutan, EXCEPTO cuando muevo los ejes desde el panel LCD que sí que se mueven lo que se deben de mover. Haciendo los cálculos con los drivers que tengo (Allegro 4988), He subido el voltaje a 1,15 para cada motor y en Ejes X e Y me van bien. todas las piezas que intento y cubos de calibración a esos pasos por milímetro me salen achatadas y, como máximo, los motores del eje z funcionan a 3200 pasos por mm (si subo, empiezan a pitar y vibrar). He intentado hacerlo con Cura y Pronter y tengo el mismo problema Agradecería que me pudieseis echar una mano. Gracias
  Responder
#2
Hola @ortegasoft, bienvenido al foro.
Si tu impresora tiene en el eje Z varillas roscadas M5 (diámetro 5 mm, paso 0,8 mm), con los A4988 configurados a 16 micropasos, el valor teórico para los micropasos por milímetro es 4000.
Cuando se utilizan varillas roscadas de rosca métrica y más si su diámetro es pequeño, la velocidad de desplazamiento está muy limitada debido a dos factores: por un lado se está obligando al firmware a enviar un gran número de micropasos para realizar un movimiento concreto y por otro, este tipo de rosca no está pensado para desplazamiento sino para apriete, por lo que tiende a bloquearse en lugar de deslizar.
Lo primero comprueba que el eje desliza con suavidad y engrasalos convenientemente, pues sino la tendencia al bloqueo será mayor.
En segundo lugar, comprueba la velocidad máxima que tienes configurada en el firmware para el eje Z, ya que no debe ser mayor de 3 mm/s para esas varillas.
  Responder
#3
Gracias por tu ayuda. Ha sido actualizar al Cura que acaba de salir ( creo que 4.5) y desaparecer el problema con los parámetros que tenía puestos, que exactamente coinciden con los que me has dicho. Ya se mueve razonablemente bien. Eso sí, debo lubricar los ejes. Seguiré informando. Gracias otra vez
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  AYUDA POR FAVOR !!! emanuel 1 195 22-03-2020, 06:37 PM
Último mensaje: Simemart
  CONSULTA error en impresion con ender3, ayuda por favor! mariaelisaluna 2 563 23-12-2019, 06:54 PM
Último mensaje: mariaelisaluna
Triste CONSULTA ruido raro no imprime, AYUDA por favor. neo1985 5 780 16-12-2019, 01:33 PM
Último mensaje: Lepes
  CONSULTA AYUDA POR FAVOR, CREO QUE HE ROTO MI IMPRESORA PRUSA I3, AYUDA POR FAVOR¡¡¡¡¡¡ _HEFESTO_ 2 696 21-09-2019, 06:21 PM
Último mensaje: Memo
  CONSULTA Una más del eje z. Altura ¿por que 0.2 y no 0? Estra 12 2,133 26-12-2018, 02:00 PM
Último mensaje: tthalatos