This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[Problema ] Configuración GRBL de CNC
#1
Buenas tardes chic@s!!!
Finalmente hoy he terminado de darle los últimos detalles a mi CNC, y me disponia hacerla funcionar, cuando...
ZAS!!!!!! PROBLEMAS!!!!!! jajajaja y estoy aquí a ver si me podéis echar una manita, los expertos...
Para poneros en situación...
Electrónica:
-Arduino UNO+CNC shield+drivers MD430
Las dimensiones externas de la maquina 1200x1200 y transmisiones mediante correas (eje z con husillo)

Problemas...
Ruido y vibraciones, nunca he visto una fresadora y no se que cantidad de ruido generan, por lo que no se si esta todo correcto...
Y en cuanto a electrónica, tiene instalado GRBL, con UGCS. 
El eje z no tiene finales de carrera, y creo que por eso que me salta error.
Podrias ayudarme, a ver como tengo que configurar todo el tema de los endstops, en cuanto a conexiones y configuracion para que me haga el homong automatico...
y si alguien tiene estos drivers, que me diga que configuracion tiene...
Muchas gracias a tod@s

[Imagen: 337ee1aa-d2fd-4578-9db1-b3b81219512c.jpg]

[Imagen: IMG-6138.jpg]

[Imagen: IMG-6137.jpg]
  Responder
#2
Hola, como estas?

Podrías subir un video para poder escuchar los ruidos,y por otro lado otro para ver la falla del homing? o explicarnos que problemas tienes con mayor detalle?
  Responder
#3
Buenas tardes
Muchas gracias por contestarme.
Voy a ampliar un poco la información, todo lo que pueda.
La maquina tiene instalados finales de carrera tanto en el eje X como en el eje Y, como normalmente cerrados.
El primer video que os muestro es al pulsar el botón de homing en UGCS, no se aprecia mucho, pero el eje X se mueve un poco hacia ambos lados, pero no llega a buscar el final de carrera, a la izquierda, que es donde debería de ir, o mejor dicho, donde quiero que vaya, sin embargo el eje Y si que lo hace todo correcto.
Os adjunto también una captura de pantalla de la modificación que hice en config.h



[Imagen: grbl-cap-2.png]

Antes de que nadie me asesine, decir que yo soy un novato en esto, perdonarme la vida.
Lo que estoy buscando, es por un lado eliminar el homing de z, ya que no tiene finales de carrera, porque voy a instalar una sonda. Y no quiero que me haga homing en z. Y por otro lado, que a la hora de hacer homing, primero me lo haga en x, hacia la izquierda, y una vez lo haya hecho, que me haga el homing en y.
Otro problema, que me he encontrado, es que si activo los finales de carrera como elemento de seguridad, para que si en algún momento, se me va de las manos y llega al final, que se pare la maquina, pero si los activo no me hace homing.
"En conclusión" estoy buscando poder usar los finales de carrera como elemento de seguridad, y para que me hagan homing, y que el homing solo me lo haga en x e y, pero no en z. Y no consigo configurar todo para que esto funcione como debe...
Adjunto una captura para que veáis la configuración actual de la maquina.

[Imagen: grbl-cap-1.png]

Con respecto al ruido, no se si me podéis aclarar algo... hace un ruido descomunal, en comparacion con las impresoras 3d que tengo. Pero lo que mas curioso me parece, es que cuando muevo los ejes, y se paran los motores (no siempre) se queda un pitido, que la virgen... se te mete hasta lo mas profundo del alma... y no se a que se debe. Adjunto otro video de movimientos al azar, para que veais el ruido que hace, aunque lo del pitido cuando se paran los motores, en este caso no han ocurrido.



Espero que con esto podáis ayudarme un poco mas, porque sino... voy a mandar a tomar por cleta la biciculo jajaja
Muchas gracias
Un saludo
  Responder
#4
No sé si van por ahí los tiros porque yo también soy nuevo en el tema y voy dando palazos de un lado para otro hasta que voy sacando cosas...

Si te fijas en la línea 104 del NotePad   te dice que es para un homing de maquina de 3 ejes.

Tal vez tengas que poner el "Define" que te dice a partir de la línea 111    (ya te digo que es suposición)

A lo mejor al escribirlo no se te vuelve loco el eje X y te anula el Z al tomarselo como máquina de 2 ejes (hablando de homing, claro)

Con el tema de los switchs que te funcionan raro... has probado a cambiar " $5=0  ?
  Responder
#5
El sonido creo que es por los drivers que usas. Yo usé esos (que creo que son TB6560) y los TB6600, después pasé a los DM542 y el cambio de sonido fué brutal
  Responder
#6
El sonido de los motores es normal. Si quieres algo mas suave, tendras que cambiar los drivers. Unos DM556 te pueden valer y son baratos.
-> Mi CNC de escritorio CNCDesktop 500 -> https://www.spainlabs.com/foros/tema-Fre...op-CNC-500
-> Laboratorio de Fabricación Digital Maker www.lowpower.io 
--> Twitter: https://twitter.com/Grafisoft_ES  | IG: https://www.instagram.com/lowpowerio/
  Responder
#7
Yo tampoco se mucho, pero las lineas que tengo yo comentadas son exactamente iguales que las que me dices, pero no se si la linea donde estén influirá, o si tiene que ver alguna linea anterior o posterior...
Y lo del $5 tiene que estar en 1 porque están en NC... entonces ahí en concreto no esta el fallo, o eso creo...
A ver si alguien puede aclarar mejor todo esto

Gracias por aclararme el tema del ruido, lo tendré en cuenta para próximas modificaciones... ya que si no es “preocupante” porque sea un fallo, pues estoy mas tranquilo, me aguantare y listo... Triste

Alguna aclaración o ayudita con respecto al tema del homing y los endstops!?
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Problemas con version grbl Pedriza 14 462 10-05-2021, 09:39 PM
Último mensaje: Pedriza
  Configuración driver mach3 TonyTren 2 238 10-05-2021, 07:45 AM
Último mensaje: TonyTren
  Configuracion 3018 esdrufao 2 1,122 18-02-2021, 03:38 PM
Último mensaje: Joseba1802
  CONSULTA Índice CNC para novatos, intentado reciclar motores para CNC lápiz katxarix 8 1,286 06-05-2020, 07:29 PM
Último mensaje: katxarix
  CONSULTA Problema con protocolo GRBL - ARDUINO UNO en plotter de corte mariano3082 12 3,143 28-02-2020, 07:28 PM
Último mensaje: Juanin