This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Motor extrusor !No para nunca!
#1
Muy buenas señores!

Pues bien tal y como dice el anunciado, al dar la orden al extrusor para que extruya una medida(1, 10 o 0.10 mm) empieza a moverse y no hay forma de pararlo, solo desconectando de la corriente la impresora.

Tengo el Firmware de Marlin 1.1.1 y lo he instalado dos veces, modificado parametros y sigue igual.

Tambíen he probado de intercambiar Pololus y motores, y todos los que se conectan al puerto del extrusor, les pasa lo mismo, extruyen sin parar.... Por lo tanto está descartado que sea el Motor.

Ayuda please... Estoy desesperado ya!!!

Gracias  todos
  Responder
#2
Hay dos opciones... o esta el puerto que controla los steps cascado (aunque dificil, pues que yo sepa para que el pololu haga avanzar al motor un paso se debe recibir un pulso... y hasta que cambia de estado no puede dar otro) o tienes un problema de configuracion en el firmware...

Prueba a instalar otra version de marlin, no vaya a tener un bug esa version y se te vuelva loco.

Por otro lado seria interesante que indicases como ke mandas el avance o retroceso a los motores... si desde el lcd de la impresora o desde el ordenador, puede ser un bug en el software o incluso podria ser que en el firmware tengas configurados unos pasos por mm del motor del extrusor demasiado altos y que al darle la orden de avanzar 1mm pues te intente avanzar mucho mas.
  Responder
#3
Muchas gracias Shellmer por tu rápida respuesta!!

Al final tuve que poner de nuevo el firmware y canvie de posición todos los drivers, y se arregló el problema  Nusenuse


Pero ahora me ha surgido una cosa muy curiosa, al realizar la extrusión de 10cm de filamento para realizar el cálculo de pasos por motor, siempre extruye la misma cantidad y eso que he ido cambiando de 1200 a 2830 que lo tengo ahora.

Alguien le ha pasado algo similar?

Gracias
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Motor del extrusor no gira chambrasoy 5 4,739 12-01-2021, 08:34 PM
Último mensaje: joseantoniio