This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Impresion columnas pequeñas
#1
Buenas a todos,
llevo algo mas de un año con una impresora modelo Vertex K8400 a la cual le he metido varias mejora (cama caliente, Hot-End E3D V6 y cambio ventilador de capa con su conducto). En terminos generales estoy muy contento con la calidad que me da pero tengo problemas para imprimir partes pequeñas del tipo columnas o pilares, por ejemplo en el barco benchy no soy capaz de imprimir la chimenea ya que se atasca. Adjunto foto donde estoy haciendo pruebas con la parte del techo y su chimenea:
[Imagen: 1610111231694.jpg]
La susodicha prueba del benchy me sale muy bien salvo la chimena. El software que utilizo es el Ultimaker Cura 4.8 y los ajustes son:
- Velocidad de impresion 30mm/sec tanto en relleno como en paredes
- Ventilador de capa 15%, no puedo poner mas ya que baja la temperatura del nozzle. El ventilador es de turbina y potente.
- Retraccion activada a 3mm y 125mm/sec. Mi maquina es bowden pero aun asi no meto mas distancia ya que desde E3D (marca Hotend) no recomiendan pasar de estos 3mm para sistemas bowden.
- Tiempo minimo de capa a 10 segundos
Con estos ajuste se atasca en la chimenea y hace el tipico ruido el extruso cuando atasca el filamento (clack clack). Probe a subir temperatura a 210º y mismo resultado. Si desactivo la extrusion hace lo mismo...
Lo cierto que ando un poco perdido en este problema, por mas cambios que hago no consigo que mejore.
  Responder
#2
juraria que el problema lo tienes con las retracciones,125mm/s es muchisimo,bajalo a unos 40 o 50 mm/s y haz la prueba a ver si con eso se soluciona,luego ya solo es cuestion de jugar con la distancia de retraccion.
  Responder
#3
Hola, en mi opinión tienes varios problemas al mismo tiempo, lo que puede que te dificulte el conseguir mejorar esa impresión solo variando un parámetro.
Sobre la retracción, decir que la recomendación de E3D de no pasar de 3 mm en Bowden supongo que se refiere a sus extrusores con barrel "all metal", en los que pasar de esa distancia implica casi con seguridad atasco.
Un extrusor con impulsor tipo Bowden y barrel con PTFE interior, que es lo más recomendable para PLA, normalmente necesita más de 3 mm de distancia de retracción para conseguir buenos resultados, naturalmente condicionado a la calidad del impulsor: yo utilizo este sistema y tengo configurada una distancia de 5mm.
Coincido con @titan83 en que esa velocidad de retracción de 125 mm/s es demasiado alta, pero casi con toda seguridad no se estará alcanzando, pues tendrás configurada en el firmware una velocidad máxima para el eje E muy inferior, muy posiblemente por debajo de la que sería recomendable configurar en la retracción: yo utilizo 90 mm/s, pero tengo un impulsor con reductora que lo aguanta todo.
Lo primero que tendrás que hacer es comprobar la velocidad máxima que tienes en el firmware para el eje E y adecuarla a la que configures en la retracción, que con 50-70 mm/s debería darte buenos resultados.
Sobre el ventiador de capa, no conseguirás buenos resultados en piezas pequeñas y voladizos si no puedes pasar de esa velocidad: tendrás que orientar mejor la tobera de salida de aire, para que no incida el chorro directamente sobre el cubo calentador o colocar una funda de silicona en él, de forma que puedas activar el ventilador de capa a su máxima velocidad.
Por otra parte, las piezas pequeñas y sobre todo si son circulares, necesitan de una mecánica bien afinada y de una configuración precisa de las aceleraciones/jerk/JD para que el movimiento sea lo suficientemente preciso: en piezas grandes se disimulan más los defectos en estos apartados.
Bajando la velocidad se amortiguan algo estos efectos, pero no se llega a conseguir del todo eliminarlos.
  Responder
#4
Buenos días una pregunta alguien sabe si el cura ultimaker funciona en algún surface de Microsoft gracias
  Responder
#5
hola necesito ayuda con mi impresora 3d es una anat a8 y no me sale filamento cuando mando a imprimir.
 pero si apretó el botón y empujo el filamento sale, pero por si sola no sale aun no logro imprimir nada.
por favor alguien que me ayude.
  Responder
#6
Hola @Bruno881 y @joseantoniio, bienvenidos al foro.
No es una buena práctica introducir preguntas en un post, cuando no están relacionadas con el tema de que trata dicho post, ya que las posibles constestaciones a ellas no las podrán encontrar otros usuarios con el mismo problema, pues no aparecerá relacionado en el título del post.
Lo más correcto es crear un tema nuevo, como ya ha hecho @joseantoniio, donde le dejo mi respuesta.
  Responder
#7
(09-01-2021, 11:46 AM)titan83 escribió: juraria que el problema lo tienes con las retracciones,125mm/s es muchisimo,bajalo a unos 40 o 50 mm/s y haz la prueba a ver si con eso se soluciona,luego ya solo es cuestion de jugar con la distancia de retraccion.
Gracias por la contestación, he probado lo que me dices bajando a 60mm/s y he podido imprimir 3 piezas como las de la foto sin incidencias... No obstante seguiré probandolo ya que no me fio, he impreso un test y me ha producido algun fallo: primera prueba del test atasco en la primera de cuatro horas, y en la segunda adjunto la foto mas abajo donde se ve que vuelve a atascar en la parte mas alta de la pieza.

(09-01-2021, 12:56 PM)Simemart escribió: Hola, en mi opinión tienes varios problemas al mismo tiempo, lo que puede que te dificulte el conseguir mejorar esa impresión solo variando un parámetro.
Sobre la retracción, decir que la recomendación de E3D de no pasar de 3 mm en Bowden supongo que se refiere a sus extrusores con barrel "all metal", en los que pasar de esa distancia implica casi con seguridad atasco.
Un extrusor con impulsor tipo Bowden y barrel con PTFE interior, que es lo más recomendable para PLA, normalmente necesita más de 3 mm de distancia de retracción para conseguir buenos resultados, naturalmente condicionado a la calidad del impulsor: yo utilizo este sistema y tengo configurada una distancia de 5mm.
Coincido con @titan83 en que esa velocidad de retracción de 125 mm/s es demasiado alta, pero casi con toda seguridad no se estará alcanzando, pues tendrás configurada en el firmware una velocidad máxima para el eje E muy inferior, muy posiblemente por debajo de la que sería recomendable configurar en la retracción: yo utilizo 90 mm/s, pero tengo un impulsor con reductora que lo aguanta todo.
Lo primero que tendrás que hacer es comprobar la velocidad máxima que tienes en el firmware para el eje E y adecuarla a la que configures en la retracción, que con 50-70 mm/s debería darte buenos resultados.
Sobre el ventiador de capa, no conseguirás buenos resultados en piezas pequeñas y voladizos si no puedes pasar de esa velocidad: tendrás que orientar mejor la tobera de salida de aire, para que no incida el chorro directamente sobre el cubo calentador o colocar una funda de silicona en él, de forma que puedas activar el ventilador de capa a su máxima velocidad.
Por otra parte, las piezas pequeñas y sobre todo si son circulares, necesitan de una mecánica bien afinada y de una configuración precisa de las aceleraciones/jerk/JD para que el movimiento sea lo suficientemente preciso: en piezas grandes se disimulan más los defectos en estos apartados.
Bajando la velocidad se amortiguan algo estos efectos, pero no se llega a conseguir del todo eliminarlos.
De nuevo gracias por la contestacion.
Efectivamente tengo un hotend all-metal de E3d (V6), este hotend no aconsejan pasar de 3mm en la retraccion. He comprobado la linea de firmware y no llegaba a la velocidad que yo le indicabaen Cura, la linea es la siguiente (o eso creo):
#define DEFAULT_RETRACT_ACCELERATION  6000   -->  Entiendo que el limite para Cura es de 100mm/sec?

El caso es que he bajado la velocidad de retraccion a 60mm/s y, aunque he impreso tres piezas con la chimenea correctamente, en otra prueba que he hecho me ha vuelto a atascar igualmente, es decir, al imprimir una parte pequeña se ha vuelto a atascar, de todas maneras creo que ha habido una mejora.
[Imagen: foto.jpg]
Probaré mas impresiones para ver el funcionamiento, me da la sensacion que fallara aleatoriamente. Por cierto la velocidad de impresion la tengo a 205º. El nozzle ya lo tengo cubierto de la funda silicona para estabilizar la temperatura de impresion pero aun así no puedo pasar del 15% de potencia, a partir de este valor el ventilado de capa me baja la temperatura del nozzle. El duct del ventilador lo diseñe yo para que enfocara directo a 4mm por debajo de la punta del nozzle, el diseño genera mucho flujo a la parte que se esta imprimiendo ya que los conductos de salida son relativamente estrechos. Adjunto el archivo.

.zip   pieza.zip (Tamaño: 130.08 KB / Descargas: 0)

No puedo pasar del 15% de flujo de aire pero el acabado de piezas relativamente faciles es perfecto o por lo menos para mí , solo me falla en partes pequeñas que se produce el atasco. Por cierto, hay un dato importante para este porcentaje de flujo, mi impresora funciona con una fuente de salida 15v, ni 12 ni 24, y el ventilador de capa es de 12v por lo que a 100%  estarian entrando los 15v y seria un 25% mas de la su tension de funcionamiento.
¿Me merece la pena hacer mas pruebas reduciendo la velocidad de retraccion? si le bajo la velocidad, afectará a la calidad me imagino??
Espero mañana poder imprimir el barco Benchy para adjunta prueba de impresion
  Responder
#8
La velocidad máxima de los ejes se fija en el parámetro DEFAULT_MAX_FEEDRATE: en concreto, la del extrusor es el último valor de la matriz.
El que indicas es la aceleración de retracción, que también tiene un valor máximo que se configura en el parámetro DEFAULT_MAX_ACCELERATION (también el último valor de la matriz) y esos 6000 son mm/s² (en mi opinión algo elevada esa cifra).
Si no pasas del 15% en el ventilador, da igual que la fuente que utilices sea de 15V, pues le estará llegando una fracción muy pequeña de ellos, aunque lo lógico es que configures los límites del PWM (que es el que regula la salida de voltaje hacia el ventilador) de forma que al 100% solo le lleguen los 12V para los que está fabricado.
Dicha configuración se realiza en el parámetro FAN_MAX_PWM, que se encuentra en el archivo Configuration_adv.h. En tu caso, deberías descomentar la línea donde se encuentra y darle el valor 204.
Dado que, si no estoy equivocado, la impresora viene de fábrica con esa fuente de 15V, debería traer los elementos adecuados a dicho voltaje, pues sino es una chapuza bastante importante del fabricante. ¿Has cambiado tú el ventilador o es el original?
Porque el voltaje de la fuente no solo afecta a los ventiladores, sino a todos los elementos que funcionan con él, como los calentadores (por ejemplo) y si no son adecuados para esa alimentación, se pone en riesgo su integridad y su vida útil.
Como información, también es posible modificar la potencia del PWM que los controla, aunque en el caso de hacerlo para la cama, esta pasa a controlarse por PID obligatoriamente: para el hotend se define en el parámetro PID_MAX y para la cama en el parámetro MAX_BED_POWER, ambos en el archivo Configuration.h.
Hay que tener en cuenta que la potencia disipada en todos esos elementos no aumenta el 25% como el voltaje y por tanto la intensidad, sino más de un 56%, ya que aquella es directamente proporcional al cuadrado de la intensidad.
La velocidad de retracción la puedes bajar hasta que empieces a tener problemas de hilos en las piezas, pues supongo que preferirás no tenerlos, pero no acabo de ver la relación con el problema de impresión de piezas pequeñas, a no ser que tengas configurado que te haga retracciones contínuamente, bien por una distancia mínima para hacerlas demasiado pequeña o por tener activada la retracción en el cambio de capa.
  Responder
#9
Perdón soy nuevo y estoy perdido en el foro 


(12-01-2021, 12:47 AM)Simemart escribió: Hola @Bruno881 y @joseantoniio, bienvenidos al foro.
No es una buena práctica introducir preguntas en un post, cuando no están relacionadas con el tema de que trata dicho post, ya que las posibles constestaciones a ellas no las podrán encontrar otros usuarios con el mismo problema, pues no aparecerá relacionado en el título del post.
Lo más correcto es crear un tema nuevo, como ya ha hecho @joseantoniio, donde le dejo mi respuesta.
  Responder
#10
No hay nada que perdonar, todos hemos sido novatos en el foro, te lo he indicado precisamente para que vayas viendo como funciona.
Lo mejor para recibir una contestación lo más rápida posible, es crear un tema nuevo dentro del subforo cuya temática se aproxime más al asunto que trate la pregunta, que tenga un título suficientemente descriptivo y en el que expliques claramente el problema, dando la mayor información posible sobre él.
La Zona impresoras 3D es un buen punto de entrada al foro, donde tienes todos los subforos relacionados con la impresión 3D: para crear un tema nuevo, solo tienes que entrar en el que consideres oportuno y utilizar el botón Publicar tema, que se encuentra arriba a la derecha en la página.
  Responder
#11
(12-01-2021, 01:59 AM)Simemart escribió: La velocidad máxima de los ejes se fija en el parámetro DEFAULT_MAX_FEEDRATE: en concreto, la del extrusor es el último valor de la matriz.
El que indicas es la aceleración de retracción, que también tiene un valor máximo que se configura en el parámetro DEFAULT_MAX_ACCELERATION (también el último valor de la matriz) y esos 6000 son mm/s² (en mi opinión algo elevada esa cifra).
Si no pasas del 15% en el ventilador, da igual que la fuente que utilices sea de 15V, pues le estará llegando una fracción muy pequeña de ellos, aunque lo lógico es que configures los límites del PWM (que es el que regula la salida de voltaje hacia el ventilador) de forma que al 100% solo le lleguen los 12V para los que está fabricado.
Dicha configuración se realiza en el parámetro FAN_MAX_PWM, que se encuentra en el archivo Configuration_adv.h. En tu caso, deberías descomentar la línea donde se encuentra y darle el valor 204.
Dado que, si no estoy equivocado, la impresora viene de fábrica con esa fuente de 15V, debería traer los elementos adecuados a dicho voltaje, pues sino es una chapuza bastante importante del fabricante. ¿Has cambiado tú el ventilador o es el original?
Porque el voltaje de la fuente no solo afecta a los ventiladores, sino a todos los elementos que funcionan con él, como los calentadores (por ejemplo) y si no son adecuados para esa alimentación, se pone en riesgo su integridad y su vida útil.
Como información, también es posible modificar la potencia del PWM que los controla, aunque en el caso de hacerlo para la cama, esta pasa a controlarse por PID obligatoriamente: para el hotend se define en el parámetro PID_MAX y para la cama en el parámetro MAX_BED_POWER, ambos en el archivo Configuration.h.
Hay que tener en cuenta que la potencia disipada en todos esos elementos no aumenta el 25% como el voltaje y por tanto la intensidad, sino más de un 56%, ya que aquella es directamente proporcional al cuadrado de la intensidad.
La velocidad de retracción la puedes bajar hasta que empieces a tener problemas de hilos en las piezas, pues supongo que preferirás no tenerlos, pero no acabo de ver la relación con el problema de impresión de piezas pequeñas, a no ser que tengas configurado que te haga retracciones contínuamente, bien por una distancia mínima para hacerlas demasiado pequeña o por tener activada la retracción en el cambio de capa.

Te indico lo que pone en mi firm:
#define DEFAULT_AXIS_STEPS_PER_UNIT  {134.74,134.74,4266.66,149.1}
#define DEFAULT_MAX_FEEDRATE          {160, 160, 10, 10000}   
#define DEFAULT_MAX_ACCELERATION      {9000,9000,100,10000}    
#define DEFAULT_ACCELERATION          6000  
#define DEFAULT_RETRACT_ACCELERATION  6000

Respecto el ajuste Fan_Max_PWM no existe en los archivos que cargo de mi firm pero esta la siguiente linea:
#define CONTROLLERFAN_SPEED 255  // == full speed
De todas maneras puedo cambiar el diseño del duct para que no tenga una salida de aire tan estrecha y asi poder dar mas potencia al Fan

El tema de la fuente de 15v es porque de fabrica venia con esta, el calentador del hotend es tambien de fabrica para esos 15v. La cama caliente es una customizacion mia que funciona con una fuente adicional de 24v. El termistor lo tuve que cambiar por el sirve para el E3D V6 AllMetal y lo cambie en el firm.

La retraccion la tengo activada con los ajustes:
- Distancia 3mm
- Velocidad 60 mm/s
- Retractium minium layer 0.8

Temperatura: 205º

He vuelto a imprimir el barco Benchy y sigue atascando la chimenea, adjunto foto:
[Imagen: IMG-20210112-WA0007.jpg]

La verdad que estoy un poco perdido en este fallo...
  Responder
#12
Si el Marlin que tiene instalado la impresora no tiene el parámetro FAN_MAX_PWM,como muy moderna será la versión 1.1.8, lo que te está privando de las importantes mejoras que incorporan las últimas versiones.
El parámetro que indicas (CONTROLLERFAN_SPEED) es para controlar un ventilador que refrigere los drivers y que se activa cuando funcionan los motores.
Sobre la configuración que tienes, la velocidad del extrusor está sin límite, pues la máxima está fijada en 10000 mm/s, lo que parece un error de dos ceros de más.
Por otro lado, las aceleraciones que tienes configuradas vuelvo a repetir que me parecen excesivas.
Sobre la retracción, la distancia mínima de desplazamiento para realizarla de 0,8 mm no tiene mucho sentido y hace que te haga retracciones casi de forma continua.
No indicas si tienes activada la retracción entre capas, cosa que podría influir de forma clara en el problema que estás teniendo, como también si tienes activada la retracción antes de la pared exterior. También sería importante saber que Jerk tienes configurado, dadas las aceleraciones tan altas que tienes.
Mi recomendación es que, en cuanto puedas, te pases a la última versión de Marlin (de Marlin1 o de Marlin2, eso como prefieras), que configures las aceleraciones a 1000 mm/s, que configures en CURA el Retracction Minimun Travel (no Layer) en 3 mm y que desactives Retract at layer change y Retract Before Outer Wall (si es que las tienes activadas).
  Responder
#13
Me da respeto actualizar el firmware ya que el fabricante no lo facilita, ultima version Nov 2017. Lo unico que me dice el fabricante Vertex es:   Controller board: AVR ATmega2560 based.
Con esta placa podria actualizar a la version 2??? Ya se que tendria que adaptar los parametros a mi impresora pero teniendo el firmware original me puede servir de guia.

En la ultima impresion del Benchy he probado los ajustes que me dice:
- Retraccion activada
- Distancia 3mm
- Velocidad 40mm
- Retraction minium travel 3mm
- no tengo activado la retraccion en cambio de capa ni antes de imprimir perimetro.
El resultado es igual de malo, en las partes estrechas se vuelve a atascar:
[Imagen: foto2.jpg]

La proxima prueba la voy a hacer desactivando la retraccion para comprobar el resultado, aparecera oozing pero quiero comprobar si no atasca...
  Responder
#14
La mayor dificultad que se te puede presentar a la hora de actualizar el firmware es que la placa sea "rara", por lo que no esté soportada por Marlin (no tenga por tanto archivo de pins) y que el firmware que tráe de fábrica, aunque basado en él, sea una adaptación hecha a medida para esa máquina concreta: si pones una foto de ella quizá saldríamos de dudas.
En todo caso, teniendo los archivos del Marlin original, no debería ser difícil configurar Marlin 2 a partir de ellos, pero es probable que solo con ese cambio no se solucione el problema de impresión que estás teniendo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Pequeñas marcas en el exterior de las piezas Mako 2 65 13-01-2021, 08:45 AM
Último mensaje: Mako
  Prusa I3 imprime con pequeñas micro-pausas titanium 6 997 27-01-2020, 07:25 AM
Último mensaje: robotel2018
  Problemas con piezas pequeñas pio_crespo 4 2,135 29-08-2018, 09:07 AM
Último mensaje: buratatxo
  Problema con piezas pequeñas. Duda para expertos xlj0003 5 1,795 10-11-2016, 09:55 AM
Último mensaje: Lepes
  Pequeñas lineas y gotitas en las esquinas al imprimir decker 5 1,581 25-07-2016, 11:45 PM
Último mensaje: decker