This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA No homing en eje Z
#1
Buenas tardes , antes que nada me disculpo si está no es la sección donde debo publicar esto , ya que soy nuevo por acá .
Bueno , les comento , hace un tiempo tengo una impresora , del tipo prusa i3 , hace unos días la desarme completa para limpiar y ajustar todo , la.cosa es que al volverla a ensamblar y cargar marlin 1.1.9 la impresora no hace el homing en z , solamente sube y baja unos 5 centimetros y marca como si lo hubiese hecho , y en los otros dos ejes funciona perfectamente .Probe bajando las aceleraciones y las velocidades , testee los endstops con M119 y funcionan correctamente , ambos motores también funcionan correctamente , hasta probé cambiar el Arduino y las ramps y sigue haciendo lo mismo , la verdad me tiene perdido , al mover el eje funciona perfecto , el problema es en el Home.
Gracias
  Responder
#2
Hola @Mateoricch, bienvenido al foro.
En lo único que puede ser diferente el homing de cualquier otro movimiento es en la velocidad con que se realice. Si los motores se mueven y funcionan bien los finales de carrera, el problema tiene que ser de tipo mecánico, por lo que cambiar al azar cosas no te va a solucionar el problema.
Ya que indicas que has desmontado y vuelto a montar la impresora recientemente, todo apunta a que no ha quedado bien el eje Z y no desliza como debería.
Si no están bien montados los elementos de ese eje, puede moverse con algo más de resistencia de lo normal y si la velocidad programada para el homing es más alta que las de otros movimientos, atascarse durante el mismo.
No indicas que tipo de arrastre tiene en ese eje, si husillos o varillas roscadas. Estas últimas son muy sensibles a la velocidad, atascándose con facilidad.
Revisa bien dicho eje, comprobando que se mueva de forma suave al girar con la mano los elementos de arrastre que utilice tu impresora. Quizá también debas engrasarlos un poco.
  Responder
#3
Hola @Simemart ante todo muchas gracias por la rápida respuesta, revise todo firmware y hardware míl veces y no encontraba la solución , me tenía loco.Pero al fin encontré el problema , resulta ser que los 4 cables del motor y los 2 del endstop viajan juntos y son bastante largos , ahora cuando el motor se mueve solo , osea sin el homing todo bien , pero cuando le doy a hacer homing la alta frecuencia de los cables mete un ruido asqueroso al endstop lo que hace que lo detecte cómo pulsado , lo solucione metiéndole un capacitor a la entrada del endstop para filtrar el ruido y funciona perfectamente.
  Responder
#4
No creo recordar que se hayan reportado nunca interferencias en los finales de carrera por ese motivo o yo no le he visto.
Gracias por compartir la solución al problema.
Un saludo.
  Responder
#5
Hola Mateoricch tuve el mismo problema que mencionas pero con un sensor inductor Lj18a3-8-z, tambien revise el firmware y hardware muchas veces y probé en distintas versiones de Marlin el resultado siempre era el mismo, el eje z funciona bien pero al momento de hacer homing el eje z se detenia como si este fuera pulsado.

agradeceria si pudieras mencionarme que valor de capacitor agregaste y como lo conectaste.

Saludos
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Marlin 1.1.9 homing failed Agh_23 10 3,077 26-05-2020, 04:56 PM
Último mensaje: gma_alonso
  Problema al hacer Homing tras subir a Marlin 2.0 fruns 9 1,171 24-04-2020, 08:33 AM
Último mensaje: Ovt
  Homing Marlin cnc Tomaste 1 582 29-12-2019, 06:52 PM
Último mensaje: Simemart
  Eje Z invertido al hacer homing + sensor de autolevel + Marlin 1.1.9 pepebky 7 3,462 18-10-2018, 08:25 PM
Último mensaje: Simemart
  CONSULTA Problema de homing Heberto Vallaud 3 960 27-07-2018, 02:03 PM
Último mensaje: Heberto Vallaud